Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200904-01 ] Openfire: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Thu Apr 02, 2009 9:26 pm    Post subject: [ GLSA 200904-01 ] Openfire: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Openfire: Multiple vulnerabilities (GLSA 200904-01)
Severity: normal
Exploitable: remote
Date: April 02, 2009
Bug(s): #246008, #254309
ID: 200904-01

Synopsis

Multiple vulnerabilities were discovered in Openfire, the worst of which may allow remote execution of arbitrary code.

Background

Ignite Realtime Openfire is a fast real-time collaboration server.

Affected Packages

Package: net-im/openfire
Vulnerable: < 3.6.3
Unaffected: >= 3.6.3
Architectures: All supported architectures


Description

Two vulnerabilities have been reported by Federico Muttis, from CORE IMPACT's Exploit Writing Team:
  • Multiple missing or incomplete input validations in several .jsps (CVE-2009-0496).
  • Incorrect input validation of the "log" parameter in log.jsp (CVE-2009-0497).
Multiple vulnerabilities have been reported by Andreas Kurtz:
  • Erroneous built-in exceptions to input validation in login.jsp (CVE-2008-6508).
  • Unsanitized user input to the "type" parameter in sipark-log-summary.jsp used in SQL statement. (CVE-2008-6509)
  • A Cross-Site-Scripting vulnerability due to unsanitized input to the "url" parameter. (CVE-2008-6510, CVE-2008-6511)


Impact

A remote attacker could execute arbitrary code on clients' systems by uploading a specially crafted plugin, bypassing authentication. Additionally, an attacker could read arbitrary files on the server or execute arbitrary SQL statements. Depending on the server's configuration the attacker might also execute code on the server via an SQL injection.

Workaround

There is no known workaround at this time.

Resolution

All Openfire users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-im/openfire-3.6.3"


References

CVE-2008-6508
CVE-2008-6509
CVE-2008-6510
CVE-2008-6511
CVE-2009-0496
CVE-2009-0497
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum