Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200903-37 ] Ghostscript: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Tue Mar 24, 2009 12:26 am    Post subject: [ GLSA 200903-37 ] Ghostscript: User-assisted execution of a Reply with quote

Gentoo Linux Security Advisory

Title: Ghostscript: User-assisted execution of arbitrary code (GLSA 200903-37)
Severity: normal
Exploitable: remote
Date: March 23, 2009
Bug(s): #261087
ID: 200903-37

Synopsis

Multiple integer overflows in the Ghostscript ICC library might allow for user-assisted execution of arbitrary code.

Background

Ghostscript is an interpreter for the PostScript language and the Portable Document Format (PDF).

Affected Packages

Package: app-text/ghostscript-gpl
Vulnerable: < 8.64-r2
Unaffected: >= 8.64-r2
Architectures: All supported architectures

Package: app-text/ghostscript-gnu
Vulnerable: < 8.62.0
Unaffected: >= 8.62.0
Architectures: All supported architectures

Package: app-text/ghostscript-esp
Vulnerable: <= 8.15.4-r1
Architectures: All supported architectures


Description

Jan Lieskovsky from the Red Hat Security Response Team discovered the following vulnerabilities in Ghostscript's ICC Library:
  • Multiple integer overflows (CVE-2009-0583).
  • Multiple insufficient bounds checks on certain variable sizes (CVE-2009-0584).


Impact

A remote attacker could entice a user to open a specially crafted PostScript file containing images and a malicious ICC profile, possibly resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All GPL Ghostscript users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.64-r2"
All GNU Ghostscript users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.62.0"
We recommend that users unmerge ESP Ghostscript and use GPL or GNU Ghostscript instead:
Code:
# emerge --unmerge "app-text/ghostscript-esp"
For installation instructions, see above.

References

CVE-2009-0583
CVE-2009-0584
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum