Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200903-33 ] FFmpeg: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Thu Mar 19, 2009 11:26 pm    Post subject: [ GLSA 200903-33 ] FFmpeg: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: FFmpeg: Multiple vulnerabilities (GLSA 200903-33)
Severity: normal
Exploitable: remote
Date: March 19, 2009
Bug(s): #231831, #231834, #245313, #257217, #257381
ID: 200903-33

Synopsis

Multiple vulnerabilities in FFmpeg may lead to the remote execution of arbitrary code or a Denial of Service.

Background

FFmpeg is a complete solution to record, convert and stream audio and video. gst-plugins-ffmpeg is a FFmpeg based gstreamer plugin which includes a vulnerable copy of FFmpeg code. Mplayer is a multimedia player which also includes a vulnerable copy of the code.

Affected Packages

Package: media-video/ffmpeg
Vulnerable: < 0.4.9_p20090201
Unaffected: >= 0.4.9_p20090201
Architectures: All supported architectures

Package: media-plugins/gst-plugins-ffmpeg
Vulnerable: < 0.10.5
Unaffected: >= 0.10.5
Architectures: All supported architectures

Package: media-video/mplayer
Vulnerable: < 1.0_rc2_p28450
Unaffected: >= 1.0_rc2_p28450
Architectures: All supported architectures


Description

Multiple vulnerabilities were found in FFmpeg:
  • astrange reported a stack-based buffer overflow in the str_read_packet() in libavformat/psxstr.c when processing .str files (CVE-2008-3162).
  • Multiple buffer overflows in libavformat/utils.c (CVE-2008-4866).
  • A buffer overflow in libavcodec/dca.c (CVE-2008-4867).
  • An unspecified vulnerability in the avcodec_close() function in libavcodec/utils.c (CVE-2008-4868).
  • Unspecified memory leaks (CVE-2008-4869).
  • Tobias Klein repoerted a NULL pointer dereference due to an integer signedness error in the fourxm_read_header() function in libavformat/4xm.c (CVE-2009-0385).


Impact

A remote attacker could entice a user to open a specially crafted media file, possibly leading to the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All FFmpeg users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/ffmpeg-0.4.9_p20090201"
All gst-plugins-ffmpeg users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-plugins/gst-plugins-ffmpeg-0.10.5"
All Mplayer users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/mplayer-1.0_rc2_p28450"


References

[url=http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3162 ]CVE-2008-3162[/url]
CVE-2008-4866
CVE-2008-4867
CVE-2008-4868
CVE-2008-4869
CVE-2009-0385
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum