Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Eject] No elimina sdb (abierto)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
pcmaster
Advocate
Advocate


Joined: 04 Dec 2003
Posts: 2020
Location: Barcelona

PostPosted: Sun Mar 22, 2009 11:03 am    Post subject: [Eject] No elimina sdb (abierto) Reply with quote

Hola a todos,

He observado que me pasa algo curioso: cuando inserto un pendrive, xfce4 me muestra en el escritorio un icono para cada partición, puedo montarlas, desmontarlas, etc. y acceder correctamente a ellas.

Pero, si en vez de realizar un umount (o desmontar la partición con el botón derecho del ratón sobre el icono del escritorio) abro una ventana de consola y hago un eject de /dev/sdb, las particiones (/dev/sdb1, etc) desaparecen de /dev, pero /dev/sdb sigue presente. El LED del pendrive tampoco se apaga.

Code:
localhost linux # ls /dev/sd* -l
brw-r----- 1 root disk 8,  0 mar 22 11:43 /dev/sda
brw-r----- 1 root disk 8,  1 mar 22 11:43 /dev/sda1
brw-r----- 1 root disk 8,  2 mar 22 11:43 /dev/sda2
brw-r----- 1 root disk 8,  3 mar 22 11:43 /dev/sda3
brw-r----- 1 root disk 8,  5 mar 22 11:43 /dev/sda5
brw-r----- 1 root disk 8,  6 mar 22 11:43 /dev/sda6
brw-r----- 1 root disk 8,  7 mar 22 11:43 /dev/sda7
brw-r----- 1 root disk 8, 16 mar 22 11:55 /dev/sdb
brw-r----- 1 root disk 8, 17 mar 22 11:55 /dev/sdb1
brw-r----- 1 root disk 8, 20 mar 22 11:55 /dev/sdb4
localhost linux # eject /dev/sdb
localhost linux # ls /dev/sd* -l
brw-r----- 1 root disk 8,  0 mar 22 11:43 /dev/sda
brw-r----- 1 root disk 8,  1 mar 22 11:43 /dev/sda1
brw-r----- 1 root disk 8,  2 mar 22 11:43 /dev/sda2
brw-r----- 1 root disk 8,  3 mar 22 11:43 /dev/sda3
brw-r----- 1 root disk 8,  5 mar 22 11:43 /dev/sda5
brw-r----- 1 root disk 8,  6 mar 22 11:43 /dev/sda6
brw-r----- 1 root disk 8,  7 mar 22 11:43 /dev/sda7
brw-r----- 1 root disk 8, 16 mar 22 11:55 /dev/sdb
localhost linux #


Recuerdo que hace tiempo sí que desaparecían todos los archivos de dispositivo (incluído /dev/sdb) y además se apagaba el LED. Sospecho que es cosa del kernel ¿A alguien le ha pasado lo mismo? Actualmente tengo instalado gentoo-sources-2.6.27-gentoo-r8 (última versión estable).

Gracias
_________________
pcmaster
Back to top
View user's profile Send private message
Inodoro_Pereyra
Advocate
Advocate


Joined: 03 Nov 2006
Posts: 2631
Location: En la otra punta del cable

PostPosted: Sun Mar 22, 2009 3:22 pm    Post subject: Reply with quote

No me ha pasado nunca, pero no uso eject para nada. De hecho nunca desmonto un pendrive para desconectarlo (en linux).

Todas esas memorias flash USB se pueden llegar a romper si son desconectadas durante operaciones de escritura. El resto del tiempo puede uno enchufarlas y desenchufarlas las veces que haga falta sin peligro.

En windows uno nunca tiene el control sobre lo que se escribe sobre el dispositivo, con tanto antivirus, antispyware, system_volume_information, recycled y thumbs.db, el usuario nunca sabe y por eso hay que andar desmontando las cosas antes de desenchufalras.

En linux? (Y sobre todo en Gentoo) Lo único que hago antes de desenchufar un pendrive es ejecutar sync por las dudas que quedara algo por copiar. Con lo único que hay que tener cuidado es con los thumbnailers de los administradores de archivos. El resto del tiempo, si no escribiste nada, desenchufa el pendrive sin miedo, *con led de estado encendido y todo* que no hay peligro.

Salud!
_________________
Mi Blog.

Si no fuera por C, estaríamos escribiendo programas en BASI, PASAL y OBOL.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum