Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200903-28 ] libpng: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Sun Mar 15, 2009 7:26 pm    Post subject: [ GLSA 200903-28 ] libpng: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libpng: Multiple vulnerabilities (GLSA 200903-28)
Severity: normal
Exploitable: remote
Date: March 15, 2009
Bug(s): #244808, #255231, #259578
ID: 200903-28

Synopsis

Multiple vulnerabilities were found in libpng, which might result in the execution of arbitrary code

Background

libpng is the official PNG reference library used to read, write and manipulate PNG images.

Affected Packages

Package: media-libs/libpng
Vulnerable: < 1.2.35
Unaffected: >= 1.2.35
Architectures: All supported architectures


Description

Multiple vulnerabilities were discovered in libpng:
  • A memory leak bug was reported in png_handle_tEXt(), a function that is used while reading PNG images (CVE-2008-6218).
  • A memory overwrite bug was reported by Jon Foster in png_check_keyword(), caused by writing overlong keywords to a PNG file (CVE-2008-5907).
  • A memory corruption issue, caused by an incorrect handling of an out of memory condition has been reported by Tavis Ormandy of the Google Security Team. That vulnerability affects direct uses of png_read_png(), pCAL chunk and 16-bit gamma table handling (CVE-2009-0040).


Impact

A remote attacker may execute arbitrary code with the privileges of the user opening a specially crafted PNG file by exploiting the erroneous out-of-memory handling. An attacker may also exploit the png_check_keyword() error to set arbitrary memory locations to 0, if the application allows overlong, user-controlled keywords when writing PNG files. The png_handle_tEXT() vulnerability may be exploited by an attacker to potentially consume all memory on a users system when a specially crafted PNG file is opened.

Workaround

There is no known workaround at this time.

Resolution

All libpng users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.35"


References

CVE-2008-5907
CVE-2008-6218
CVE-2009-0040
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum