Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200903-07 ] Samba: Data disclosure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1612

PostPosted: Sat Mar 07, 2009 7:26 pm    Post subject: [ GLSA 200903-07 ] Samba: Data disclosure Reply with quote

Gentoo Linux Security Advisory

Title: Samba: Data disclosure (GLSA 200903-07)
Severity: normal
Exploitable: remote
Date: March 07, 2009
Bug(s): #247620
ID: 200903-07

Synopsis

A missing boundary check in Samba might lead to the disclosure of memory contents.

Background

Samba is a suite of SMB and CIFS client/server programs.

Affected Packages

Package: net-fs/samba
Vulnerable: < 3.0.33
Unaffected: >= 3.0.33
Architectures: All supported architectures


Description

Samba does not properly check memory boundaries when handling trans, rans2, and nttrans requests.

Impact

A remote attacker could send specially crafted requests to a Samba daemon, leading to the disclosure of arbitrary memory or to a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Samba users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-fs/samba-3.0.33"


References

CVE-2008-4314
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum