Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200902-06 ] GNU Emacs, XEmacs: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1569

PostPosted: Mon Feb 23, 2009 11:26 pm    Post subject: [ GLSA 200902-06 ] GNU Emacs, XEmacs: Multiple vulnerabiliti Reply with quote

Gentoo Linux Security Advisory

Title: GNU Emacs, XEmacs: Multiple vulnerabilities (GLSA 200902-06)
Severity: normal
Exploitable: remote
Date: February 23, 2009
Bug(s): #221197, #236498
ID: 200902-06

Synopsis

Two vulnerabilities were found in GNU Emacs, possibly leading to user-assisted execution of arbitrary code. One also affects edit-utils in XEmacs.

Background

GNU Emacs and XEmacs are highly extensible and customizable text editors. edit-utils are miscellaneous extensions to XEmacs.

Affected Packages

Package: app-editors/emacs
Vulnerable: < 22.2-r3
Unaffected: >= 22.2-r3
Unaffected: >= 21.4-r17 < 21.5
Unaffected: < 19
Architectures: All supported architectures

Package: app-xemacs/edit-utils
Vulnerable: < 2.39
Unaffected: >= 2.39
Architectures: All supported architectures


Description

Morten Welinder reports about GNU Emacs and edit-utils in XEmacs: By shipping a .flc accompanying a source file (.c for example) and setting font-lock-support-mode to fast-lock-mode in the source file through local variables, any Lisp code in the .flc file is executed without warning (CVE-2008-2142). Romain Francoise reported a security risk in a feature of GNU Emacs related to interacting with Python. The vulnerability arises because Python, by default, prepends the current directory to the module search path, allowing for arbitrary code execution when launched from a specially crafted directory (CVE-2008-3949).

Impact

Remote attackers could entice a user to open a specially crafted file in GNU Emacs, possibly leading to the execution of arbitrary Emacs Lisp code or arbitrary Python code with the privileges of the user running GNU Emacs or XEmacs.

Workaround

There is no known workaround at this time.

Resolution

All GNU Emacs users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-editors/emacs-22.2-r3"
All edit-utils users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-xemacs/edit-utils-2.39"


References

CVE-2008-2142
CVE-2008-3949
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum