Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200902-05 ] KTorrent: Multiple vulnerabilitites
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1569

PostPosted: Mon Feb 23, 2009 10:26 pm    Post subject: [ GLSA 200902-05 ] KTorrent: Multiple vulnerabilitites Reply with quote

Gentoo Linux Security Advisory

Title: KTorrent: Multiple vulnerabilitites (GLSA 200902-05)
Severity: high
Exploitable: remote
Date: February 23, 2009
Bug(s): #244741
ID: 200902-05

Synopsis

Two vulnerabilities in the web interface plugin in KTorrent allow for remote execution of code and arbitrary torrent uploads.

Background

KTorrent is a BitTorrent program for KDE.

Affected Packages

Package: net-p2p/ktorrent
Vulnerable: < 2.2.8
Unaffected: >= 2.2.8
Architectures: All supported architectures


Description

The web interface plugin does not restrict access to the torrent upload functionality (CVE-2008-5905) and does not sanitize request parameters properly (CVE-2008-5906) .

Impact

A remote attacker could send specially crafted parameters to the web interface that would allow for arbitrary torrent uploads and remote code execution with the privileges of the KTorrent process.

Workaround

Disabling the web interface plugin will prevent exploitation of both issues. Click "Plugins" in the configuration menu and uncheck the checkbox left of "WebInterface", then apply the changes.

Resolution

All KTorrent users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-p2p/ktorrent-2.2.8"


References

CVE-2008-5905
CVE-2008-5906
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum