Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qt-script, qt-core, qt-sdl, qt-dbus, qt-gui slot conflict
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2662
Location: de

PostPosted: Wed Feb 18, 2009 1:56 pm    Post subject: Reply with quote

I had the same problems. Putting qt-phonon into /etc/portage/package.mask didn't solve it. strigi wanted qt-4.3.x.

I don't know, if all the procedure is necessary. At least it seemed to me the only working chance:

1. Deinstall all the qt-stuff (qt-core, qt-gui, qt-opengl...)
2. Put app-misc/strigi-0.6.4 into /etc/portage/profiles/package.provided
3. If enabled in /etc/make.conf, disable phonon in the USE-flags (with phonon enabled, it's not possible to emerge the qt-stuff)
4. Deinstall the kde4-stuff, which is complaining about in emerge -puDN world, deinstall kdelibs-4.2.x
5. emerge kdelibs. That will install the qt-stuff and all the other depencies - hopefully without qt-phonon
6. At the point when kdelibs itself has to be merged, kdelibs will fail to compile while configuring. At this point you have to remove the strigi-entry in /etc/portage/profiles/package.provided.
7. emerge kdelibs will install strigi (without qt-4.3.x) and finally kdelibs.


Last edited by musv on Thu Feb 19, 2009 9:19 am; edited 1 time in total
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Wed Feb 18, 2009 8:24 pm    Post subject: Reply with quote

qt-4.3 is hardmasked, so that should not be a problem.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
ar_it
Apprentice
Apprentice


Joined: 25 Feb 2006
Posts: 211
Location: Poland/Warsaw

PostPosted: Wed Mar 04, 2009 10:56 pm    Post subject: Reply with quote

Hi,
I have problem with upgrede to qt-4.5
Code:
 
 emerge -DuNtpv @system @world
WARNING: One or more repositories have missing repo_name entries:

        /usr/portage/local/layman/profiles/repo_name
        /usr/local/portage/profiles/repo_name       

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.                 

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-sql:4

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-sql-4.5.0_rc1[qt3support,-debug] required by ('installed', '/', 'x11-libs/qt-qt3support-4.5.0_rc1', 'nomerge')

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.0', 'merge') pulled in by
    x11-libs/qt-sql:4[qt3support] required by ('installed', '/', 'kde-base/krunner-4.2.0', 'nomerge')
    x11-libs/qt-sql:4[qt3support] required by ('installed', '/', 'kde-base/libkworkspace-4.2.0', 'nomerge')
    x11-libs/qt-sql:4[qt3support] required by ('installed', '/', 'kde-base/kcminit-4.2.0', 'nomerge')
    (and 5 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "~x11-libs/qt-gui-4.5.0[-debug]".
(dependency required by "x11-libs/qt-svg-4.5.0" [ebuild])
(dependency required by "kde-base/kcminit-4.2.0" [installed])
(dependency required by "kde-base/ksmserver-4.2.0" [installed])
(dependency required by "kde-base/krunner-4.2.0" [installed])
(dependency required by "kde-base/kdeplasma-addons-4.2.0-r1" [installed])
(dependency required by "@world" [argument])

[/code]
_________________
ar_it
http://www.teamquest.pl/
https://pozyskajdane.pl
Back to top
View user's profile Send private message
transsib
l33t
l33t


Joined: 26 Jul 2003
Posts: 639

PostPosted: Sun Mar 29, 2009 9:01 am    Post subject: Reply with quote

Hi all,
short summary question for the slower people like me.
Looks like I have to upgrade:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "~x11-libs/qt-dbus-4.5.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-dbus-4.5.0 (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-4.5.0" [ebuild])
(dependency required by "world" [argument])


Unmerging qt-4.4.2 should not be a problem here but I`d have to unmerge stellarium as well:
Code:
 # equery depends "qt:4"
/usr/lib/portage/pym/portage_util.py:45: DeprecationWarning: DEPRECATION NOTICE: The portage_util module was replaced by portage.util
/usr/lib/portage/pym/portage_checksum.py:45: DeprecationWarning: DEPRECATION NOTICE: The portage_checksum module was replaced by portage.checksum
/usr/lib/portage/pym/output.py:45: DeprecationWarning: DEPRECATION NOTICE: The output module was replaced by portage.output
[ Searching for packages depending on qt:4... ]
sci-astronomy/stellarium-0.9.1-r1 (>=x11-libs/qt-4.2:4)


But if I want stellarium and I`d reemerge it after the procedure it would pull qt-4.2 back in or does stellarium then use qt-4.5?

All other packages that need qt still need qt:3 and there are a lot of them.

I apologize for the simple question.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sun Mar 29, 2009 10:34 am    Post subject: Reply with quote

I don't know what is pulling the ~amd64 version (4.5.0) for you, but you should be able to use the stable version (4.4.2). If your portage is up to date, then the upgrade should be smooth. And yes, stellarium can use the split qt ebuilds (both stable 4.4.2 and testing 4.5.0 versions).
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
1clue
Veteran
Veteran


Joined: 05 Feb 2006
Posts: 1387

PostPosted: Thu Apr 02, 2009 3:25 am    Post subject: Reply with quote

OK, I'm lost here. I followed the nice abstract discussion on the first couple pages, but for some reason my particular situation does not seem to make any sense. That said, I've been up for almost 30 hours trying to get this %@#@$@ box working.

Here's the interesting part of my emerge -pDNu command:
[ebuild N ] x11-libs/qt-core-4.4.2 USE="doc qt3support ssl -custom-cxxflags -debug -glib -pch"
[ebuild N ] x11-libs/qt-test-4.4.2 USE="-custom-cxxflags -debug -pch"
[ebuild N ] x11-libs/qt-dbus-4.4.2 USE="-custom-cxxflags -debug -pch"
[ebuild N ] x11-libs/qt-script-4.4.2 USE="-custom-cxxflags -debug -pch"
[ebuild N ] x11-libs/qt-sql-4.4.2 USE="qt3support sqlite -custom-cxxflags -debug -firebird -mysql -odbc -pch -postgres"
[ebuild N ] x11-libs/qt-gui-4.4.2-r1 USE="accessibility cups dbus qt3support tiff -custom-cxxflags -debug -glib -mng -nas -nis -pch -xinerama" INPUT_DEVICES="-wacom"
[ebuild N ] x11-libs/qt-qt3support-4.4.2 USE="accessibility -custom-cxxflags -debug -pch"
[ebuild U ] app-text/poppler-bindings-0.10.4 [0.8.7]
[ebuild N ] virtual/poppler-glib-0.10.4 USE="cairo"
[ebuild U ] media-gfx/gimp-2.6.4 [2.4.6] USE="jpeg%* -webkit%"
[uninstall ] x11-libs/qt-4.3.3
[blocks b ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-gui-4.4.2-r1, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2)


For some reason, everyone on this thread is talking about an upgrade to 4.4, and the way I read this my system wants to downgrade to 4.3? Say it ain't so.

Background: For some reason in the distant past, I upgraded to a beta glibc and xorg. I've been stuck with it since, and have been considering a re-install to get around the mistake. I just checked, and glibc's stable version has surpassed my beta one, and xorg seems to be reasonable too. So I decided to paint new lines instead of rebuilding the highway, so to speak.

I think if I took a nap, I might be able to make sense of the above block of junk. However, I would like to leave my emerge running for however long it takes, if it will run that long.

So, the questions I need to have answered, if somebody will be so kind:
:?: Is my system trying to upgrade or downgrade?
:?: If it's trying to downgrade, is that safe for this particular setup?

Thanks.

Edit: Oh, heck. I thought of another question.
:?: Will portage handle all that without intervention, or will it blow up and leave me with a tatered system in the morning?

Thanks again.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2662
Location: de

PostPosted: Thu Apr 02, 2009 6:50 am    Post subject: Reply with quote

1clue wrote:
For some reason, everyone on this thread is talking about an upgrade to 4.4, and the way I read this my system wants to downgrade to 4.3? Say it ain't so.

http://forums.gentoo.org/viewtopic-t-736457-start-50.html#5489396
me wrote:
I had the same problems. Putting qt-phonon into /etc/portage/package.mask didn't solve it. strigi wanted qt-4.3.x.

Consider going directly to qt-4.5.0 or you will get the same problems again in a few weeks. Your upgrade of glibc and xorg isn't probably the reason.

Your qt until 4.3.x is a monolithic build. With qt-4.4.x it will be splittet into minor parts. That's why portage is leading you into trouble.

Your solution:
1. Write down that list you posted.
2. Deinstall qt-4.3.3 (emerge --unmerge =qt-4.3.3)
3. Begin to install the new qt-packages in single-steps:
emerge -p =qt-core-4.4.2 -> will only install qt-core? Yes, then -> emerge -1 =qt-core-4.4.2
emerge -p =qt-test-4.4.2 -> will only install qt-test? Yes, then -> emerge -1 =qt-test-4.4.2
So you will be find the critical package which wants to install 4.3.3 again.
Back to top
View user's profile Send private message
1clue
Veteran
Veteran


Joined: 05 Feb 2006
Posts: 1387

PostPosted: Thu Apr 02, 2009 2:55 pm    Post subject: Reply with quote

Thanks for the reply.

Will de-installing qt hurt the system in some way? It seems to be a common library. Do I then need to finish installation before continuing other work? Would that be safer without X running?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2662
Location: de

PostPosted: Thu Apr 02, 2009 7:17 pm    Post subject: Reply with quote

Every stuff based on qt4 won't work. That means all the kde4 progs. X you don't have to stop.
Back to top
View user's profile Send private message
Tuxenstein
Apprentice
Apprentice


Joined: 28 May 2005
Posts: 155

PostPosted: Tue Apr 14, 2009 10:08 pm    Post subject: Reply with quote

So, let me see if I understand this correctly. Qt-4.5 is currently around the corner and those of us who are currently dealing with the 4.4 situation (which I'm admittedly unclear as to how to resolve at the moment), will likely be having to deal with this very same type of situation yet again in the upcoming few weeks or months?
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Apr 18, 2009 8:50 am    Post subject: Reply with quote

No. The upgrade is smooth now. Just make sure you have synced and your portage (the program itself) is up to date. This topic is basically obsolete now. Monolithic Qt 4.3 was hardmasked and is no longer in the tree. Portage has a much more intelligent dependency resolver and block handler now. So in almost all cases upgrading or installing Qt4 should be no problem at all. There may be a few minor issues you may have to deal with, but of course we're happy to help.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Fri Apr 24, 2009 12:11 pm    Post subject: Reply with quote

The upgrade path is not smooth for me. After
Code:
emerge --sync && emerge world -pv
I have:

Quote:

[uninstall ] gnome-base/gail-1.20.2 USE="-debug -doc" [0]
[blocks b ] <gnome-base/gail-1000 ("<gnome-base/gail-1000" is blocking x11-libs/gtk+-2.14.7-r2)
[blocks B ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks B ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-opengl-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks B ] <x11-libs/qt-4.4.0:4 ("<x11-libs/qt-4.4.0:4" is blocking x11-libs/qt-assistant-4.4.2-r1)

Total: 191 packages (31 upgrades, 27 new, 1 in new slot, 132 reinstalls, 1 uninstall, 1 interactive), Size of downloads: 308,355 kB
Fetch Restriction: 1 package
Conflict: 4 blocks (3 unsatisfied)
Portage tree and overlays:
[0] /usr/portage
[1] /usr/local/portage
[?] indicates that the source repository could not be determined

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge') pulled in by
~x11-libs/qt-test-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.4.2', 'merge') pulled in by
~x11-libs/qt-xmlpatterns-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-webkit-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-opengl-4.4.2', 'merge') pulled in by
~x11-libs/qt-opengl-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-assistant-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-svg-4.4.2', 'merge') pulled in by
~x11-libs/qt-svg-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')

('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')

('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
(and 4 more)

('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
=x11-libs/qt-4.3* required by ('installed', '/', 'dev-python/PyQt4-4.3.3', 'nomerge')
x11-libs/qt:4 required by world


Thanks.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Apr 25, 2009 1:32 pm    Post subject: Reply with quote

metalus wrote:
The upgrade path is not smooth for me.
Code:
  ('installed', '/', 'x11-libs/qt-4.3.3', 'nomerge') pulled in by
    =x11-libs/qt-4.3* required by ('installed', '/', 'dev-python/PyQt4-4.3.3', 'nomerge')
    x11-libs/qt:4 required by world


PyQt4-4.3.3 is no longer in portage, so a world update should offer you an upgrade to 4.4.4. Are you sure you haven't masked any upgrades?

If you still have problems, you could try unmerging the problematic packages (try `equery depends qt:4` to find them), unmerging qt-4.3*, and then reinstalling the packages you want/need. That should pull in the current qt packages.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Sat Apr 25, 2009 5:16 pm    Post subject: Reply with quote

I am guessing that the lack of package.mask means I don't mask any packages:
Code:

# ls /etc/portage
bin  color.map  kde_keywords  package.keywords  package.use  postsync.d  savedconfig


What depends on qt:4 is
Code:

# equery depends qt:4
[ Searching for packages depending on qt:4... ]
app-text/poppler-bindings-0.8.7 (qt4? =x11-libs/qt-4.3*)
dev-python/PyQt4-4.3.3 (=x11-libs/qt-4.3*)
x11-libs/qscintilla-2.1-r1 (qt4? =x11-libs/qt-4.3*:4)


Thanks for the advice, I'll try it when I have time to risk this upgrade.
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Sat Apr 25, 2009 7:18 pm    Post subject: Reply with quote

metalus wrote:
What depends on qt:4 is
Code:
# equery depends qt:4
[ Searching for packages depending on qt:4... ]
app-text/poppler-bindings-0.8.7 (qt4? =x11-libs/qt-4.3*)
dev-python/PyQt4-4.3.3 (=x11-libs/qt-4.3*)
x11-libs/qscintilla-2.1-r1 (qt4? =x11-libs/qt-4.3*:4)


Thanks for the advice, I'll try it when I have time to risk this upgrade.

There is no risk. You just have some very outdated packages. It's safe enough to unmerge poppler-bindings, PyQt4 and qscintilla, as well as qt-4.3*. You should also unmerge app-text/poppler, and migrate to dev-libs/poppler, and then install poppler-qt4 instead of poppler-bindings. When you reinstall PyQt4, you should get the new 4.4.4 version, which will also pull in the Qt packages you need. An emerge -avuD world finally should bring you all up to date then.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Sat Apr 25, 2009 8:49 pm    Post subject: Reply with quote

By risk I mean not knowing where the upgrade difficulties will end. Here is what I did:

Code:

# emerge --unmerge app-text/poppler-bindings dev-python/PyQt4 x11-libs/qscintilla app-text/poppler dev-python/PyQt gnomad
... [stuff deleted] ...
 * GNU info directory index is up-to-date.
# emerge world -pv
... [ stuff deleted ] ...

[blocks b     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-webkit-4.4.2-r1, x11-libs/qt-dbus-4.4.2, x11-libs/qt-sql-4.4.2-r1, x11-libs/qt-script-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-opengl-4.4.2, x11-libs/qt-core-4.4.2-r2)
[blocks b     ] <x11-libs/qt-4.4.0:4 ("<x11-libs/qt-4.4.0:4" is blocking x11-libs/qt-assistant-4.4.2-r1)

Total: 196 packages (30 upgrades, 34 new, 1 in new slot, 131 reinstalls, 1 uninstall, 1 interactive), Size of downloads: 319,223 kB
Fetch Restriction: 1 package
Conflict: 4 blocks
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage
 [?] indicates that the source repository could not be determined



Two questions:

1) How do I fix this?
2) Is there a way to know what other difficulties lie ahead?

I hope the is no power outage because I would not want to reboot at this point and lose X or KDE.


Last edited by metalus on Sat Apr 25, 2009 10:03 pm; edited 1 time in total
Back to top
View user's profile Send private message
emerald
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 113

PostPosted: Sat Apr 25, 2009 10:01 pm    Post subject: Reply with quote

you should not try to upgrade via emerge -pv world but use emerge -avuD world or -avuND world. This will update all deep dependencies too.
And, especially have portage up-to-date too, before you attempt to update!
_________________
Knowledge is scary....

... running Gentoo Linux ...
... and Windows in a 'small corner'(C) - i.e. vmware - :D ...
System Profile

Don't open the Red Door !
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Sat Apr 25, 2009 10:06 pm    Post subject: Reply with quote

Ah, emerge -avuD world works. 600M+ of downloads and 178 packages to compile :-)
I'll take until tomorrow, but that is okay. Thanks!
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Sun Apr 26, 2009 11:57 pm    Post subject: Reply with quote

The emerge world -avuND ends with:

Code:

 * Package 'x11-libs/qt-gui-4.4.2-r3' NOT merged due to file collisions.
 * If necessary, refer to your elog messages for the whole content of the
 * above message.


Now what do I do?

I have found two bug reports, are they relevant?
http://bugs.gentoo.org/show_bug.cgi?id=248110
http://bugs.gentoo.org/show_bug.cgi?id=262457

I use KDE 3.5 by the way, if that matters.
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Mon Apr 27, 2009 4:46 am    Post subject: Reply with quote

Okay, after rebooting, KDE won't start anymore. I have found a guide here:
http://dev.gentoo.org/~nightmorph/qt4-split-ebuilds.xml

My computer having become unusable, I am following that guide.
Back to top
View user's profile Send private message
emerald
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 113

PostPosted: Mon Apr 27, 2009 7:15 am    Post subject: Reply with quote

you probably updated qt:3 so you need remerge kdelibs:3.5 to get kde working again
_________________
Knowledge is scary....

... running Gentoo Linux ...
... and Windows in a 'small corner'(C) - i.e. vmware - :D ...
System Profile

Don't open the Red Door !
Back to top
View user's profile Send private message
metalus
n00b
n00b


Joined: 09 May 2004
Posts: 52

PostPosted: Mon Apr 27, 2009 12:42 pm    Post subject: Reply with quote

Oh, it is X which won't start. I have removed my xorg.conf and I get:

Code:

(EE) module ABI major version (1) doesn't match the server's version (4)
(EE) Failed to load module "ati" (module requirement mismatch , 0)
(EE) Failed to load module "fbdev" (module does not exist, 0)
(EE) Failed to load module "vesa" (module does not exists, 0)
(EE) No drivers available

Fatal server error:
no screens found
giving up


Needed to emerge xf86-video-ati and reboot.
Back to top
View user's profile Send private message
guinness.stout
Apprentice
Apprentice


Joined: 26 Aug 2006
Posts: 237
Location: Maryland

PostPosted: Tue Jun 09, 2009 2:41 am    Post subject: Reply with quote

just did emerge --sync then tired emerge -avuND world and got this fun mess

Code:

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-devel/gcc-config-1.4.1 [1.4.0-r4] 0 kB
[ebuild   R   ] sys-devel/patch-2.5.9  USE="-static (-build%)" 198 kB
[ebuild     U ] media-libs/openjpeg-1.3-r2 [1.3] USE="-tools" 0 kB
[ebuild     U ] dev-libs/libmcrypt-2.5.8-r1 [2.5.8] 0 kB
[ebuild     U ] dev-libs/libevent-1.4.10 [1.4.9] 484 kB
[ebuild   R   ] sys-libs/ncurses-5.6-r2  USE="gpm unicode -debug -doc -minimal -nocxx -profile -trace (-bootstrap%) (-build%)" 2,353 kB
[ebuild     U ] dev-java/java-config-wrapper-0.16 [0.15] 8 kB
[ebuild   R   ] media-libs/tiff-3.8.2-r4  USE="jpeg* zlib -jbig -nocxx" 0 kB
[ebuild  N    ] virtual/acl-0  0 kB
[ebuild     U ] media-libs/vigra-1.6.0 [1.5.0-r1] USE="jpeg* png* zlib -doc -fftw -test% -tiff" 16,139 kB
[ebuild     U ] net-misc/tor-0.2.0.34-r2 [0.2.0.34] USE="bundledlibevent -debug" 0 kB
[ebuild   R   ] x11-libs/cairo-1.8.6-r1  USE="X opengl -cleartype -debug -directfb -doc -glitz -svg* -xcb" 0 kB
[ebuild   R   ] app-emulation/emul-linux-x86-soundlibs-20080418  USE="alsa* arts -esd" 0 kB
[ebuild     U ] dev-perl/yaml-0.68 [0.65] 91 kB
[ebuild     U ] dev-perl/perl-tk-804.028-r2 [804.028-r1] 0 kB
[ebuild     U ] dev-perl/HTML-Parser-3.60 [3.56] USE="-test" 86 kB
[ebuild  N    ] virtual/perl-Compress-Raw-Bzip2-2.015  0 kB
[ebuild     U ] media-libs/libvorbis-1.2.1_rc1-r2 [1.2.1_rc1] USE="aotuv%* -doc" 86 kB
[ebuild     U ] dev-libs/libusb-0.1.12-r5 [0.1.12-r1] USE="-debug -doc -nocxx%" 0 kB
[ebuild     U ] media-sound/lame-3.98.2-r1 [3.98.2] USE="-debug (-mmx) -mp3rtp -sndfile" 0 kB
[ebuild     U ] media-libs/libdvdcss-1.2.10 [1.2.9-r1] USE="-doc" 302 kB
[ebuild     U ] media-libs/a52dec-0.7.4-r6 [0.7.4-r5] USE="-djbfft -oss" 0 kB
[ebuild  N    ] virtual/libusb-0  0 kB
[ebuild  N    ] virtual/perl-IO-Compress-Bzip2-2.015  0 kB
[ebuild     U ] perl-core/File-Spec-3.29 [3.25] 128 kB
[ebuild     U ] virtual/perl-File-Spec-3.29 [3.25] 0 kB
[ebuild     U ] dev-util/boost-build-1.35.0-r1 [1.34.1] USE="python -examples%" 22,868 kB
[ebuild     U ] dev-libs/boost-1.35.0-r2 [1.34.1-r2] USE="-debug -doc -expat% -icu -mpi% -tools (-pyste%)" 5 kB
[ebuild   R   ] net-misc/mDNSResponder-107.6-r5  USE="java* -debug -doc" 0 kB
[ebuild     U ] media-libs/libsndfile-1.0.20 [1.0.19] USE="alsa -jack% -minimal -sqlite" 906 kB
[ebuild   R   ] sys-apps/coreutils-7.1  USE="acl nls -caps -gmp% (-selinux) -static -vanilla -xattr" 0 kB
[ebuild   R   ] sys-devel/binutils-2.18-r3  USE="nls -gold% -multislot -multitarget -test -vanilla" 0 kB
[ebuild     U ] dev-libs/libgpg-error-1.7 [1.6] USE="nls" 395 kB
[ebuild     U ] dev-lang/yasm-0.8.0 [0.7.1] USE="nls" 1,387 kB
[ebuild  N    ] dev-java/servletapi-2.4-r5  USE="-doc -source" 4,684 kB
[ebuild  N    ] dev-java/tomcat-servlet-api-4.1.36  USE="-doc -source" 3,629 kB
[ebuild  NS   ] sys-libs/db-4.6.21_p4 [4.3.29-r2, 4.5.20_p2-r1] USE="java -doc -nocxx -tcl -test" 11,649 kB
[ebuild     U ] app-admin/eselect-1.0.12 [1.0.11-r1] USE="-bash-completion -doc (-vim-syntax%)" 143 kB
[ebuild   R   ] sys-libs/db-4.5.20_p2-r1  USE="java* -doc -nocxx -tcl -test (-bootstrap%)" 0 kB
[ebuild     U ] media-video/ffmpeg-0.5-r1 [0.4.9_p20090201] USE="3dnow* 3dnowext%* X alsa encode* hardcoded-tables* ipv6 mmx mmxext* mp3 ssse3* v4l* v4l2* vorbis zlib (-altivec) -amr -bindist -custom-cflags% -debug -dirac -doc -faac% -faad% -gsm -ieee1394 -jpeg2k% -network -oss -schroedinger -sdl -speex -test -theora -threads -vhook -x264 -xvid (-aac%)" 2,681 kB
[ebuild  N    ] java-virtuals/servlet-api-2.3  0 kB
[ebuild  N    ] app-admin/eselect-ruby-20081227  2 kB
[ebuild     U ] dev-libs/xmlrpc-c-1.18.02 [1.06.27] USE="cgi%* curl cxx%* -abyss% -threads -tools%" 540 kB
[ebuild     U ] dev-lang/ruby-1.8.6_p368 [1.8.6_p287-r5] USE="berkdb gdbm ipv6 ssl -debug -doc -emacs -examples -rubytests -socks5 -threads -tk -xemacs" 3,875 kB
[ebuild  N    ] dev-java/bsh-2.0_beta4-r3  USE="readline -bsf -doc -source" 1,628 kB
[ebuild     U ] dev-ruby/rcairo-1.8.0-r1 [1.4.1] USE="-svg% (-examples%)" 272 kB
[ebuild   R   ] dev-libs/cyrus-sasl-2.1.22-r2  USE="berkdb crypt gdbm java* mysql* pam ssl -authdaemond -kerberos -ldap -ntlm_unsupported_patch -postgres -sample -srp -urandom" 0 kB
[ebuild  N    ] virtual/cdrtools-0  0 kB
[ebuild   R   ] net-firewall/iptables-1.4.2-r2  USE="-l7filter%" 0 kB
[ebuild   R   ] sys-libs/glibc-2.8_p20080602-r1  USE="gd (multilib) nls -debug -glibc-omitfp (-hardened) -profile (-selinux) -vanilla (-glibc-compat20%)" 101 kB
[ebuild  NS   ] dev-java/sun-jdk-1.5.0.18 [1.6.0.11] USE="X alsa -doc -examples -jce (-nsplugin) -odbc" 43,061 kB
[ebuild   R   ] media-video/transcode-1.0.7  USE="X dvd iconv jpeg mmx mp3 sse sse2 v4l2* vorbis xml -3dnow -a52 (-altivec) -dv -extrafilters -fame -imagemagick -lzo -mjpeg -mpeg -network -nuv -ogg -oss -quicktime -sdl -theora -truetype -xvid" 0 kB
[ebuild     U ] x11-misc/shared-mime-info-0.60 [0.51] 447 kB
[ebuild  NS   ] virtual/jdk-1.5.0 [1.6.0] 0 kB
[ebuild     U ] x11-misc/xdg-utils-1.0.2-r3 [1.0.2-r1] USE="-doc" 0 kB
[ebuild  N    ] dev-db/hsqldb-1.8.0.10  USE="-doc -java6 -source -test" 3,437 kB
[ebuild     U ] app-text/ghostscript-gpl-8.64-r3 [8.64-r2] USE="X cups gtk -bindist -cairo -cjk -djvu -jpeg2k" 12 kB
[ebuild   R   ] dev-cpp/gtkmm-2.12.7  USE="-debug -doc -examples -test (-accessibility%)" 0 kB
[ebuild   R   ] dev-java/swt-3.4-r2  USE="opengl -cairo* -gnome -xulrunner*" 0 kB
[ebuild   R   ] media-libs/gegl-0.0.22  USE="jpeg mmx png sse v4l* -cairo -debug -doc -ffmpeg -openexr -raw -sdl -svg" 0 kB
[ebuild   R   ] media-sound/audacity-1.3.6  USE="alsa flac* midi mp3 vorbis -ffmpeg -id3tag -jack -ladspa -libsamplerate -soundtouch -twolame -vamp" 0 kB
[ebuild   R   ] net-analyzer/ntop-3.3.9-r2  USE="ipv6 ssl tcpd (-nls%*)" 0 kB
[ebuild   R   ] dev-python/twisted-8.1.0  USE="crypt gtk* -serial" 0 kB
[ebuild   R   ] x11-drivers/xf86-video-ati-6.12.1-r1  USE="-debug (-dri%*)" 0 kB
[ebuild   R   ] app-admin/conky-1.6.1  USE="X ipv6* nvidia -audacious (-bmpx) -debug -hddtemp -mpd -nano-syntax -rss -smapi -truetype -vim-syntax -wifi" 0 kB
[ebuild     U ] kde-base/kdelibs-3.5.10-r6 [3.5.9-r4] USE="acl alsa* cups -arts -avahi -bindist -branding -debug -doc -fam -jpeg2k -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -spell -tiff -utempter (-kdeenablefinal%) (-xinerama%)" 15,256 kB
[ebuild     U ] kde-base/libkonq-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 23,770 kB
[ebuild     U ] kde-base/kdialog-3.5.10 [3.5.9-r1] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 26 kB
[ebuild     U ] kde-base/kcminit-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdebase-data-3.5.10 [3.5.9] USE="-debug (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/khotkeys-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kmenuedit-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdesu-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/ksplashml-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility -xinerama (-arts%) (-kdeenablefinal%)" 0 kB
[ebuild     U ] kde-base/kwin-3.5.10 [3.5.9-r1] USE="-debug -kdehiddenvisibility -xcomposite (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kreadconfig-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kcheckpass-3.5.10 [3.5.9] USE="pam -debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/ksmserver-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kpersonalizer-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/ksysguard-3.5.10 [3.5.9] USE="lm_sensors* -debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kxkb-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/ktip-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kscreensaver-3.5.10 [3.5.9] USE="opengl -arts -debug -kdehiddenvisibility (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/knetattach-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kpager-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kate-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/ksystraycmd-3.5.10-r1 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/klipper-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdcop-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kstart-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/nsplugins-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdebugdialog-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/drkonqi-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kghostview-3.5.10 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 7,267 kB
[ebuild     U ] kde-base/kcalc-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 2,991 kB
[ebuild     U ] kde-base/ksnapshot-3.5.10 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kmix-3.5.10 [3.5.9] USE="alsa -debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 6,185 kB
[ebuild     U ] kde-base/kcharselect-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild   R   ] app-office/openoffice-3.0.0  USE="cups dbus gtk* java* kde opengl pam -binfilter -debug -eds -gnome -gstreamer -ldap -mono -nsplugin -odk -templates" LINGUAS="-af -ar -as_IN -be_BY -bg -bn -br -bs -ca -cs -cy -da -de -dz -el -en -en_GB -en_US -en_ZA -eo -es -et -fa -fi -fr -ga -gl -gu_IN -he -hi_IN -hr -hu -it -ja -km -ko -ku -lt -lv -mk -ml_IN -mr_IN -nb -ne -nl -nn -nr -ns -or_IN -pa_IN -pl -pt -pt_BR -ru -rw -sh -sk -sl -sr -ss -st -sv -sw_TZ -ta_IN -te_IN -tg -th -ti_ER -tn -tr -ts -uk -ur_IN -ve -vi -xh -zh_CN -zh_TW -zu" 10,552 kB
[ebuild     U ] kde-base/kamera-3.5.10 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kgamma-3.5.10 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kicker-3.5.10-r1 [3.5.9] USE="-debug -kdehiddenvisibility -xcomposite (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdebase-kioslaves-3.5.10-r1 [3.5.9] USE="hal* samba -debug -kdehiddenvisibility -ldap -openexr (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kfind-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdeprint-3.5.10 [3.5.9] USE="cups kde -debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdepasswd-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/khelpcenter-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kappfinder-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kcontrol-3.5.10 [3.5.9] USE="opengl -arts -debug -ieee1394 -joystick -kdehiddenvisibility -logitech-mouse (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/konqueror-3.5.10 [3.5.9] USE="java* -branding -debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/konsole-3.5.10 [3.5.9] USE="-debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdesktop-3.5.10 [3.5.9-r1] USE="-debug -kdehiddenvisibility -xscreensaver (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdm-3.5.10 [3.5.9] USE="pam -debug -kdehiddenvisibility (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[ebuild     U ] kde-base/kdebase-startkde-3.5.10-r5 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 0 kB
[blocks b     ] <=kde-base/kdebase-startkde-3.5.10-r3 ("<=kde-base/kdebase-startkde-3.5.10-r3" is blocking kde-base/kdelibs-3.5.10-r6)
[ebuild     U ] kde-base/kdebase-meta-3.5.10 [3.5.9] 0 kB
[ebuild  NS   ] app-cdr/k3b-1.0.5-r5 [1.0.5-r3] USE="alsa dvd flac hal mp3 vorbis -arts -css -debug -dvdr -emovix -encode -ffmpeg -musepack -musicbrainz -sndfile -vcd -xinerama" LINGUAS="-af -ar -bg -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW" 0 kB
[uninstall    ] app-cdr/k3b-1.0.5-r3  USE="alsa dvd flac hal mp3 vorbis -arts -css -debug -dvdr -emovix -encode -ffmpeg -musepack -musicbrainz -sndfile -vcd -xinerama" LINGUAS="-af -ar -bg -br -bs -ca -cs -cy -da -de -el -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hu -is -it -ja -ka -lt -mk -ms -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -rw -se -sk -sr -sr@Latn -sv -ta -tr -uk -uz -zh_CN -zh_TW"
[blocks b     ] <app-cdr/k3b-1.0.5-r5 ("<app-cdr/k3b-1.0.5-r5" is blocking app-cdr/k3b-1.0.5-r5)
[ebuild     U ] x11-libs/qt-core-4.5.1 [4.4.2-r2] USE="glib iconv qt3support ssl -custom-cxxflags -debug -doc -pch" 111,980 kB
[ebuild     U ] x11-libs/qt-dbus-4.5.1 [4.4.2] USE="-custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-dbus-4.5.1 ("<x11-libs/qt-dbus-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-sql-4.5.1 [4.4.2-r1] USE="iconv mysql qt3support sqlite -custom-cxxflags -debug (-firebird) -odbc -pch -postgres" 0 kB
[blocks b     ] <x11-libs/qt-sql-4.5.1 ("<x11-libs/qt-sql-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-test-4.5.1 [4.4.2] USE="iconv%* -custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-test-4.5.1 ("<x11-libs/qt-test-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-script-4.5.1 [4.4.2] USE="iconv%* -custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-script-4.5.1 ("<x11-libs/qt-script-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-xmlpatterns-4.5.1 [4.4.2] USE="-custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-xmlpatterns-4.5.1 ("<x11-libs/qt-xmlpatterns-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-gui-4.5.1 [4.4.2-r3] USE="accessibility cups dbus glib gtkstyle%* qt3support -custom-cxxflags -debug -mng -nas -nis -pch -raster% -tiff -xinerama" INPUT_DEVICES="(-wacom%)" 0 kB
[blocks b     ] <x11-libs/qt-gui-4.5.1 ("<x11-libs/qt-gui-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-qt3support-4.5.1 [4.4.2] USE="accessibility kde%* -custom-cxxflags% -debug -pch -phonon%" 0 kB
[blocks b     ] <x11-libs/qt-qt3support-4.5.1 ("<x11-libs/qt-qt3support-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-opengl-4.5.1 [4.4.2] USE="qt3support -custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-opengl-4.5.1 ("<x11-libs/qt-opengl-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild   R   ] app-text/poppler-bindings-0.10.5-r1  USE="gtk qt3 qt4 -cairo* -test" 0 kB
[ebuild     U ] dev-util/cmake-2.6.4 [2.6.2-r1] USE="qt4 -emacs -vim-syntax" 3,209 kB
[ebuild     U ] x11-libs/qt-svg-4.5.1-r1 [4.4.2] USE="iconv%* -custom-cxxflags% -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-svg-4.5.1 ("<x11-libs/qt-svg-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild  N    ] kde-base/automoc-0.9.88  9 kB
[ebuild  N    ] media-sound/phonon-4.3.1  USE="xcb xine -debug -gstreamer" 563 kB
[ebuild     U ] kde-base/kpdf-3.5.10-r1 [3.5.9] USE="-debug (-arts%) (-kdeenablefinal%) (-xinerama%)" 6 kB
[ebuild     U ] x11-libs/qt-webkit-4.5.1 [4.4.2-r1] USE="kde%* -custom-cxxflags -debug -pch" 0 kB
[blocks b     ] <x11-libs/qt-webkit-4.5.1 ("<x11-libs/qt-webkit-4.5.1" is blocking x11-libs/qt-assistant-4.5.1, x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1)
[ebuild     U ] x11-libs/qt-assistant-4.5.1 [4.4.2-r1] USE="-custom-cxxflags% -debug -pch (-webkit%*)" 0 kB
[blocks b     ] <x11-libs/qt-assistant-4.5.1 ("<x11-libs/qt-assistant-4.5.1" is blocking x11-libs/qt-opengl-4.5.1, x11-libs/qt-svg-4.5.1-r1, x11-libs/qt-script-4.5.1, x11-libs/qt-dbus-4.5.1, x11-libs/qt-xmlpatterns-4.5.1, x11-libs/qt-test-4.5.1, x11-libs/qt-gui-4.5.1, x11-libs/qt-qt3support-4.5.1, x11-libs/qt-sql-4.5.1, x11-libs/qt-core-4.5.1, x11-libs/qt-webkit-4.5.1)
[ebuild     U ] x11-libs/qt-4.5.1 [4.4.2] USE="dbus kde%* opengl qt3support" 0 kB

Total: 134 packages (94 upgrades, 13 new, 4 in new slots, 23 reinstalls, 1 uninstall), Size of downloads: 303,390 kB
Conflict: 13 blocks

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/cairo:0

  ('installed', '/', 'x11-libs/cairo-1.8.6-r1', 'nomerge') pulled in by
    >=x11-libs/cairo-1.7.6[svg,X] required by ('installed', '/', 'x11-libs/pango-1.24.2', 'nomerge')
    (and 11 more)

  ('ebuild', '/', 'x11-libs/cairo-1.8.6-r1', 'merge') pulled in by
    >=x11-libs/cairo-1.4 required by ('installed', '/', 'app-text/poppler-bindings-0.10.5-r1', 'nomerge')
    >=x11-libs/cairo-1.4.14 required by ('installed', '/', 'dev-java/swt-3.4-r2', 'nomerge')
    x11-libs/cairo required by world
    (and 8 more)

  Explanation:

    New USE for 'x11-libs/cairo:0' are incorrectly set. In order to solve
    this, adjust USE to satisfy '>=x11-libs/cairo-1.7.6[svg,X]'.

app-text/poppler-bindings:0

  ('installed', '/', 'app-text/poppler-bindings-0.10.5-r1', 'nomerge') pulled in by
    ~app-text/poppler-bindings-0.10.5[gtk,cairo] required by ('installed', '/', 'virtual/poppler-glib-0.10.5', 'nomerge')
    ~app-text/poppler-bindings-0.10.5[gtk,cairo] required by ('installed', '/', 'media-gfx/gimp-2.6.4', 'nomerge')
    (and 3 more)

  ('ebuild', '/', 'app-text/poppler-bindings-0.10.5-r1', 'merge') pulled in by
    ~app-text/poppler-bindings-0.10.5[qt3] required by ('installed', '/', 'virtual/poppler-qt3-0.10.5', 'nomerge')
    ~app-text/poppler-bindings-0.10.5[qt3] required by ('ebuild', '/', 'kde-base/kpdf-3.5.10-r1', 'merge')
    app-text/poppler-bindings required by world

  Explanation:

    New USE for 'app-text/poppler-bindings:0' are incorrectly set. In
    order to solve this, adjust USE to satisfy '~app-text/poppler-
    bindings-0.10.5[gtk,cairo]'.

dev-java/swt:3.4

  ('installed', '/', 'dev-java/swt-3.4-r2', 'nomerge') pulled in by
    >=dev-java/swt-3.4:3.4[cairo,xulrunner] required by ('installed', '/', 'net-p2p/vuze-4.2.0.2', 'nomerge')
    (and 1 more)

  ('ebuild', '/', 'dev-java/swt-3.4-r2', 'merge') pulled in by
    dev-java/swt required by world

  Explanation:

    New USE for 'dev-java/swt:3.4' are incorrectly set. In order to solve
    this, adjust USE to satisfy '>=dev-java/swt-3.4:3.4[cairo,xulrunner]'.



 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
zzz025
n00b
n00b


Joined: 06 Nov 2008
Posts: 8

PostPosted: Sun Jun 14, 2009 8:13 am    Post subject: Reply with quote

I am also stuck on emerge -uvDNp world after emerge --sync. This problem has been last for weeks.

I had emerge -C qt:4 already. And it seems no package depends on qt4 by "equery depends qt:4"
command. Here is the snapshot.

# equery depends qt:4
[ Searching for packages depending on qt:4... ]

However, I still keep getting error messages on running emerge -uvDNp. The error messages are
here:
# emerge -vuNDp world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "~x11-libs/qt-gui-4.5.1[qt3support]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-core-4.5.1" [ebuild])
(dependency required by "dev-python/PyQt4-4.4.4-r2" [installed])
(dependency required by "dev-python/qscintilla-python-2.3.2" [installed])
(dependency required by "x11-libs/qscintilla-2.3.2" [installed])
(dependency required by "dev-python/PyQt-3.17.6" [installed])
(dependency required by "media-sound/amarok-1.4.10_p20090130-r2" [ebuild])
(dependency required by "world" [argument])

And here is my emerge --info
# emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-Intel-R-_Pentium-R-_4_CPU_3.00GHz-with-glibc2.0
Timestamp of tree: Fri, 12 Jun 2009 15:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash: 3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python: 2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox: 1.6-r2
sys-devel/autoconf: 2.13, 2.63
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 1.5.26
virtual/os-headers: 2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.twaren.net/Linux/Gentoo/ ftp://ftp.isu.edu.tw/pub/Linux/Gentoo http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US zh_TW ja"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gentoo-taiwan"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi alsa asf berkdb bluetooth branding bzip2 cairo canna cdr charconv chardet cjk cli cracklib crypt cups dbus dri dvd dvdnav dvdr dvdread emboss encode esd evo fam ffmpeg firefox flac fortran gif gnome gpm gstreamer gtk gtk-im gtk2 hal iconv immqt-bc ipv6 isdnlog ja java jpeg jpg kde kerberos latex ldap libnotify mad midi mikmod mmx mmxext mp3 mpeg msn mudflap mysql ncurses nls nptl nptlonly nsplugin nvidia oav ogg opengl openmp pam pcre pdf perl png ppds pppd python qt-im qt3 qt3support qt4 quicktime readline reflection samba sdl session slang spell spl srt sse ssl startup-notification svg sysfs tcl tcpd tetex thunderbird tiff tk truetype unicode usb utf utf-8 vcd vorbis win32codecs wma wmp x86 xine xml xorg xscreensaver xulrunner xv xvid zh_TW zlib" ALSA_CARDS="emu10k1 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US zh_TW ja" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Thanks for help!
Back to top
View user's profile Send private message
Hwoarang
Developer
Developer


Joined: 24 Feb 2007
Posts: 701
Location: Leeds, UK

PostPosted: Sun Jun 14, 2009 9:16 am    Post subject: Reply with quote

Code:
!!! All ebuilds that could satisfy "~x11-libs/qt-gui-4.5.1[qt3support]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/qt-gui-4.5.1-r2 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1-r1 (masked by: ~x86 keyword)
- x11-libs/qt-gui-4.5.1 (masked by: ~x86 keyword)


Do you have x11-libs/qt-gui on your package.keywords file?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8  Next
Page 3 of 8

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum