Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mass downgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
KocetoNS
n00b
n00b


Joined: 17 Oct 2005
Posts: 43
Location: Bulgaria, Nesebar/Sofia

PostPosted: Sat Dec 13, 2008 8:48 am    Post subject: Mass downgrade Reply with quote

Hello
This morning when i tryed to do emerge world i got big list of unwanted downgrades:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD] sys-apps/portage-2.1.6 [2.2_rc14] USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl" 507 kB
*** Portage will stop merging at this point and reload itself,                                             
    then resume the merge.                                                                                 
[ebuild     U ] dev-db/sqlite-3.6.6.2 [3.5.9] USE="threadsafe -debug -doc -soundex -tcl" 2,250 kB         
[ebuild     U ] sys-libs/timezone-data-2008i [2008g-r1] USE="nls" 356 kB                                   
[ebuild  N    ] dev-libs/libical-0.27-r1  1,118 kB                                                         
[ebuild     U ] app-arch/unrar-3.8.5 [3.8.2] 133 kB                                                       
[ebuild     U ] dev-libs/nspr-4.7.3 [4.7.1] USE="ipv6 -debug" 1,226 kB                                     
[ebuild     U ] dev-libs/nss-3.12.2_rc1 [3.12] USE="-utils" 3,874 kB                                       
[ebuild     U ] media-libs/libpng-1.2.33 [1.2.26-r1] 502 kB                                               
[ebuild     U ] sys-apps/man-pages-3.14 [3.10] USE="nls" LINGUAS="-cs -da -de -es -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,015 kB                                                                                       
[ebuild     U ] dev-libs/libxml2-2.7.2-r1 [2.7.2] USE="ipv6 python readline -debug -doc -examples -test (-bootstrap%) (-build%)" 4,679 kB                                                                             
[ebuild     U ] dev-java/java-config-1.3.7-r1 [1.3.7] 15 kB                                               
[ebuild     U ] sys-apps/util-linux-2.14.1 [2.13.1.1] USE="crypt nls unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" 2,861 kB                                                                               
[ebuild     U ] dev-java/sun-jdk-1.6.0.11 [1.6.0.07] USE="alsa nsplugin -X -doc -examples -jce -odbc" 78,184 kB                                                                                                       
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.07] USE="alsa nsplugin -X -odbc" 0 kB                 
[ebuild     U ] x11-terms/xterm-237 [235] USE="unicode -Xaw3d -paste64 -toolbar -truetype" 841 kB         
[ebuild     U ] sys-apps/busybox-1.11.3 [1.11.1] USE="pam -debug -make-symlinks -savedconfig (-selinux) -static" 1,880 kB                                                                                             
[ebuild     U ] app-admin/sudo-1.6.9_p17 [1.6.9_p16] USE="pam -ldap -offensive (-selinux) -skey" 580 kB   
[ebuild  NS   ] sys-kernel/hardened-sources-2.6.25-r11 [2.6.25-r8, 2.6.25-r9] USE="-build -symlink" 47,891 kB                                                                                                         
[ebuild   R   ] sys-fs/cryptsetup-1.0.5-r1  USE="nls -dynamic (-selinux) (-build%)" 315 kB                 
[ebuild  N    ] virtual/perl-Term-ANSIColor-1.12  0 kB                                                     
[ebuild     U ] net-misc/rsync-3.0.4 [3.0.3] USE="acl iconv ipv6 -static -xattr -xinetd" 755 kB           
[ebuild     U ] dev-libs/dbus-glib-0.76 [0.74] USE="-debug -doc (-selinux)" 652 kB                         
[ebuild     U ] dev-util/subversion-1.5.4 [1.5.2] USE="berkdb dso nls perl python webdav-neon -apache2 -bash-completion -debug -doc -emacs -extras -java -ruby -sasl -vim-syntax -webdav-serf" 4,810 kB               
[ebuild     U ] app-arch/dpkg-1.14.22 [1.14.20] USE="bzip2 nls unicode zlib (-selinux) -test" 6,634 kB     
[ebuild     U ] net-libs/gnutls-2.4.1-r2 [2.4.1-r1] USE="nls zlib -bindist -doc -guile -lzo" 4,825 kB     
[ebuild     U ] net-print/cups-1.3.9-r1 [1.3.8-r2] USE="acl pam perl python ssl -X -avahi -dbus -gnutls -java -jpeg -kerberos -ldap -php -png -ppds -samba -slp -static -tiff -xinetd -zeroconf" LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW" 3,901 kB                                                           
[ebuild     U ] app-text/ghostscript-gpl-8.63 [8.62] USE="cups -X -bindist -cairo% -cjk -djvu -gtk -jpeg2k" 14,670 kB                                                                                                 
[ebuild  NS   ] kde-base/kdelibs-3.5.9-r4 [4.1.3-r1] USE="acl alsa cups -arts -avahi -bindist -branding -debug -doc -fam -jpeg2k -kdeenablefinal -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -spell -tiff -utempter -xinerama" 15,242 kB                                                                             
[ebuild     U ] net-libs/xulrunner-1.9.0.4-r1 [1.9.0.3] USE="ipv6 -custom-optimization -dbus -gnome -java -startup-notification" 33,278 kB                                                                           
[ebuild     U ] net-libs/xulrunner-1.8.1.18-r1 [1.8.1.17] USE="ipv6 -debug -gnome -java -xinerama -xprint" 37,271 kB                                                                                                 
[ebuild  N    ] kde-base/libkdenetwork-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 14,159 kB       
[ebuild  N    ] kde-base/libkmime-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                 
[ebuild  NS   ] kde-base/libkonq-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 23,672 kB                                                                                           
[ebuild  NS   ] kde-base/kdebase-data-3.5.9 [4.1.3] USE="-debug -kdeenablefinal -xinerama" 0 kB           
[ebuild  N    ] kde-base/ktnef-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                   
[ebuild  NS   ] kde-base/mimelib-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB           
[ebuild  NS   ] kde-base/libksieve-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB         
[ebuild  NS   ] kde-base/libkpgp-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB           
[ebuild  NS   ] kde-base/kmailcvt-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB         
[ebuild  NS   ] kde-base/kdesu-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 39 kB                                                                                                 
[ebuild  NS   ] kde-base/kcminit-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                                 
[ebuild  NS   ] kde-base/khotkeys-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                               
[ebuild  NS   ] kde-base/kdialog-3.5.9-r1 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                             
[ebuild  NS   ] kde-base/libkholidays-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB     
[ebuild  NS   ] kde-base/kode-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB             
[ebuild  NS   ] kde-base/kcalc-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 2,990 kB                                                                                               
[ebuild  NS   ] kde-base/kjots-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                                   
[ebuild  NS   ] kde-base/ksnapshot-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 7,268 kB     
[ebuild  NS   ] kde-base/kmix-3.5.9 [4.1.3] USE="alsa -arts -debug -kdeenablefinal -xinerama" 6,180 kB     
[ebuild  NS   ] kde-base/kcharselect-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                             
[ebuild  NS   ] kde-base/kget-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 9,121 kB                                                                                               
[ebuild  NS   ] kde-base/ark-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB                                                                                                     
[ebuild  NS   ] kde-base/krdc-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -rdesktop -slp -xinerama" 0 kB                                                                                     
[ebuild     U ] www-client/mozilla-firefox-3.0.4-r2 [3.0.3] USE="ipv6 java xulrunner -bindist -custom-optimization -dbus -gnome -iceweasel -mozdevelop -restrict-javascript -startup-notification" LINGUAS="-af -ar -be -bg% -bn -bn_IN -ca -cs -cy% -da -de -el -en -en_GB -en_US -eo% -es -es_AR -es_ES -et% -eu -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hu -id -is -it -ja -ka -kn -ko -ku -lt -lv% -mk -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc% -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -te% -th -tr -uk -zh -zh_CN -zh_TW" 11,275 kB                                                                     
[ebuild  N    ] kde-base/libkcal-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 131 kB               
[ebuild  N    ] kde-base/certmanager-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB             
[ebuild  NS   ] kde-base/kdebase-kioslaves-3.5.9 [4.1.3] USE="-arts -debug -hal -kdeenablefinal -kdehiddenvisibility -ldap -openexr -samba -xinerama" 39 kB                                                           
[ebuild  N    ] kde-base/kdepim-kioslaves-3.5.9  USE="-arts -debug -kdeenablefinal -sasl -xinerama" 0 kB   
[ebuild  N    ] kde-base/kicker-3.5.9  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xcomposite -xinerama" 21 kB                                                                                           
[ebuild  NS   ] kde-base/libkdepim-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB         
[ebuild  N    ] kde-base/libkpimexchange-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB         
[ebuild  NS   ] kde-base/khelpcenter-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 9 kB                                                                                             
[ebuild  N    ] kde-base/libkpimidentities-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB       
[ebuild  NS   ] kde-base/kcontrol-3.5.9 [4.1.3] USE="-arts -debug -ieee1394 -joystick -kdeenablefinal -kdehiddenvisibility -logitech-mouse -opengl -xinerama" 38 kB                                                   
[ebuild  N    ] kde-base/kontact-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                 
[ebuild  NS   ] kde-base/kaddressbook-3.5.9 [4.1.3] USE="-arts -debug -gnokii -kdeenablefinal -xinerama" 0 kB                                                                                                         
[ebuild  NS   ] kde-base/kmail-3.5.9 [4.1.3] USE="crypt -arts -debug -kdeenablefinal -xinerama" 0 kB       
[ebuild  NS   ] kde-base/kdepim-kresources-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/korganizer-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB       
[ebuild     U ] dev-libs/soprano-2.1.1 [2.1] USE="clucene sesame2 -debug -doc -redland" 1,789 kB           
[ebuild     UD] x11-libs/qt-4.3.3 [4.4.2] USE="accessibility%* cups%* qt3support* ssl%* zlib%* -dbus -debug% -doc% -examples% -firebird% -gif% -glib% -jpeg% -mng% -mysql% -nas% -nis% -odbc% -opengl -pch% -png% -postgres% -sqlite% -sqlite3% -tiff% -xinerama%" INPUT_DEVICES="-wacom%" 41,350 kB                             
[uninstall    ] x11-libs/qt-assistant-4.4.2  USE="webkit -debug -pch"                                     
[uninstall    ] x11-libs/qt-xmlpatterns-4.4.2  USE="-debug -pch"                                           
[blocks b     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-assistant-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2)                                                           
[blocks B     ] x11-libs/qt-core ("x11-libs/qt-core" is blocking x11-libs/qt-4.3.3)                       
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 ("<=x11-libs/qt-4.4.0_alpha:4" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-script-4.4.2, x11-libs/qt-dbus-4.4.2, x11-libs/qt-assistant-4.4.2, x11-libs/qt-qt3support-4.4.2, x11-libs/qt-sql-4.4.2, x11-libs/qt-gui-4.4.2, x11-libs/qt-svg-4.4.2, x11-libs/qt-test-4.4.2, x11-libs/qt-core-4.4.2, x11-libs/qt-webkit-4.4.2)                                                           

Total: 71 packages (26 upgrades, 2 downgrades, 12 new, 30 in new slots, 1 reinstall, 2 uninstalls), Size of downloads: 388,323 kB                                                                                     
Conflict: 3 blocks (2 unsatisfied)                                                                         

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):   

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


I really like KDE4 look and feel but i`m getting pissed of that masking, unmasking and etc.
Back to top
View user's profile Send private message
Abraxas
l33t
l33t


Joined: 25 May 2003
Posts: 793

PostPosted: Sat Dec 13, 2008 1:45 pm    Post subject: Reply with quote

That will happen if you're mixing stable and unstable packages. I like to test out some unstable packages so it requires me to constantly edit my package.keywords file. It's just the nature of the beast. If you won't want to deal with it then the only thing you can do is wait until KDE4 is stable.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32091
Location: 56N 3W

PostPosted: Sat Dec 13, 2008 2:03 pm    Post subject: Reply with quote

KocetoNS,

You are using a mix of testing and stable. Portage-2.2-rc* has been hard masked in favour of 2.1.6, which is a downgrade for you. Unfortunately you need Portage-2-2 for your KDE, which is being downgraded as a consequence of portage.

Unmask portage in /etc/portage/package.unmask
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
KocetoNS
n00b
n00b


Joined: 17 Oct 2005
Posts: 43
Location: Bulgaria, Nesebar/Sofia

PostPosted: Sun Dec 14, 2008 10:31 am    Post subject: Reply with quote

Okey i`ve unmasked portage and emerged the latests.But when trying to emerge world there is still installs kde3 in a new slot.

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-db/sqlite-3.6.6.2 [3.5.9] USE="threadsafe -debug -doc -soundex -tcl" 2,250 kB
[ebuild     U ] sys-libs/timezone-data-2008i [2008g-r1] USE="nls" 356 kB                         
[ebuild  N    ] dev-libs/libical-0.27-r1  1,118 kB                                               
[ebuild     U ] app-arch/unrar-3.8.5 [3.8.2] 133 kB                                             
[ebuild     U ] dev-libs/nspr-4.7.3 [4.7.1] USE="ipv6 -debug" 1,226 kB                           
[ebuild     U ] dev-libs/nss-3.12.2_rc1 [3.12] USE="-utils" 3,874 kB                             
[ebuild     U ] media-libs/libpng-1.2.33 [1.2.26-r1] 502 kB                                     
[ebuild     U ] sys-apps/man-pages-3.14 [3.10] USE="nls" LINGUAS="-cs -da -de -es -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,015 kB
[ebuild     U ] dev-libs/libxml2-2.7.2-r1 [2.7.2] USE="ipv6 python readline -debug -doc -examples -test (-bootstrap%) (-build%)" 4,679 kB                                                                                                                         
[ebuild     U ] dev-java/java-config-1.3.7-r1 [1.3.7] 15 kB                                                                     
[ebuild     U ] sys-apps/util-linux-2.14.1 [2.13.1.1] USE="crypt nls unicode -loop-aes -old-linux (-selinux) -slang (-uclibc)" 2,861 kB                                                                                                                           
[ebuild     U ] x11-terms/xterm-237 [235] USE="unicode -Xaw3d -paste64 -toolbar -truetype" 841 kB                               
[ebuild     U ] sys-apps/busybox-1.11.3 [1.11.1] USE="pam -debug -make-symlinks -savedconfig (-selinux) -static" 1,880 kB       
[ebuild     U ] app-admin/sudo-1.6.9_p17 [1.6.9_p16] USE="pam -ldap -offensive (-selinux) -skey" 580 kB                         
[ebuild     U ] dev-java/sun-jdk-1.6.0.11 [1.6.0.07] USE="alsa nsplugin -X -doc -examples -jce -odbc" 78,184 kB                 
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.07] USE="alsa nsplugin -X -odbc" 0 kB                                       
[ebuild  NS   ] sys-kernel/hardened-sources-2.6.25-r11 [2.6.25-r8, 2.6.25-r9] USE="-build -symlink" 47,891 kB                   
[ebuild   R   ] sys-fs/cryptsetup-1.0.5-r1  USE="nls -dynamic (-selinux) (-build%)" 315 kB                                       
[ebuild  N    ] virtual/perl-Term-ANSIColor-1.12  0 kB                                                                           
[ebuild     U ] net-misc/rsync-3.0.4 [3.0.3] USE="acl iconv ipv6 -static -xattr -xinetd" 755 kB                                 
[ebuild     U ] dev-libs/dbus-glib-0.76 [0.74] USE="-debug -doc (-selinux)" 652 kB                                               
[ebuild     U ] dev-util/subversion-1.5.4 [1.5.2] USE="berkdb dso nls perl python webdav-neon -apache2 -bash-completion -debug -doc -emacs -extras -java -ruby -sasl -vim-syntax -webdav-serf" 4,810 kB                                                           
[ebuild     U ] app-arch/dpkg-1.14.22 [1.14.20] USE="bzip2 nls unicode zlib (-selinux) -test" 6,634 kB                           
[ebuild     U ] net-libs/gnutls-2.4.1-r2 [2.4.1-r1] USE="nls zlib -bindist -doc -guile -lzo" 4,825 kB                           
[ebuild     U ] net-print/cups-1.3.9-r1 [1.3.8-r2] USE="acl pam perl python ssl -X -avahi -dbus -gnutls -java -jpeg -kerberos -ldap -php -png -ppds -samba -slp -static -tiff -xinetd -zeroconf" LINGUAS="-de -en -es -et -fr -he -id -it -ja -pl -sv -zh_TW" 3,901 kB                                                                                                                             
[ebuild     U ] app-text/ghostscript-gpl-8.63 [8.62] USE="cups -X -bindist -cairo% -cjk -djvu -gtk -jpeg2k" 14,670 kB           
[ebuild  NS   ] kde-base/kdelibs-3.5.9-r4 [4.1.3-r1] USE="acl alsa cups -arts -avahi -bindist -branding -debug -doc -fam -jpeg2k -kdeenablefinal -kdehiddenvisibility -kerberos -legacyssl -lua -openexr -spell -tiff -utempter -xinerama" 15,242 kB             
[ebuild     UD] www-client/mozilla-firefox-2.0.0.18 [3.0.3] USE="ipv6 java -bindist -debug% -filepicker% -gnome -iceweasel -mozdevelop -moznopango% -restrict-javascript -xforms% -xinerama% -xprint% (-custom-optimization%) (-dbus%) (-startup-notification%) (-xulrunner%*)" LINGUAS="-af -ar -be -bg% -ca -cs -da -de -el -en -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW (-bn%) (-bn_IN%) (-gl%) (-hi%) (-hi_IN%) (-id%) (-is%) (-kn%) (-mr%) (-si%) (-sq%) (-sr%) (-th%)" 39,379 kB                                                                                                                   
[ebuild     U ] net-libs/xulrunner-1.8.1.18-r1 [1.8.1.17] USE="ipv6 -debug -gnome -java -xinerama -xprint" 37,271 kB             
[ebuild     U ] net-libs/xulrunner-1.9.0.4-r1 [1.9.0.3] USE="ipv6 -custom-optimization -dbus -gnome -java -startup-notification" 33,278 kB                                                                                                                       
[ebuild  N    ] kde-base/libkdenetwork-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 14,159 kB                             
[ebuild  N    ] kde-base/libkmime-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                                       
[ebuild  NS   ] kde-base/libkonq-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 23,672 kB       
[ebuild  NS   ] kde-base/kdebase-data-3.5.9 [4.1.3] USE="-debug -kdeenablefinal -xinerama" 0 kB                                 
[ebuild  N    ] kde-base/ktnef-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                                         
[ebuild  NS   ] kde-base/mimelib-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                                 
[ebuild  NS   ] kde-base/libksieve-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                               
[ebuild  NS   ] kde-base/libkpgp-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                                 
[ebuild  NS   ] kde-base/kmailcvt-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                               
[ebuild  NS   ] kde-base/kdesu-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 39 kB             
[ebuild  NS   ] kde-base/kcminit-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB           
[ebuild  NS   ] kde-base/khotkeys-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB           
[ebuild  NS   ] kde-base/kdialog-3.5.9-r1 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB         
[ebuild  NS   ] kde-base/libkholidays-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                           
[ebuild  NS   ] kde-base/kode-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB                                   
[ebuild  NS   ] kde-base/kcalc-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 2,990 kB         
[ebuild  NS   ] kde-base/kjots-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB
[ebuild  NS   ] kde-base/ksnapshot-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 7,268 kB
[ebuild  NS   ] kde-base/kmix-3.5.9 [4.1.3] USE="alsa -arts -debug -kdeenablefinal -xinerama" 6,180 kB
[ebuild  NS   ] kde-base/kcharselect-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB
[ebuild  NS   ] kde-base/kget-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 9,121 kB
[ebuild  NS   ] kde-base/ark-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB

[ebuild  NS   ] kde-base/krdc-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -rdesktop -slp -xinerama" 0 kB
[ebuild  N    ] kde-base/libkcal-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 131 kB
[ebuild  N    ] kde-base/certmanager-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/kdebase-kioslaves-3.5.9 [4.1.3] USE="-arts -debug -hal -kdeenablefinal -kdehiddenvisibility -ldap -openexr -samba -xinerama" 39 kB
[ebuild  N    ] kde-base/kdepim-kioslaves-3.5.9  USE="-arts -debug -kdeenablefinal -sasl -xinerama" 0 kB
[ebuild  N    ] kde-base/kicker-3.5.9  USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xcomposite -xinerama" 21 kB
[ebuild  NS   ] kde-base/libkdepim-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  N    ] kde-base/libkpimexchange-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/khelpcenter-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 9 kB
[ebuild  N    ] kde-base/libkpimidentities-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/kcontrol-3.5.9 [4.1.3] USE="-arts -debug -ieee1394 -joystick -kdeenablefinal -kdehiddenvisibility -logitech-mouse -opengl -xinerama" 38 kB
[ebuild  N    ] kde-base/kontact-3.5.9  USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/kaddressbook-3.5.9 [4.1.3] USE="-arts -debug -gnokii -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/kmail-3.5.9 [4.1.3] USE="crypt -arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/kdepim-kresources-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild  NS   ] kde-base/korganizer-3.5.9 [4.1.3] USE="-arts -debug -kdeenablefinal -xinerama" 0 kB
[ebuild     U ] dev-libs/soprano-2.1.1 [2.1] USE="clucene sesame2 -debug -doc -redland" 1,789 kB

Total: 69 packages (25 upgrades, 1 downgrade, 12 new, 30 in new slots, 1 reinstall), Size of downloads: 374,572 kB

Would you like to merge these packages? [Yes/No]


Thank You
Back to top
View user's profile Send private message
widremann
Veteran
Veteran


Joined: 14 Mar 2005
Posts: 1314

PostPosted: Sun Dec 14, 2008 4:32 pm    Post subject: Reply with quote

It's not downgrading. Notice that it says "NS" and not "UD" next to those packages. That means it wants to install KDE 3.5 alongside KDE 4. You can mask KDE packages < 4.0.0 or try to figure out what's bringing in KDE 3. You can use emerge --pv --tree to find that out.
Back to top
View user's profile Send private message
manji_
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2007
Posts: 120

PostPosted: Mon Feb 23, 2009 11:25 pm    Post subject: Reply with quote

I have the same problem. Did you find maybe which package demands the kde 3.5.9 libs?
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Mon Feb 23, 2009 11:36 pm    Post subject: Reply with quote

KDE 4.1 was recently removed from the tree because there is KDE 4.2 now, which is much more stable and usable. You probably just need to update your package.keywords for KDE 4.2.
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
manji_
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2007
Posts: 120

PostPosted: Tue Feb 24, 2009 12:16 am    Post subject: Reply with quote

Thank you for you reply. I did update the new keywords for kde 4.2, but now I see these blocks:

Code:
...

[ebuild  NS   ] kde-base/kde-l10n-4.2.0 [4.1.4] USE="-htmlhandbook -kdeprefix" LINGUAS="el -ar -bg -bn_IN -ca -cs -csb -da -de -en_GB -es -et -eu -fi -fr -ga -gl -gu -he -hi -hu -is -it -ja -kk -km -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -sl -sr -sv -tg -th -tr -uk -wa -zh_CN -zh_TW" 2,078 kB                                                                                                                       
[uninstall    ] kde-base/kde-l10n-4.1.4  USE="-htmlhandbook -kdeprefix" LINGUAS="el -bg -ca -cs -csb -da -de -en_GB -eo -es -et -fi -fr -fy -ga -gl -hi -hu -it -ja -kk -km -ko -ku -lt -lv -mk -ml -nb -nds -nl -nn -pa -pl -pt -pt_BR -ru -sl -sr -sv -ta -th -tr -uk -wa -zh_CN -zh_TW"                   
[blocks b     ] kde-base/kde-l10n:4.2[-kdeprefix] ("kde-base/kde-l10n:4.2[-kdeprefix]" is blocking kde-base/kde-l10n-4.1.4)                           
[blocks b     ] kde-base/kde-l10n:4.1[-kdeprefix] ("kde-base/kde-l10n:4.1[-kdeprefix]" is blocking kde-base/kde-l10n-4.2.0)                           
[blocks B     ] kde-base/kdebase-data:4.2[-kdeprefix] ("kde-base/kdebase-data:4.2[-kdeprefix]" is blocking kde-base/kdebase-data-4.1.4)               
[blocks B     ] kde-base/kdebase-data:4.1[-kdeprefix] ("kde-base/kdebase-data:4.1[-kdeprefix]" is blocking kde-base/kdebase-data-4.2.0)               
[blocks B     ] kde-base/kdelibs:4.1[-kdeprefix] ("kde-base/kdelibs:4.1[-kdeprefix]" is blocking kde-base/kdelibs-4.2.0-r3)                           
[blocks B     ] <kde-base/dolphin-4.1.87[-kdeprefix] ("<kde-base/dolphin-4.1.87[-kdeprefix]" is blocking kde-base/kdebase-data-4.2.0)                 
[blocks B     ] <kde-base/kdelibs-3.5.10 ("<kde-base/kdelibs-3.5.10" is blocking kde-base/kdelibs-4.2.0-r3)                                           
[blocks B     ] kde-base/kdelibs:4.2[-kdeprefix] ("kde-base/kdelibs:4.2[-kdeprefix]" is blocking kde-base/kdelibs-4.1.4)                               
[blocks B     ] kde-base/libplasma[-kdeprefix] ("kde-base/libplasma[-kdeprefix]" is blocking kde-base/kdelibs-4.2.0-r3)                               

Total: 12 packages (4 upgrades, 1 downgrade, 3 new, 4 in new slots, 3 uninstalls), Size of downloads: 87,862 kB
Conflict: 12 blocks (7 unsatisfied)                                                                           

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.                 

  ('installed', '/', 'kde-base/libplasma-4.1.4', 'nomerge') pulled in by
    >=kde-base/libplasma-4.1.4:4.1 required by ('installed', '/', 'kde-base/ksysguard-4.1.4', 'nomerge')
    kde-base/libplasma:4.1 required by ('installed', '/', 'kde-base/plasma-apps-4.1.4', 'nomerge')     
    >=kde-base/libplasma-4.1.4:4.1 required by ('installed', '/', 'kde-base/plasma-workspace-4.1.4', 'nomerge')
    (and 2 more)                                                                                               

  ('installed', '/', 'kde-base/kdelibs-3.5.9-r4', 'nomerge') pulled in by
    =kde-base/kdelibs-3.5* required by ('installed', '/', 'app-cdr/k3b-1.0.5-r3', 'nomerge')

  ('ebuild', '/', 'kde-base/kdebase-data-4.2.0', 'merge') pulled in by
    >=kde-base/kdebase-data-4.1.4[-kdeprefix] required by ('installed', '/', 'kde-base/kde-menu-icons-4.1.4', 'nomerge')
    >=kde-base/kdebase-data-4.1[-kdeprefix] required by ('installed', '/', 'kde-misc/kshutdown-2.0_beta4', 'nomerge')   
    >=kde-base/kdebase-data-4.1.4[-kdeprefix] required by ('installed', '/', 'kde-base/ark-4.1.4', 'nomerge')           
    (and 74 more)                                                                                                       

  ('installed', '/', 'kde-base/dolphin-4.1.4', 'nomerge') pulled in by
    kde-base/dolphin required by @world
    >=kde-base/dolphin-4.1.4:4.1 required by ('installed', '/', 'kde-base/plasma-workspace-4.1.4', 'nomerge')

  ('ebuild', '/', 'kde-base/kdelibs-4.2.0-r3', 'merge') pulled in by
    >=kde-base/kdelibs-4.1.4[-kdeprefix] required by ('installed', '/', 'kde-base/kdeartwork-iconthemes-4.1.4', 'nomerge')
    >=kde-base/kdelibs-4.1.4[-kdeprefix] required by ('installed', '/', 'kde-base/nepomuk-4.1.4', 'nomerge')
    >=kde-base/kdelibs-4.1.4[-kdeprefix] required by ('installed', '/', 'kde-base/kdebugdialog-4.1.4', 'nomerge')
    (and 79 more)

  ('installed', '/', 'kde-base/kdebase-data-4.1.4', 'nomerge') pulled in by
    >=kde-base/kdebase-data-4.1.4:4.1 required by ('installed', '/', 'kde-base/krunner-4.1.4', 'nomerge')
    >=kde-base/kdebase-data-4.1.4:4.1 required by ('installed', '/', 'kde-base/kdebase-startkde-4.1.4', 'nomerge')
    >=kde-base/kdebase-data-4.1.4:4.1 required by ('installed', '/', 'kde-base/ksysguard-4.1.4', 'nomerge')
    (and 1 more)

...

Any ideas?
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Tue Feb 24, 2009 8:54 am    Post subject: Reply with quote

You can't install multiple versions of KDE4 with the kdeprefix use flag disabled. When kdeprefix is disabled, everything is installed directly under /usr. When it's enabled, everything is installed under /usr/kde/<ver>/
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
manji_
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2007
Posts: 120

PostPosted: Tue Feb 24, 2009 9:01 am    Post subject: Reply with quote

I don't want multiple versions. I just want to upgrade to 4.2. So, should I just unmerge the blocking kde4.1 packages?

Also, why do these kde3.5.9 libs still demand to be emerged?
Back to top
View user's profile Send private message
yngwin
Developer
Developer


Joined: 19 Dec 2002
Posts: 4394
Location: Suzhou, China

PostPosted: Tue Feb 24, 2009 10:07 am    Post subject: Reply with quote

manji_ wrote:
Also, why do these kde3.5.9 libs still demand to be emerged?

Because you have a kde3 program installed: k3b, as it says:
Code:
('installed', '/', 'kde-base/kdelibs-3.5.9-r4', 'nomerge') pulled in by
    =kde-base/kdelibs-3.5* required by ('installed', '/', 'app-cdr/k3b-1.0.5-r3', 'nomerge')

You either need to unmerge that, or keyword the latest kde 3.5.10.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
manji_
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2007
Posts: 120

PostPosted: Tue Feb 24, 2009 1:14 pm    Post subject: Reply with quote

Ok thank you, I'll do that. And what about the blocking kde4.1 packages? Does anyone have any idea?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum