Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Best upgrade method to Xserver1.5 with Hal and evdev
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 23

PostPosted: Thu Aug 06, 2009 8:49 am    Post subject: Reply with quote

piponazo wrote:
when I'm exiting of the system (Gnome desktop environment), the mouse and keyboard become freeze, and the the screen don't show information about the stopping process of the services. Always it is shown the desktop wallpaper until the system is shut down definitely.


I saw that couple of times with ati, but did not find it specially annoying. I think it is video-driver related. Do you use framebuffer for console in the kernel? You can try to switch it off.
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 23

PostPosted: Thu Aug 06, 2009 8:52 am    Post subject: Reply with quote

Anon-E-moose wrote:

I was getting that error earlier, it seems that when I upgraded to xorg 1.6.3 it put its xorg-server.conf in /etc/X11/dbus-1/system.d and
it really belongs in /etc/dbus-1/system.d. I copied it to where it belongs and it shut up about the Access Denied.
YMMV


yes, on both laptops I'm no more getting the error in the Xorg.log :)
but the mouse-synaptics problem with X taking 100% of cpu on the first laptop still exists :?
Back to top
View user's profile Send private message
piponazo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2008
Posts: 102
Location: Córdoba - Spain

PostPosted: Thu Aug 06, 2009 9:34 am    Post subject: Reply with quote

trubicoid wrote:
piponazo wrote:
when I'm exiting of the system (Gnome desktop environment), the mouse and keyboard become freeze, and the the screen don't show information about the stopping process of the services. Always it is shown the desktop wallpaper until the system is shut down definitely.


I saw that couple of times with ati, but did not find it specially annoying. I think it is video-driver related. Do you use framebuffer for console in the kernel? You can try to switch it off.


Before the updating of xorg conf all runs correctly: first gnome session ends, then xorg, and after that in a tty I can saw all the messages related with the stopping of services. So I think that must be a problem with the new configuration with hal and evdev.
_________________
La plaga tux! ;)
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 23

PostPosted: Thu Aug 06, 2009 10:01 am    Post subject: Reply with quote

piponazo wrote:
So I think that must be a problem with the new configuration with hal and evdev.


well, it's just about input devices...
did you update nvidia-drivers after xorg-server? (maybe it is done automatically)
Back to top
View user's profile Send private message
piponazo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2008
Posts: 102
Location: Córdoba - Spain

PostPosted: Thu Aug 06, 2009 10:28 am    Post subject: Reply with quote

trubicoid wrote:
piponazo wrote:
So I think that must be a problem with the new configuration with hal and evdev.


well, it's just about input devices...
did you update nvidia-drivers after xorg-server? (maybe it is done automatically)


I have installed the last stable version 180.60. Do you think that upgrading the drivers to 185.XX will solve the problem ?
_________________
La plaga tux! ;)
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 23

PostPosted: Fri Aug 07, 2009 7:23 am    Post subject: Reply with quote

maybe...
but my point was to always emerge nvidia-drivers after updating xorg-server, even if it is still the same version of nvidia-drivers
Back to top
View user's profile Send private message
piponazo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2008
Posts: 102
Location: Córdoba - Spain

PostPosted: Fri Aug 07, 2009 7:42 am    Post subject: Reply with quote

Thanks trubicoid it seems that this was the problem. In one of my computers I simply recompile the nvidia driver 180.60. and in other I update to the 185.XX and now, the X session ends correctly and I can see the closing messages of the services in the TTY :wink: .

I would like to do another question. Once the Xorg 1.5.3 configuration with the fdi file and the evdev driver is running correctly, I tried to update to the Xorg. 1.6.3 but while the xorg session starts correctly and I can see the GDM screen, I can't handle neither the keyboard or mouse again.

There is any "trick" to change from xorg-server from 1.5.3 to 1.6.3 to solve this kind of problems ?
_________________
La plaga tux! ;)
Back to top
View user's profile Send private message
trubicoid
n00b
n00b


Joined: 04 Aug 2009
Posts: 23

PostPosted: Fri Aug 07, 2009 8:40 am    Post subject: Reply with quote

I guess it is the same story, you need to re-emerge all your x11-drivers after xorg upgrade including xf86-input-evdev;
btw. I think it is written as a message after xorg emerge

to find out what x11-drivers you need to re-emerge do:
Code:
qlist -I -C x11-drivers


qlist is in portage-utils
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Fri Aug 07, 2009 8:45 pm    Post subject: Reply with quote

In fact, everytime that you update your xorg-server you need to recompile all of your x11-drivers.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
piponazo
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2008
Posts: 102
Location: Córdoba - Spain

PostPosted: Sun Aug 09, 2009 10:30 am    Post subject: Reply with quote

Thanks you very much for your suggests :D. Finally I have running correctly my gentoo system with xorg-server 1.6.3 and nvidia drivers 185.18.14 (with latest drivers I have problems in my laptop)
_________________
La plaga tux! ;)
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Sun Aug 23, 2009 1:16 pm    Post subject: Reply with quote

I've upgraded from KDE 3.5.10 to KDE 4.2 following the gentoo guide. I believe that this also caused my Xorg to be updated and since then I'm having problems typing characters like ë ê é è
The keyboard seems to work perfectly but when I try an ë I just end up with "e

What I've done:
I'm using the default "10-x11-input.fdi" file
Removed all references to keyboard and mouse in xorg.conf
Recompiled all the input-drivers

But nothing helps. My xorg log is without errors and correctly reports my mouse and keyboard:
Code:

(II) config/hal: Adding input device Logitech USB-PS/2 Optical Mouse                                                                       
(II) LoadModule: "evdev"                                                                                                                   

(II) Loading /usr/lib64/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.5.3, module version = 2.1.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) Logitech USB-PS/2 Optical Mouse: always reports core events
(**) Logitech USB-PS/2 Optical Mouse: Device: "/dev/input/event3"
(II) Logitech USB-PS/2 Optical Mouse: Found 4 mouse buttons
(II) Logitech USB-PS/2 Optical Mouse: Found x and y relative axes
(II) Logitech USB-PS/2 Optical Mouse: Configuring as mouse
(**) Logitech USB-PS/2 Optical Mouse: YAxisMapping: buttons 4 and 5
(**) Logitech USB-PS/2 Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Logitech USB-PS/2 Optical Mouse" (type: MOUSE)
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"


my make.conf
Code:

USE="hal andalotofothers"
INPUT_DEVICES="keyboard mouse evdev"
VIDEO_CARDS="nvidia"


hal fdi file
Code:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <!-- FIXME: Support tablets too. -->
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.touchpad">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.x11_driver" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>
  </device>
</deviceinfo>


locale.gen
Code:

#en_US ISO-8859-1
en_GB.UTF-8 UTF-8
en_US.UTF-8 UTF-8
#ja_JP.EUC-JP EUC-JP
#ja_JP.UTF-8 UTF-8
#ja_JP EUC-JP
#en_HK ISO-8859-1
#en_PH ISO-8859-1
#de_DE ISO-8859-1
#de_DE@euro ISO-8859-15
#es_MX ISO-8859-1
#fa_IR UTF-8
#fr_FR ISO-8859-1
#fr_FR@euro ISO-8859-15
#it_IT ISO-8859-1


Since I've got no serious errors anywhere I assume I messed up somewhere a little bit or forgot to recompile something...

edit:
on a funny side note: my windows session in vmware works perfectly with ë
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Sun Aug 23, 2009 7:51 pm    Post subject: Reply with quote

Hi, did you change anything inside /etc/conf.d/consolefont ?
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Mon Aug 24, 2009 10:31 am    Post subject: Reply with quote

d2_racing wrote:
Hi, did you change anything inside /etc/conf.d/consolefont ?


No, the only entries I have there are
CONSOLEFONT="default8x16"
#CONSOLETRANSLATION="8859-1_to_uni"
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Aug 24, 2009 5:27 pm    Post subject: Reply with quote

Try to enable this line CONSOLETRANSLATION="8859-1_to_uni"

and then reboot.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Mon Aug 24, 2009 9:48 pm    Post subject: Reply with quote

d2_racing wrote:
Try to enable this line CONSOLETRANSLATION="8859-1_to_uni"

and then reboot.


I'm afraid it didn't help. Nothing seems to have changed.
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Sat Aug 29, 2009 9:45 am    Post subject: Reply with quote

nobody any idea?
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Sat Aug 29, 2009 8:51 pm    Post subject: Reply with quote

Hi, can you post this :

Code:

# emerge --info
# cat /etc/locale.gen
# cat /etc/conf.d/consolefont

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
Neo2
Apprentice
Apprentice


Joined: 25 Sep 2006
Posts: 224
Location: Italy

PostPosted: Sun Aug 30, 2009 9:46 am    Post subject: Reply with quote

Try to manually specify the keyboard layout and model in the fdi file:
Code:
fabio@gentoo-node1 ~ $ cat /etc/hal/fdi/policy/10-keymap.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<match key="info.capabilities" contains="input.keyboard">
        <merge key="input.x11_driver" type="string">evdev</merge>
        <merge key="input.xkb.layout" type="string">it</merge>
        <merge key="input.xkb.model" type="string">microsoftmult</merge>
</match>

Evdev doesn't know which layout you're supposed to have, and defaults to "us". Since you are using en_GB and en_US locales, you may need to alter the keyboard model setting.
Quote:
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"

If the problem doesn't show up in the console but only during KDE sessions, you may need to re-enter your settings in System Settings -> Language and Country:
-> Ensure that "State or region" is set correctly or click onto the blue "change..." link. In the right lower corner, select your language from one of the installed ones through "Add language" and make sure it appears as the first one in the list. Click apply.
-> From the left menu, click "Keyboard mappings" and select "Enable keyboard mappings", from the dropdown list select "Evdev-managed keyboard". On the active mappings, check that you have your layout specified (usually it defaults to "us"). Add/Remove the mappings you need by selecting them from the lists and using the green arrows at the top. Click apply.

Cheers,
Neo2
_________________
Neo2
Unofficial minimal liveCD for x86/amd64 w/reiser4+truecrypt
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Sun Aug 30, 2009 11:58 am    Post subject: Reply with quote

ah! that got me pointed a the right direction :)

I've found that the problem is that indeed the keyboard layout is faulty. It works great if I set it manually with:
Code:

setxkbmap us_intl


But specifying it in the fdi file changes nothing

Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keyboard">
        <merge key="input.x11_driver" type="string">evdev</merge>
        <merge key="input.xkb.layout" type="string">us_intl</merge>
        <merge key="input.xkb.model" type="string">hp250x</merge>
    </match
  </device>
</deviceinfo>


I've currently sort of fixed it by adding the setxkbmap us_intl to my .xinitrc file.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5654

PostPosted: Sun Aug 30, 2009 6:23 pm    Post subject: Reply with quote

Most probably, either your fdi file has incorrect syntax,
or you're setting invalid values - there's a difference between
layout and variant, see /usr/share/X11/xkb/rules/evdev.lst.
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Sun Aug 30, 2009 6:24 pm    Post subject: Reply with quote

You should post your /etc/X11/xorg.conf, because I found that certains options can block evdev from working properly.
_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Mon Aug 31, 2009 12:35 pm    Post subject: Reply with quote

I'll look into the fdi syntax, there must be another user with a us intl keyboard...

Here's my Xorg.conf. I't has some funny comments since I've been using this one since mandrake 6.0, editting it when needed.

Code:

# File generated by XFdrake.           

# **********************************************************************
# Refer to the XF86Config man page for details about the format of     
# this file.                                                           
# **********************************************************************

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.                                         
   FontPath    "/usr/share/fonts/misc/:unscaled"                             
   FontPath    "/usr/share/fonts/Type1/"                                     
   FontPath    "/usr/share/fonts/TTF/"                                       
   FontPath    "/usr/share/fonts/corefonts/"                                 
   FontPath    "/usr/share/fonts/freefont/"                                 
   FontPath    "/usr/share/fonts/sharefonts/"                               
   FontPath    "/usr/share/fonts/terminus/"                                 
   FontPath    "/usr/share/fonts/ttf-bitstream-vera/"                       
   FontPath    "/usr/share/fonts/unifont/"                                   
   FontPath    "/usr/share/fonts/75dpi/:unscaled"                           
   FontPath    "/usr/share/fonts/100dpi/:unscaled"                           
   FontPath    "/usr/share/fonts/artwiz/"                                   
   FontPath "/usr/X11R6/lib/X11/fonts/local/"                               
   FontPath "/usr/X11R6/lib/X11/fonts/misc/"                                 
    FontPath "/usr/X11R6/lib/X11/75dpi/:unscaled"                           
    FontPath "/usr/X11R6/lib/X11/100dpi/:unscaled"                           
    FontPath "/usr/X11R6/lib/X11/Type1/"                                     
    FontPath "/usr/X11R6/lib/X11/Speedo/"                                   
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"                               
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"                             
    #FontPath "unix/:-1"                                                     
EndSection                                                                   

Section "ServerFlags"
    Option "AutoAddDevices" "on"
    Option "AutoEnableDevices" "on"
    Option "AllowEmptyInput" "on"   
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work                                                                     
    #AllowEmptyInput                                                                                                                                       
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)                                                                                     
EndSection                                                                                                                                                 
                                                                                                                                                           
Section "Module"                                                                                                                                           
    Load "dbe" # Double-Buffering Extension                                                                                                                 
    #Load "v4l" # Video for Linux                                                                                                                           
    Load "extmod"                                                                                                                                           
    #Load "type1"                                                                                                                                           
    Load "freetype"                                                                                                                                         
    Load "glx" # 3D layer                                                                                                                                   
EndSection                                                                                                                                                 
                                                                                                                                                           
#Section "InputDevice"                                                                                                                                     
#    Identifier "Keyboard"                                                                                                                                 
#    Driver "kbd"                                                                                                                                           
#    Option "XkbModel" "pc105"                                                                                                                             
#    Option "XkbLayout" "us_intl"                                                                                                                           
#    Option "XkbOptions" ""                                                                                                                                 
#EndSection                                                                                                                                                 

#Section "InputDevice"
#    Identifier "Mouse"
#    Driver "mouse"   
#    Option "Protocol" "ExplorerPS/2"
#    Option "Device" "/dev/input/mice"
#    Option "ZAxisMapping" "4 5"     
#    Option "Buttons" "7"             
#EndSection                           

Section "Monitor"
    Identifier "monitor1"
    VendorName "HP"     
    ModelName "HP L1906"
    HorizSync 30.0-83.0 
    VertRefresh 50.0-76.0
    Option "DPMS"       
    # Sony Vaio C1(X,XS,VE,VN)?
    # 1024x480 @ 85.6 Hz, 48 kHz hsync
    #ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
                                                                                       
    # TV fullscreen mode or DVD fullscreen output.                                     
    # 768x576 @ 79 Hz, 50 kHz hsync
    #ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

    # 768x576 @ 100 Hz, 61.6 kHz hsync
    #ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "TwinView"
    VendorName "NVidia"
    BoardName "NVIDIA GeForce4 (generic)"
    Driver "nvidia"
    Option "Coolbits" "1"
    Option "DPMS"
    #Option "MetaModes" "1152x864,1152x864; 1024x768,1024x768; 1024x768,NULL; 1152x864,NULL;
    Option "MetaModes" "1280x1024,1280x1024; 1152x864,1024x768; 1024x768,1024x768; 1024x768,NULL; 1152x864,NULL; 1280x1024,NULL"
    Option "SecondMonitorHorizSync" "30-83"
    Option "SecondMonitorVertRefresh" "50-76"
    #Option "ConnectedMonitor" "crt,crt"
    #Option "UseDisplayDevice" "DFP-0,DFP-1"
    Option "UseDisplayDevice" "CRT-0,CRT-1"
    Option "TwinViewOrientation" "RightOf"
    Option "TwinView"
EndSection
#####SCREEN LEFT######

Section "Screen"
    Identifier "screen1"
    Device "TwinView"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
        Depth 8
        Modes "1152x864, 1280x1024"
    EndSubsection

    Subsection "Display"
        Depth 15
        Modes "1152x864, 1280x1024"
    EndSubsection

    Subsection "Display"
        Depth 16
        Modes "1152x864, 1280x1024"
    EndSubsection

    Subsection "Display"
        Depth 24
        Modes "1152x864, 1280x1024"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    #InputDevice "Keyboard" "CoreKeyboard"
    #InputDevice "Mouse" "CorePointer"
    Screen "screen1"
EndSection
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Mon Aug 31, 2009 2:01 pm    Post subject: Reply with quote

my xorg.log

Code:

(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event2"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(**) Option "xkb_variant" "altgr-intl"
(EE) Error loading keymap /var/lib/xkb/server-0.xkm


using "/etc/hal/fdi/policy/10-keymap.fdi" (only file in that dir)

Code:

<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->                                             
<deviceinfo version="0.2">                                                                                   
  <device>                                                                                                   
    <match key="info.capabilities" contains="input.keymap">                                                   
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>                               
    </match>                                                                                                 

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string">altgr-intl</merge>
    </match>
  </device>
</deviceinfo>
Back to top
View user's profile Send private message
d2_racing
Moderator
Moderator


Joined: 25 Apr 2005
Posts: 13046
Location: Ste-Foy,Canada

PostPosted: Mon Aug 31, 2009 2:24 pm    Post subject: Reply with quote

Can you comment that and reboot your box :

Code:

  Option "AutoAddDevices" "on"
    Option "AutoEnableDevices" "on"
    Option "AllowEmptyInput" "on"   

_________________
Sysadmin of GentooQuébec.org
Wiki
Signature
IRC on Freenode : #gentoo-quebec
Back to top
View user's profile Send private message
SandStar
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jan 2005
Posts: 77

PostPosted: Mon Aug 31, 2009 4:46 pm    Post subject: Reply with quote

d2_racing wrote:
Can you comment that and reboot your box :

Code:

  Option "AutoAddDevices" "on"
    Option "AutoEnableDevices" "on"
    Option "AllowEmptyInput" "on"   


Just tried that. Although the "(EE) Error loading keymap /var/lib/xkb/server-0.xkm" disappeared, nothing else changed.

lshal output:

Code:

udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'
  info.addons.singleton = {'hald-addon-input'} (string list)
  info.capabilities = {'input', 'input.keyboard', 'input.keypad', 'input.keys', 'button'} (string list)
  info.category = 'input'  (string)
  info.parent = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  info.product = 'AT Translated Set 2 keyboard'  (string)
  info.subsystem = 'input'  (string)
  info.udi = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port_logicaldev_input'  (string)
  input.device = '/dev/input/event2'  (string)
  input.originating_device = '/org/freedesktop/Hal/devices/platform_i8042_i8042_KBD_port'  (string)
  input.product = 'AT Translated Set 2 keyboard'  (string)
  input.x11_driver = 'evdev'  (string)
  input.xkb.layout = 'us'  (string)
  input.xkb.model = 'evdev'  (string)
  input.xkb.rules = 'base'  (string)
  input.xkb.variant = 'altgr-intl'  (string)
  linux.device_file = '/dev/input/event2'  (string)
  linux.hotplug_type = 2  (0x2)  (int)
  linux.subsystem = 'input'  (string)
  linux.sysfs_path = '/sys/class/input/input2/event2'  (string)


the 'altgr-intl' seems to work as my right-alt + 5 gives me €

And if I type "setxkbmap us_intl -variant altgr-intl" after login into KDE everything works perfect...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... , 14, 15, 16  Next
Page 15 of 16

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum