Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 37, 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Thu Jun 04, 2009 5:11 pm    Post subject: Reply with quote

Hi to every body.

I have been using kde-4.3 for times but now I can't update to 4.2.89 packages. Portage says there isn't any ebuild to satisfy 4.2.89 and if I try to update with:

Code:

emerge -uDNav @kde-4.3


I don't see any package from 4.2.89 neither 4.2.88. I have the same package.unmask and package.keyword as I had for kde-4.2.87 my actual version... What can it be??

I have the ebuilds in layman...

Any idea?
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 730
Location: Alaska

PostPosted: Thu Jun 04, 2009 7:08 pm    Post subject: Reply with quote

marcus84 wrote:

I have been using kde-4.3 for times but now I can't update to 4.2.89 packages.

I don't see any package from 4.2.89 neither 4.2.88. I have the same package.unmask and package.keyword as I had for kde-4.2.87 my actual version... What can it be??

I have the ebuilds in layman...

Any idea?


I haven't sync'd my overlay today so don't know about whether 4.2.89 has appeared. But if it has appeared in the overlay, then sometimes it appears before there are actually any packages available. At those times you have to be patient - wait maybe a few days. In that case, and if you need to update other stuff, then you may have to mask that version.

Don't know if this helps. /jim
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5399
Location: Langen (Hessen), Germany

PostPosted: Thu Jun 04, 2009 9:07 pm    Post subject: Reply with quote

marcus84 wrote:
Hi to every body.

I have been using kde-4.3 for times but now I can't update to 4.2.89 packages. Portage says there isn't any ebuild to satisfy 4.2.89 and if I try to update with:

Code:

emerge -uDNav @kde-4.3


I don't see any package from 4.2.89 neither 4.2.88. I have the same package.unmask and package.keyword as I had for kde-4.2.87 my actual version... What can it be??

I have the ebuilds in layman...

Any idea?


I am compiling kde-base/kdelibs-4.2.89 at the moment.
So it is working.

What does eix -e kdelibs says?
layman -s kde-testing returns without an error?

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2470
Location: Austria

PostPosted: Thu Jun 04, 2009 10:27 pm    Post subject: Reply with quote

interesting, few hours after 4.2.89 there are 4.2.90 ebuilds available already? ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5399
Location: Langen (Hessen), Germany

PostPosted: Fri Jun 05, 2009 9:10 am    Post subject: Reply with quote

genstorm wrote:
interesting, few hours after 4.2.89 there are 4.2.90 ebuilds available already? ;)


Available yes, but no sources...
We will have to wait till 9th.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
fanthom
n00b
n00b


Joined: 31 May 2007
Posts: 41

PostPosted: Sat Jun 06, 2009 12:36 am    Post subject: Reply with quote

Finswimmer wrote:
genstorm wrote:
interesting, few hours after 4.2.89 there are 4.2.90 ebuilds available already? ;)


Available yes, but no sources...
We will have to wait till 9th.

Tobi


Hi!
I have just downloaded kde-testing overlay and now want to upgrade my kde to 4.3. Portage is trying to use 4.2.90 ebuilds but - as mentioned before - there is no soures yet. Is there any quick way to force installing version 4.2.89?
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Sat Jun 06, 2009 2:06 pm    Post subject: Reply with quote

fanthom wrote:
Finswimmer wrote:
genstorm wrote:
interesting, few hours after 4.2.89 there are 4.2.90 ebuilds available already? ;)


Available yes, but no sources...
We will have to wait till 9th.

Tobi


Hi!
I have just downloaded kde-testing overlay and now want to upgrade my kde to 4.3. Portage is trying to use 4.2.90 ebuilds but - as mentioned before - there is no soures yet. Is there any quick way to force installing version 4.2.89?


I will to cite Tobi:
Quote:
We will have to wait till 9th.

...
Back to top
View user's profile Send private message
R_W
n00b
n00b


Joined: 05 Jan 2005
Posts: 32

PostPosted: Sat Jun 06, 2009 2:56 pm    Post subject: Reply with quote

fanthom wrote:
Finswimmer wrote:


Hi!
I have just downloaded kde-testing overlay and now want to upgrade my kde to 4.3. Portage is trying to use 4.2.90 ebuilds but - as mentioned before - there is no soures yet. Is there any quick way to force installing version 4.2.89?


I will to cite Tobi:
Quote:
We will have to wait till 9th.

...


That's why he wants to install 4.2.89 now ;)

I have this in /etc/portage/package.unmask:
Code:
# kde 4.3
=kde-base/dolphin-4.2.89
=kde-base/libknotificationitem-4.2.89
=kde-base/kcheckpass-4.2.89
=kde-base/kcminit-4.2.89
=kde-base/kcmshell-4.2.89
=kde-base/kde-env-4.2.89
=kde-base/kcontrol-4.2.89
=kde-base/kdebase-menu-icons-4.2.89
=kde-base/kdebase-wallpapers-4.2.89
=kde-base/kdebase-data-4.2.89
=kde-base/kdebase-desktoptheme-4.2.89
=kde-base/kdebase-kioslaves-4.2.89
=kde-base/kdepasswd-4.2.89
=kde-base/kdeplasma-addons-4.2.89
=kde-base/kdebase-startkde-4.2.89
=kde-base/kglobalaccel-4.2.89
=kde-base/kdelibs-4.2.89
=kde-base/kdepimlibs-4.2.89
=kde-base/kdesu-4.2.89
=kde-base/kdialog-4.2.89
=kde-base/kdm-4.2.89
=kde-base/kdnssd-4.2.89
=kde-base/keditfiletype-4.2.89
=kde-base/kephal-4.2.89
=kde-base/kfind-4.2.89
=kde-base/khotkeys-4.2.89
=kde-base/kioclient-4.2.89
=kde-base/kmail-4.2.89
=kde-base/kmailcvt-4.2.89
=kde-base/kmenuedit-4.2.89
=kde-base/kmix-4.2.89
=kde-base/knotify-4.2.89
=kde-base/kode-4.2.89
=kde-base/konsole-4.2.89
=kde-base/kontactinterfaces-4.2.89
=kde-base/kopete-4.2.89
=kde-base/kreadconfig-4.2.89
=kde-base/krunner-4.2.89
=kde-base/ksmserver-4.2.89
=kde-base/ksplash-4.2.89
=kde-base/kstartupconfig-4.2.89
=kde-base/kstyles-4.2.89
=kde-base/ksysguard-4.2.89
=kde-base/ktimezoned-4.2.89
=kde-base/kwallet-4.2.89
=kde-base/kwalletd-4.2.89
=kde-base/kwin-4.2.89
=kde-base/libkdepim-4.2.89
=kde-base/libkleo-4.2.89
=kde-base/libkonq-4.2.89
=kde-base/libkpgp-4.2.89
=kde-base/libksieve-4.2.89
=kde-base/libplasmaclock-4.2.89
=kde-base/libtaskmanager-4.2.89
=kde-base/libkworkspace-4.2.89
=kde-base/mimelib-4.2.89
=kde-base/oxygen-icons-4.2.89
=kde-base/phonon-kde-4.2.89
=kde-base/plasma-apps-4.2.89
=kde-base/plasma-workspace-4.2.89
=kde-base/pykde4-4.2.89
=kde-base/soliduiserver-4.2.89
=kde-base/solid-4.2.89
=kde-base/systemsettings-4.2.89


Make sure you remove other entries that still unmask 4.2.90 (like "kde-base/kdelibs:4.3") and it should work. Hope this helps :)
Back to top
View user's profile Send private message
fanthom
n00b
n00b


Joined: 31 May 2007
Posts: 41

PostPosted: Sat Jun 06, 2009 9:18 pm    Post subject: Reply with quote

I was trying to aviod that way - too lazy for editing package.unmask file. thnx a lot.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jun 07, 2009 9:54 am    Post subject: Reply with quote

hunky wrote:
marcus84 wrote:

I have been using kde-4.3 for times but now I can't update to 4.2.89 packages.

I don't see any package from 4.2.89 neither 4.2.88. I have the same package.unmask and package.keyword as I had for kde-4.2.87 my actual version... What can it be??

I have the ebuilds in layman...

Any idea?


I haven't sync'd my overlay today so don't know about whether 4.2.89 has appeared. But if it has appeared in the overlay, then sometimes it appears before there are actually any packages available. At those times you have to be patient - wait maybe a few days. In that case, and if you need to update other stuff, then you may have to mask that version.

Don't know if this helps. /jim


Solved. I have problems with laymans dirs!

Thanks
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7214
Location: Pelotas, BR

PostPosted: Sun Jun 07, 2009 12:45 pm    Post subject: Reply with quote

Is anybody else having issues with kdm-4.2.89? I can' t login, it spits some errors in /var/log/messages and go back to the login greeter.

Code:

Jun  6 14:08:10 spitfire kdm: :0[13063]: Cannot open ConsoleKit session: Unable to open session: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success
Jun  6 14:08:10 spitfire kdm: :0[13063]: Client start failed
Jun  6 14:08:10 spitfire kdm: :0[13063]: Cannot close ConsoleKit session: Unable to close session: no session open


Besides, I have had a couple locks after upgrading, I am using fluxbox to see if it is a X problem.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
Dancingfire
n00b
n00b


Joined: 01 Jan 2007
Posts: 37

PostPosted: Sun Jun 07, 2009 7:20 pm    Post subject: Reply with quote

pilla wrote:
Is anybody else having issues with kdm-4.2.89? I can' t login, it spits some errors in /var/log/messages and go back to the login greeter.

Code:

Jun  6 14:08:10 spitfire kdm: :0[13063]: Cannot open ConsoleKit session: Unable to open session: Failed to execute program /usr/libexec/dbus-daemon-launch-helper: Success
Jun  6 14:08:10 spitfire kdm: :0[13063]: Client start failed
Jun  6 14:08:10 spitfire kdm: :0[13063]: Cannot close ConsoleKit session: Unable to close session: no session open


Besides, I have had a couple locks after upgrading, I am using fluxbox to see if it is a X problem.


emerged kde-4.2.89 today (rebuilt system to amd64) - works fine
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7214
Location: Pelotas, BR

PostPosted: Sun Jun 07, 2009 11:19 pm    Post subject: Reply with quote

Dancingfire wrote:

emerged kde-4.2.89 today (rebuilt system to amd64) - works fine


kdm is still broken for me, although I didn't have more lockups. Also on amd64.

update: I've reemerged dbus and now it works fine.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
The Dealy Lama
n00b
n00b


Joined: 10 Jun 2003
Posts: 35
Location: Da'ath

PostPosted: Tue Jun 09, 2009 4:46 pm    Post subject: Reply with quote

I got this funky error trying to emerge 4.2.90:

Quote:
>>> Install sip-4.8 into /var/tmp/portage/dev-python/sip-4.8/image/ category dev-python
make -j3 DESTDIR=/var/tmp/portage/dev-python/sip-4.8/image/ install
make[1]: Entering directory `/var/tmp/portage/dev-python/sip-4.8/work/sip-4.8/sipgen'
mkdir: cannot create directory `/var/tmp/portage/dev-python/sip-4.8/image//usr/bin \t\t\t--destdir=/usr/lib/python2.5/site-packages \t\t\t--incdir=/usr/include/python2.5 \t\t\t--sipdir=/usr/share/sip \t\t\t \t\t\tCC=i686-pc-linux-gnu-gcc CXX=i686-pc-linux-gnu-g++ \t\t\tLINK=i686-pc-linux-gnu-g++ LINK_SHLIB=i686-pc-linux-gnu-g++ \t\t\tCFLAGS=\'-march=prescott -O2 -pipe -fomit-frame-pointer\' CXXFLAGS=\'-march=prescott -O2 -pipe -fomit-frame-pointer\' \t\t\tLFLAGS=\'-Wl,-O1\' \t\t\tSTRIP=true': File name too long
make[1]: *** [install] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-python/sip-4.8/work/sip-4.8/sipgen'
make: *** [install] Error 2


Any ideas? :o
_________________
"The shadows of this world are perceived by mortals, and they think they know the Truth, but the Reality which casts the shadows is hidden from them, and they do not perceive the Light." (Sayings 2:2)"
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Tue Jun 09, 2009 5:17 pm    Post subject: Reply with quote

Code:
krogpc krog # emerge -auDv --newuse world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-python/PyQt4-4.5[dbus,qt3support,sql,svg,webkit,X]".
(dependency required by "kde-base/pykde4-4.2.90" [ebuild])                                         
(dependency required by "kde-base/marble-4.2.90" [ebuild])                                         
(dependency required by "kde-base/kdeplasma-addons-4.2.90" [ebuild])                               
(dependency required by "@world" [argument])


where is an ebuild for >=dev-python/PyQt4-4.5?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5720
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jun 09, 2009 5:43 pm    Post subject: Reply with quote

Krog wrote:
Code:
krogpc krog # emerge -auDv --newuse world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-python/PyQt4-4.5[dbus,qt3support,sql,svg,webkit,X]".
(dependency required by "kde-base/pykde4-4.2.90" [ebuild])                                         
(dependency required by "kde-base/marble-4.2.90" [ebuild])                                         
(dependency required by "kde-base/kdeplasma-addons-4.2.90" [ebuild])                               
(dependency required by "@world" [argument])


where is an ebuild for >=dev-python/PyQt4-4.5?


wrong question :P

the question is IF you've enabled all of the needed USE-flags:

dbus,qt3support,sql,svg,webkit,X :idea:
Quote:
dep -e PyQt4
dev-python/PyQt4:
[ ~ ] 4.4.4-r2 (0)
[ ~ ] 4.4.4-r4 (0)
[ ~ ] 4.4.4-r4 (0) /usr/gentoo/overlays/overlay
[ ~ ] 4.4.4-r5 (0)
[U~ ] 4.5 (0) /usr/gentoo/overlays/qting-edge

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Krog
Apprentice
Apprentice


Joined: 26 Jun 2007
Posts: 256
Location: Roma, Italy

PostPosted: Tue Jun 09, 2009 6:33 pm    Post subject: Reply with quote

i have'nt qting-edge overlay installed
is it necessary now?
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 730
Location: Alaska

PostPosted: Tue Jun 09, 2009 7:10 pm    Post subject: Reply with quote

Curious if anyone is emerging 4.2.90 yet? I'm stuck on about the first package - oxygen-icons-4.2.90 (being pulled in by kdebase-data-4.2.90) as not being found on any of the mirrors (several) that it tries. Perhaps I need to use a specific mirror?

Krog: seems as if you do need qting-edge now. I'm thinking of bailing on using these overlays - it has been fun but seems to be requiring more and more time to figure it all out for my less than guru knowledge.
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Tue Jun 09, 2009 11:12 pm    Post subject: Reply with quote

The last version of PyQT4 (4.5) disappeared from the qting-edge overlay. 8O
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7214
Location: Pelotas, BR

PostPosted: Tue Jun 09, 2009 11:17 pm    Post subject: Reply with quote

hunky wrote:
Curious if anyone is emerging 4.2.90 yet? I'm stuck on about the first package - oxygen-icons-4.2.90 (being pulled in by kdebase-data-4.2.90) as not being found on any of the mirrors (several) that it tries. Perhaps I need to use a specific mirror?

Krog: seems as if you do need qting-edge now. I'm thinking of bailing on using these overlays - it has been fun but seems to be requiring more and more time to figure it all out for my less than guru knowledge.


Has 4.2.90 already been released?
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 730
Location: Alaska

PostPosted: Tue Jun 09, 2009 11:20 pm    Post subject: Reply with quote

A few posts above mine seemed to indicate it was, but maybe it isn't yet. Ebuilds are in the overlay for the last 5 days but I can't locate any source. Finswimmer (Tobi) said it would be released on the 9th, so hence my question you quoted.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5399
Location: Langen (Hessen), Germany

PostPosted: Wed Jun 10, 2009 6:48 am    Post subject: Reply with quote

hunky wrote:
A few posts above mine seemed to indicate it was, but maybe it isn't yet. Ebuilds are in the overlay for the last 5 days but I can't locate any source. Finswimmer (Tobi) said it would be released on the 9th, so hence my question you quoted.


http://techbase.kde.org/Schedules/KDE4/4.3_Release_Schedule

But there are (still) no sources available on the offical ftp.kde.org Server.

So we will have to wait.

Tob
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
hunky
l33t
l33t


Joined: 19 Nov 2003
Posts: 730
Location: Alaska

PostPosted: Wed Jun 10, 2009 7:13 am    Post subject: Reply with quote

Thanks for the links!
Back to top
View user's profile Send private message
Biert
n00b
n00b


Joined: 14 Sep 2006
Posts: 45
Location: The Netherlands

PostPosted: Wed Jun 10, 2009 9:55 am    Post subject: Reply with quote

The packages are available now, but the manifests don't seem to match.
_________________
http://www.last.fm/user/Biert/
Back to top
View user's profile Send private message
TheDodger
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2002
Posts: 126
Location: Hamburg

PostPosted: Wed Jun 10, 2009 10:38 am    Post subject: Reply with quote

Biert wrote:
The packages are available now, but the manifests don't seem to match.


Yes, i have currently this problem:
Code:

>>> Downloading 'http://mirrors.isc.org/pub/kde/unstable/4.2.90/src/kdelibs-4.2.90.tar.bz2'
--2009-06-10 12:35:51--  http://mirrors.isc.org/pub/kde/unstable/4.2.90/src/kdelibs-4.2.90.tar.bz2
Auflösen des Hostnamen »mirrors.isc.org«.... 204.152.184.134
Verbindungsaufbau zu mirrors.isc.org|204.152.184.134|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 10065082 (9,6M) [application/x-bzip]
In »/usr/portage/distfiles/kdelibs-4.2.90.tar.bz2« speichern.

100%[============================================>] 10.065.082  1,10M/s   in 11s

2009-06-10 12:36:02 (904 KB/s) - »/usr/portage/distfiles/kdelibs-4.2.90.tar.bz2« gespeichert [10065082/10065082]

('Filesize does not match recorded size', 10065082L, 10065958)
!!! Fetched file: kdelibs-4.2.90.tar.bz2 VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got:      10065082
!!! Expected: 10065958
Refetching... File renamed to '/usr/portage/distfiles/kdelibs-4.2.90.tar.bz2._checksum_failure_.EVxJDv'


I'm waiting for an update ... ;)
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 37, 38, 39, 40  Next
Page 38 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum