Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kde-testing] and [kde-crazy] KDE4 overlays thread (part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4 ... 38, 39, 40  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Jan 03, 2009 9:59 am    Post subject: Reply with quote

Hi to everybody!

Updating the @kde-4.2 I get the next warnings:
Code:

!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
kde-base/kdeartwork-desktopthemes:4.2 kde-base/kdebase-desktoptheme:4.2


should I be worried about it?

P.D.

Korganizer still failing. I have syncd the overlay this morning:

Code:


>>> Emerging (5 of 13) kde-base/korganizer-4.1.87
 * kdepim-4.1.87.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                   [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                       [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                      [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                     [ ok ]
>>> Unpacking source...                                                                                                                                         
 * Unpacking parts of kdepim-4.1.87.tar.bz2 to /home/tmp_portage/portage/kde-base/korganizer-4.1.87/work ...                                                [ ok ]
>>> Source unpacked.                                                                                                                                             
sed: no es pot llegir kontact/plugins/planner/CMakeLists.txt: El fitxer o directori no existeix                                                                   
 *                                                                                                                                                               
 * ERROR: kde-base/korganizer-4.1.87 failed.                                                                                                                     
 * Call stack:                                                                                                                                                   
 *               ebuild.sh, line   49:  Called src_prepare                                                                                                       
 *             environment, line 3779:  Called die                                                                                                               
 * The specific snippet of code:                                                                                                                                 
 *           sed -i -e's/kaddressbookprivate ${KDE4_KCAL_LIBS}/${KDE4_KCAL_LIBS}/' kontact/plugins/planner/CMakeLists.txt || die "Failed to remove kaddressbookprivate from link";                                                                                                                                                 
 *  The die message:                                                                                                                                             
 *   Failed to remove kaddressbookprivate from link                                                                                                               
 *                                                                                                                                                               
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                             
 * A complete build log is located at '/home/tmp_portage/portage/kde-base/korganizer-4.1.87/temp/build.log'.                                                     
 * The ebuild environment file is located at '/home/tmp_portage/portage/kde-base/korganizer-4.1.87/temp/environment'.                                             
 * 


Last edited by marcus84 on Sat Jan 03, 2009 10:04 am; edited 1 time in total
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 261

PostPosted: Sat Jan 03, 2009 10:01 am    Post subject: Reply with quote

Try to sync the overlay.
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Jan 03, 2009 10:05 am    Post subject: Reply with quote

Boccaccio wrote:
Try to sync the overlay.


I have done it, I will try to delete the overlay and fetchit another time...

P.D.

I have recompiled pykde4 and like always since v4.1.72 fails compiling like this:

Code:

Linking CXX shared library ../../lib/pykde/plasma.so                                                                                                             
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart0.o: In function `void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)':                                                                                                                                   
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x2a): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'
sipplasmapart0.cpp:(.text._Z24qMetaTypeConstructHelperIN6Plasma11Containment11StyleOptionEEPvPKT_[void* qMetaTypeConstructHelper<Plasma::Containment::StyleOption>(Plasma::Containment::StyleOption const*)]+0x51): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'                                       
CMakeFiles/python_module_PyKDE4_plasma.dir/sip/plasma/sipplasmapart6.o: In function `init_Plasma_Containment_StyleOption':                                       
sipplasmapart6.cpp:(.text+0xa0b4): undefined reference to `Plasma::Containment::StyleOption::StyleOption(QStyleOptionGraphicsItem const&)'                       
sipplasmapart6.cpp:(.text+0xa0db): undefined reference to `Plasma::Containment::StyleOption::StyleOption()'                                                       
sipplasmapart6.cpp:(.text+0xa113): undefined reference to `Plasma::Containment::StyleOption::StyleOption(Plasma::Containment::StyleOption const&)'               
collect2: ld va retornar l'estat de sortida 1                                                                                                                     
make[2]: *** [lib/pykde/plasma.so] Error 1                                                                                                                       
make[1]: *** [python/pykde4/CMakeFiles/python_module_PyKDE4_plasma.dir/all] Error 2                                                                               
make: *** [all] Error 2                                                                                                                                           
 *                                                                                                                                                               
 * ERROR: kde-base/pykde4-4.1.87 failed.                                                                                                                         
 * Call stack:                                                                                                                                                   
 *               ebuild.sh, line   49:  Called src_compile                                                                                                       
 *             environment, line 3764:  Called kde4-meta_src_compile                                                                                             
 *             environment, line 2894:  Called kde4-base_src_make                                                                                                 
 *             environment, line 2655:  Called cmake-utils_src_make                                                                                               
 *             environment, line 1016:  Called die                                                                                                               
 * The specific snippet of code:                                                                                                                                 
 *           emake "$@" || die "Make failed!";                                                                                                                   
 *  The die message:                                                                                                                                             
 *   Make failed!                                                                                                                                                 
 *                                                                                                                                                               
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                             
 * A complete build log is located at '/home/tmp_portage/portage/kde-base/pykde4-4.1.87/temp/build.log'.                                                         
 * The ebuild environment file is located at '/home/tmp_portage/portage/kde-base/pykde4-4.1.87/temp/environment'.                                                 
 *                   


This is in amd64

Does anybody compile pykde4 with amd64 and kdeprefix???


Last edited by marcus84 on Sat Jan 03, 2009 2:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
afijssi
n00b
n00b


Joined: 02 Jan 2009
Posts: 2

PostPosted: Sat Jan 03, 2009 11:24 am    Post subject: kopete/ortp conflict Reply with quote

There is a conflict for kopete versions 4.1.87 and 3.5.10 built with net-libs/ortp (jabber, jingle use flag). kopete 3.5.10 requires ~ortp-0.7, while kopete 4.1.87 requires >=net-libs/ortp-0.13. If kde 3.5 and 4.2 are to be both installed, the ortp package should be slotted.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sat Jan 03, 2009 4:52 pm    Post subject: Reply with quote

Since I stumbled over it again recently: Imo nepomuk should be removed from the @kdebase sets as it gets pulled in via the semantic-desktop USE-flag and is not required otherwise. I already opened a bug about that: https://bugs.gentoo.org/show_bug.cgi?id=252298
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Jan 03, 2009 5:13 pm    Post subject: Reply with quote

genstorm wrote:
Since I stumbled over it again recently: Imo nepomuk should be removed from the @kdebase sets as it gets pulled in via the semantic-desktop USE-flag and is not required otherwise. I already opened a bug about that: https://bugs.gentoo.org/show_bug.cgi?id=252298


You have a war with nepomuk software :P
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2444
Location: Austria

PostPosted: Sat Jan 03, 2009 5:35 pm    Post subject: Reply with quote

Well, I simply don't need it, therefore it would be useless junk on my notebook. And that's what USE-flags are about after all. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Jan 03, 2009 6:14 pm    Post subject: Reply with quote

new errors in korganizer

Code:

-- Looking for assuan_inquire_ext - found                                                                                                                         
-- Performing Test HAVE_NEW_STYLE_ASSUAN_INQUIRE_EXT                                                                                                             
-- Performing Test HAVE_NEW_STYLE_ASSUAN_INQUIRE_EXT - Success                                                                                                   
-- Performing Test HAVE_GPG_ERR_SOURCE_KLEO                                                                                                                       
terminate called after throwing an instance of 'std::out_of_range'                                                                                               
  what():  basic_string::erase                                                                                                                                   
/home/tmp_portage/portage/kde-base/korganizer-4.1.87/temp/environment: line 991: 14255 Avortat                 cmake -C "${TMPDIR}/gentoo_common_config.cmake" ${cmakeargs} "${S}" 
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5675
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Jan 03, 2009 6:38 pm    Post subject: Reply with quote

genstorm wrote:
Well, I simply don't need it, therefore it would be useless junk on my notebook. And that's what USE-flags are about after all. ;)


++

as long as there's no frontend with which you're able to search through all that crawled/indexed data there's not much need for that additional disk waste (I'm already using recoll)
and disk space is pretty precious on my laptop, still waiting on that 750 GB 2.5'' harddisk :P
_________________
Unofficial minimal livecd x86/amd64 w/reiser4+truecrypt (by Neo2)
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sat Jan 03, 2009 7:45 pm    Post subject: Reply with quote

With the new kde-4.1.85 I get an error when the screen should be locked. The error is from runner_locker. Here is the info:

Aplicació: Bloqueig del KRunner (krunner_lock), senyal SIGSEGV
Using host libthread_db library "/lib/libthread_db.so.1".
0x00007f4803a36de1 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 15019)]

Thread 2 (Thread 0x40c7b950 (LWP 15020)):
#0 0x00007f4803a5e942 in select () from /lib/libc.so.6
#1 0x00007f48054f207e in ?? () from /usr/lib64/qt4/libQtCore.so.4
#2 0x00007f4805432132 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#3 0x00007f48051c2097 in start_thread () from /lib/libpthread.so.0
#4 0x00007f4803a64bcd in clone () from /lib/libc.so.6
#5 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f4807efc750 (LWP 15019)):
[KCrash Handler]
#5 0x00007f47fd9d3f82 in xkl_process_error () from /usr/lib/libxklavier.so.12
#6 0x00007f48071615be in _XError () from /usr/lib/libX11.so.6
#7 0x00007f48071631eb in _XReply () from /usr/lib/libX11.so.6
#8 0x00007f480714c3ae in XInternAtom () from /usr/lib/libX11.so.6
#9 0x00007f47fd9d38ed in ?? () from /usr/lib/libxklavier.so.12
#10 0x00007f47fd795e3f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#11 0x00007f47fd79690d in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#12 0x00007f47fd796ab1 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#13 0x00007f47fd9d36ed in xkl_engine_get_instance () from /usr/lib/libxklavier.so.12
#14 0x00007f47fdbf84cc in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#15 0x00007f47fdbf86c9 in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#16 0x00007f47fdbf2398 in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#17 0x00007f47fdbfc819 in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#18 0x00007f47fdbfc942 in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#19 0x00007f47fdc0051a in ?? () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#20 0x00007f47fdc00f63 in KPluginFactory::createInstance<KxkbPart, QWidget> () from /usr/kde/4.2/lib64/libkdeinit4_kxkb.so
#21 0x00007f4805c479dc in KPluginFactory::create () from /usr/kde/4.2/lib64/libkdecore.so.5
#22 0x00000000004194b2 in _start ()

Any idea??
Back to top
View user's profile Send private message
reficul
n00b
n00b


Joined: 03 Apr 2004
Posts: 8
Location: Bielefeld, Germany

PostPosted: Sat Jan 03, 2009 9:45 pm    Post subject: Reply with quote

Hi together,

A few days ago i started installing the beta from the kde-testing overlay. After a few minor setbacks (nvidia card + window resizing :roll: ) yesterday evening i was able to login - with login sounds. When I upgraded phonon this morning (and again this evening a few minutes ago) I did not have any backends listed under "Multimedia" in the control panel anymore.

Actual phonon packages installed:

Code:

 [I] kde-base/phonon-kde [1]
     Available versions:  (4.2)  (~)4.1.85 (~)4.1.87
        {debug kdeprefix}
     Installed versions:  4.1.87(4.2)(10:11:16 PM 01/03/2009)(kdeprefix -debug)
     Homepage:            http://phonon.kde.org
     Description:         Phonon KDE Integration

[I] media-sound/phonon
     Available versions:  (~)4.2.0!t (~)4.2.80[1] (~)4.2.81_p904813[1] {debug gstreamer xcb xine}
     Installed versions:  4.2.81_p904813[1](08:24:32 PM 01/03/2009)(gstreamer xcb xine -debug)
     Homepage:            http://phonon.kde.org
     Description:         KDE multimedia API


Sound in Amarok 1.4 is fine, but no KDE application is able to produce sound. Any Sugessestions? Maybe phonon 4.2.81_pxyz is not compatible with KDE build 4.2.87? KMix also diplays my soundcard correctly and using this mixer Amarok sound output can be controlled.
Back to top
View user's profile Send private message
tampakrap
Developer
Developer


Joined: 27 Nov 2007
Posts: 71
Location: Prague, Czech Republic

PostPosted: Sat Jan 03, 2009 11:27 pm    Post subject: Reply with quote

remove the gstreamer use flag
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Sun Jan 04, 2009 12:37 am    Post subject: Reply with quote

I can report the reason for many pykde4 failures and how to fix it.

In the kdelibs-4.1.87.tar.bz2 archive in the plasma folder in a file called containment.h file is a nested class called with the name StyleOption. The overall class is exported but not the nested StyleOption class inside. For some compilers, this violation of C++ rules may work, but not for gcc-4.1.2 under x86.

The fix is: unpack kdelibs-4.1.87.tar.bz2 to a folder. Search the file containment.h and the definition of the class StyleOption. Add PLASMA_EXPORT to that definition. Repack kdelibs-4.1.87.tar.bz2 again and put it to the /usr/portage/distfiles folder. Then remove the manifest file of kdelibs in the kde-testing overlay and build a new digest for the modified kdelibs (without the removal of the manifest, portage would refetch the faulty file from kde servers). After this, emerge kdelibs and finally emerge pykde. the package pykde should compile.

I made the kde team aware of this bug in http://bugs.kde.org/show_bug.cgi?id=178354 Perhaps they fix it in the next beta.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sun Jan 04, 2009 7:08 am    Post subject: Reply with quote

I was wrong that I do not understand with amarok 2.0-r1.
If I listen to a song in my collection, it sounds good I am, by against if I want to listen to Internet radio I heard nothing.
I do not know where to start looking
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
reficul
n00b
n00b


Joined: 03 Apr 2004
Posts: 8
Location: Bielefeld, Germany

PostPosted: Sun Jan 04, 2009 10:07 am    Post subject: Reply with quote

tampakrap wrote:
remove the gstreamer use flag


Thanks, worked for me (even if the backend list is still empty but I got normal sound again).
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jan 04, 2009 10:37 am    Post subject: Reply with quote

Benni123 wrote:
I can report the reason for many pykde4 failures and how to fix it.

In the kdelibs-4.1.87.tar.bz2 archive in the plasma folder in a file called containment.h file is a nested class called with the name StyleOption. The overall class is exported but not the nested StyleOption class inside. For some compilers, this violation of C++ rules may work, but not for gcc-4.1.2 under x86.

The fix is: unpack kdelibs-4.1.87.tar.bz2 to a folder. Search the file containment.h and the definition of the class StyleOption. Add PLASMA_EXPORT to that definition. Repack kdelibs-4.1.87.tar.bz2 again and put it to the /usr/portage/distfiles folder. Then remove the manifest file of kdelibs in the kde-testing overlay and build a new digest for the modified kdelibs (without the removal of the manifest, portage would refetch the faulty file from kde servers). After this, emerge kdelibs and finally emerge pykde. the package pykde should compile.

I made the kde team aware of this bug in http://bugs.kde.org/show_bug.cgi?id=178354 Perhaps they fix it in the next beta.


I don't understand what I have to add to the class... The class is the next code:
Code:


class StyleOption : public QStyleOptionGraphicsItem
        {
            public:
                explicit StyleOption();
                explicit StyleOption(const StyleOption &other);
                explicit StyleOption(const QStyleOptionGraphicsItem &other);

                enum StyleOptionType {
                    Type = SO_CustomBase + 1
                };
                enum StyleOptionVersion {
                    Version = QStyleOptionGraphicsItem::Version + 1
                };

                /**
                 * The View, if any, that this containment is currently
                 * being rendered into. Note: this may be NULL, so be
                 * sure to check it before using it!
                 */
                Plasma::View *view;
        };



P.S

My response:

Code:

kdelibs-4.1.87/plasma/containment.h: change line 72

from class StyleOption : public QStyleOptionGraphicsItem
to class PLASMA_EXPORT StyleOption : public QStyleOptionGraphicsItem



P.D. IT HAS COMPILED CORRECT!!! Thank you very much


Last edited by marcus84 on Sun Jan 04, 2009 11:15 am; edited 1 time in total
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Sun Jan 04, 2009 11:02 am    Post subject: Reply with quote

Hi, is anyone able to build successfully the latest versions of skulpture style (>0.2.0.1) with live ebuilds from kde-crazy?
For me it fails with following linking error:
Code:

...
Linking CXX shared module ../lib/kwin3_skulpture.so
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lKDE4Workspace__kdecorations
collect2: ld returned 1 exit status
make[2]: *** [lib/kwin3_skulpture.so] Error 1
make[1]: *** [kwin-client/CMakeFiles/kwin3_skulpture.dir/all] Error 2
make: *** [all] Error 2


Any hint? Thanks in advance.
_________________
hidentity.org
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5375
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 04, 2009 11:13 am    Post subject: Reply with quote

Yakuake needs these changes to compile with KDE-4.1.87. Otherwise it tries to pull 4.1.

NEED_KDE="4.1.87"
SLOT="4.2"

Can someone please add it to the overlay?

Thanks

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5375
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 04, 2009 11:23 am    Post subject: Reply with quote

plasma-netgraph needs kde-base/libplasma which is only available for 4.1, but not in slot 4.2.
As of the description in eix I suppose that libplasma:4.1 and plasma-workspace:4.2 are the same.

Can someone confirm this and adjust the ebuild?

Thanks
Tobi

EDIT: toggle-compositing has exactly the same problem.
Other plasmoids not tested, but I think there is no difference.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Sun Jan 04, 2009 11:29 am; edited 1 time in total
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jan 04, 2009 11:23 am    Post subject: Reply with quote

Now the pykde4 has compiled all the packages failing start compiling like korganizer and marble!!
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jan 04, 2009 11:26 am    Post subject: Reply with quote

Finswimmer wrote:
Yakuake needs these changes to compile with KDE-4.1.87. Otherwise it tries to pull 4.1.

NEED_KDE="4.1.87"
SLOT="4.2"

Can someone please add it to the overlay?

Thanks

Tobi


Where is the yakuake ebuild? I don't see it in kde-testing... And in kde-crazy there is only the 9999 version...
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5375
Location: Langen (Hessen), Germany

PostPosted: Sun Jan 04, 2009 11:31 am    Post subject: Reply with quote

marcus84 wrote:
Finswimmer wrote:
Yakuake needs these changes to compile with KDE-4.1.87. Otherwise it tries to pull 4.1.

NEED_KDE="4.1.87"
SLOT="4.2"

Can someone please add it to the overlay?

Thanks

Tobi


Where is the yakuake ebuild? I don't see it in kde-testing... And in kde-crazy there is only the 9999 version...


It is in the normal portage tree.
But yakuake needs a konsole part, therefore it pulls (at the moment) konsole:4.1 and not konsole:4.2.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
marcus84
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2008
Posts: 87

PostPosted: Sun Jan 04, 2009 11:43 am    Post subject: Reply with quote

Finswimmer wrote:
marcus84 wrote:
Finswimmer wrote:
Yakuake needs these changes to compile with KDE-4.1.87. Otherwise it tries to pull 4.1.

NEED_KDE="4.1.87"
SLOT="4.2"

Can someone please add it to the overlay?

Thanks

Tobi


Where is the yakuake ebuild? I don't see it in kde-testing... And in kde-crazy there is only the 9999 version...


It is in the normal portage tree.
But yakuake needs a konsole part, therefore it pulls (at the moment) konsole:4.1 and not konsole:4.2.

Tobi


Thanks!

Working in kde-4.1.87 ;)
Back to top
View user's profile Send private message
ssmaxss
Apprentice
Apprentice


Joined: 28 Jun 2005
Posts: 160
Location: Moscow, Russia.

PostPosted: Sun Jan 04, 2009 11:52 am    Post subject: Reply with quote

Yakuake works with this modifications :) Never seen compilation problem with pykde4... But with update to 4.1.87 plasma behaves strange. Old plasma theme was broken. Taskbar no longer returns when I move mouse to the bottom of the screen (in windows can cover mode).
Back to top
View user's profile Send private message
martin.k
Guru
Guru


Joined: 28 Nov 2004
Posts: 492
Location: Wylatowo, Polska

PostPosted: Sun Jan 04, 2009 1:52 pm    Post subject: Reply with quote

mikedee wrote:
I am having a problem with a lot of the live ebuilds.

I can install everything in @kde-live with the kdeprefix use flag, but if I want to install extra apps like k3b, kdevelop etc it tells me that some libraries need to be compiled WITHOUT the kdeprefix use flag. If I remove the kdeprefix flag then most of @kde-live will not build.

This is the example for k3b

Code:
# emerge k3b
Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=kde-base/kdepimlibs-3.9[-kdeprefix]" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdepimlibs-9999 (masked by: missing keyword)
- kde-base/kdepimlibs-4.1.3 (masked by: ~amd64 keyword)
- kde-base/kdepimlibs-4.1.2 (masked by: ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "app-cdr/k3b-9999" [ebuild])
(dependency required by "k3b" [argument])


Does anyone know a workaround?

USE="kdeprefix" emerge -pv k3b:live
???
_________________
linux-2.6.17 +ck +R4 +lockless +genetic-as +... więcej nie pamiętam :)
LRU #299256
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4 ... 38, 39, 40  Next
Page 3 of 40

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum