Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EBUILD] Kadu 0.12.0 (modularne) - roslin
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
cst
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 194
Location: /proc

PostPosted: Tue May 05, 2009 1:27 pm    Post subject: Reply with quote

Ad 1 : Zadzialalo - trzebabylo zaladowac ten modul...
Ad 2 : Nie zainstalowalo mi qca-ossl, zainstalowalem i juz dziala.

Thx
_________________
Phenom II X2 550 @ 4x3,7GHz
Gigabayte MA770T-UD3P
12GB 1333 MHz DDR3 Kingmax
2xSamsung HD502HJ in RAID 0
Asus GTX 660
latest gentoo-sources on x86_64 Fluxbox (amd64)

best render farm: www.GarageFarm.NET
Back to top
View user's profile Send private message
kacper
Guru
Guru


Joined: 07 Feb 2004
Posts: 300
Location: Poland, Słubice

PostPosted: Wed May 06, 2009 5:13 pm    Post subject: Reply with quote

Eh, to nowe kadu z portage... nie działają mi tabsy jak :

a. zrobić aby działały z tym kadu z portage?
b. wrócić do modularnego z overlaya?
_________________
http://www.koniec-iti.eu
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Wed May 06, 2009 5:22 pm    Post subject: Reply with quote

Aby wrócić do modularnego Kadu, będziesz musiał zamaskować kadu-0.6.5.2-r1 z portage. Potem przydałoby się skasować i ponownie zainstalować Kadu. Inaczej może dojść do kolizji plików.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 763

PostPosted: Wed May 13, 2009 1:43 am    Post subject: Reply with quote

kadu nie kompiluje się z gcc-4.4.0. patch -> http://starowa.one.pl/~uzi/kadu/kadu-gcc44.patch
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Wed May 13, 2009 4:04 pm    Post subject: Reply with quote

Wrzucone, dzięki. Przydałoby się tę usterkę zgłosić do upstreamu.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 3:49 am    Post subject: Reply with quote

Code:
[ 41%] Building CXX object kadu-core/CMakeFiles/kadu.dir/chat_manager.cpp.o
In file included from /var/tmp/portage/net-im/kadu-core-0.6.5.2/work/kadu/kadu-core/search.h:4,
                 from /var/tmp/portage/net-im/kadu-core-0.6.5.2/work/kadu/kadu-core/chat_manager.cpp:25:
/var/tmp/portage/net-im/kadu-core-0.6.5.2/work/kadu/kadu-core/gadu.h:15:3: error: #error "libgadu must be compiled with pthread support"


A libgadu oczywiście skompilowane z USE=thread , zresztą jak inaczej ruszyłby emerge kadu, gdyby odpowiednie zależności nie były spełnione? ;-)
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 1:04 pm    Post subject: Reply with quote

W takim razie zestaw kontrolny:
Code:
emerge --info

Code:
emerge -pv libgadu

Code:
grep PTHREAD /usr/include/libgadu.h

_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 2:21 pm    Post subject: Reply with quote

emerge --info
Code:

emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.10.1-r0, 2.6.29-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r4-i686-Intel-R-_Celeron-R-_CPU_540_@_1.86GHz-with-gentoo-2.0.0
Timestamp of tree: Sun, 24 May 2009 21:15:02 +0000
app-shells/bash:     4.0_p24
dev-java/java-config: 1.3.7-r1, 2.1.8
dev-lang/python:     2.5.4-r2, 2.6.2
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.29
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-O2 -mtune=pentium-m -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="pl_PL"
LC_ALL="pl_PL"
LDFLAGS="-Wl,-O1"
LINGUAS="en pl"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/welp /usr/local/portage/layman/php-experimental /usr/local/portage/layman/php-testing /usr/local/portage/layman/mozilla /usr/local/portage/layman/roslin /usr/local/portage/layman/ruby"
SYNC="rsync://192.168.0.1/gentoo-portage"
USE="X aac acl acpi alsa ao avahi bash-completion berkdb bzip2 cairo cdparanoia cdr cli cracklib crypt curl directfb dri dv dvd dvdr exif ffmpeg firefox flac fortran ftp gd gdbm gif gnome gphoto2 gpm gtk gtk2 hal iconv imagemagick ipv6 isdnlog jabber jpeg jpeg2k lame libgda lm_sensors midi mmx mp3 mpeg mplayer mudflap muscicbrainz ncurses netboot nls nptl nptlonly ogg opengl openmp pam pcmcia pcre pdf perl php png pppd python readline reflection ruby samba sdl session sockets socks5 spl sqlite3 sse sse2 ssl ssse3 svg sysfs syslog tcpd tiff unicode usv wifi win32codecs x86 xcomposite xml xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl" USERLAND="GNU" VIDEO_CARDS="i965 i945 i810 vesa intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


emerge -pv libgadu

Code:
[ebuild   R   ] net-libs/libgadu-1.8.2  USE="ssl threads" 0 kB


grep PTHREAD /usr/include/libgadu.h

Code:

#define GG_CONFIG_HAVE_PTHREAD
#ifdef GG_CONFIG_HAVE_PTHREAD

_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 2:44 pm    Post subject: Reply with quote

Zawartość libgadu.h w porządku, wersja cmake w porządku. Mam starsze glibc i basha. Jeśli miałbym zgadywać, ten drugi może być winny.

Kadu robi coś takiego:
Code:
execute_process (
   COMMAND grep "#define GG_CONFIG_HAVE_PTHREAD" ${LIBGADU_INCLUDEDIR}/libgadu.h
   RESULT_VARIABLE LIBGADU_PTHEADS
)

if (NOT APPLE AND ${LIBGADU_PTHEADS} GREATER 0)
   message (FATAL_ERROR "libgadu must be compiled with pthreads support")
endif (NOT APPLE AND ${LIBGADU_PTHEADS} GREATER 0)


Nowy pomysł:
Code:
grep PTHREAD /usr/include/libgadu.h >/dev/null && echo true


Spróbuj też skompilować Kadu z palca. Raczej wyłoży się dokładnie tak samo, ale chcę mieć pewność.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 2:51 pm    Post subject: Reply with quote

Przy ręcznej kompilacji wywala się w tym samym momencie.
Jakieś pomysły?
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 2:54 pm    Post subject: Reply with quote

Komenda, którą podałem, zwraca "true"?
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 2:59 pm    Post subject: Reply with quote

Tak.
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 3:05 pm    Post subject: Reply with quote

W pierwszej kolejności spróbowałbym downgrade basha do czegoś z serii 3.2*. Możliwe, że execute_process głupieje pod nowym bashem.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 3:32 pm    Post subject: Reply with quote

Po
Code:
emerge --oneshot "=app-shells/bash-3.2_p48"

wciąż nie działa
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 3:49 pm    Post subject: Reply with quote

A przelogowałeś się?
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Mon May 25, 2009 3:55 pm    Post subject: Reply with quote

Oczywiście. Zgłosiłem błąd na bugs.gentoo.org, może ktoś coś poradzi ;-) http://bugs.gentoo.org/show_bug.cgi?id=271211
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 3:58 pm    Post subject: Reply with quote

Warto by też poruszyć sprawę na forum Kadu.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2460
Location: Polska / Lenkija

PostPosted: Mon May 25, 2009 4:53 pm    Post subject: Reply with quote

Może ${LIBGADU_INCLUDEDIR} ma nieprawidłową wartość...
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon May 25, 2009 5:42 pm    Post subject: Reply with quote

meal: Otwórz CMakeLists.txt i zmień COMMAND grep na COMMAND echo grep.

Chciałbym zobaczyć co wypluwa cmake po takim zabiegu.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
meal
n00b
n00b


Joined: 20 Nov 2006
Posts: 65
Location: Silesia / Poland

PostPosted: Wed May 27, 2009 7:12 pm    Post subject: Reply with quote

Problem solved. Okazało się, że w /usr/local/include była wersja libgadu kompilowana przezemnie ręcznie jakiś już czas temu, bez obsługi pthread.
Usunięcie felernego pliku pozwoliło na prawidłową kompilację. Swoją drogą: źle, że emerge korzystało z tej właśnie wersji biblioteki, zamiast korzystać z instalowanej z portage.
_________________
http://www.mkozak.pl
http://blog.mkozak.pl
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Wed May 27, 2009 7:15 pm    Post subject: Reply with quote

Tak? Moim zdaniem jest to całkiem oczekiwane zachowanie. Po prostu nie należy mieć bałaganu w systemie :)
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Sun Feb 14, 2010 8:19 pm    Post subject: Reply with quote

wydaje mi się, czy ebuild kadu jest coś nie teges? Nawet nie ma linka do downloadu wewnatrz pliku. Niedawno instalowalem 0.6.5.4 i bylo ok. Teraz usunalem kadu, zrobilem -s overlaya i ebuild juz nie byl taki sam. Czy to tylko u mnie coś nie tak?
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Sun Feb 14, 2010 8:42 pm    Post subject: Reply with quote

net-im/kadu to tylko meta-ebuild wciągający kadu-core i podstawowe moduły. Tak jest od początku w moich modularnych ebuildach. Nie jest to oznaka, że cokolwiek jest źle.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Mon Feb 15, 2010 11:02 am    Post subject: Reply with quote

sęk w tym, ze po zainstalowaniu 0.6.5.3 z drzewa, dodalem overlaya i w czasie instalacji nic sie nie kompilowalo, po czym jedyne co się stalo, to usuniete zostaly pliki wersji 0.6.5.3 ;d Nie mam pojęcia, czemu tak się dzieje. Być może coś się sknociło jak zainstalowałem niedawno 0.6.6 ze źródeł..

edit: przekompiluję wszystkie zaleznosci i mysle, ze bedzie ok. Swoja droga jest jakas komenda pozwalajaca rekompilowac dany ebuild wraz z jego zaleznosciami? Tak jak -e dla worlda?
Back to top
View user's profile Send private message
nUmer_inaczej
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2007
Posts: 133
Location: Bydgoszcz

PostPosted: Mon Feb 15, 2010 11:24 am    Post subject: Reply with quote

Code:
emerge -1av $(qlist -I -C net-im/kadu-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 4 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum