Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[EBUILD] Kadu 0.12.0 (modularne) - roslin
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon Feb 15, 2010 2:41 pm    Post subject: Reply with quote

Przy przejściu z monolitu na modularne Kadu warto wyrzucić całkiem net-im/kadu i zainstalować je od nowa, by uniknąć kolizji. Najpewniej to u ciebie zaszło. Gdybyś miał ustawione FEATURES="collision-protect", dostałbyś stosowne ostrzeżenie. Teraz pozostaje przekompilowanie wszystkich pakietów Kadu, jak pisał przedmówca.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Tue Mar 09, 2010 11:46 am    Post subject: Reply with quote

ok, super.

Czy będzie można liczyć na ebuild 0.6.6, gdy tylko wersja ta stanie się w miarę używalna. Nie ukrywam, że strasznie brakuje mi w tym komunikatorze wyszukiwania w historii.
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Tue Mar 09, 2010 2:13 pm    Post subject: Reply with quote

Tak, kiedy wyjdzie pierwsza beta, prawdopodobnie dorzucę zestaw ebuildów jako missing keyword.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Wed Apr 14, 2010 11:39 pm    Post subject: Reply with quote

No wiec mamy pierwsza betę ;)
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Thu Apr 15, 2010 3:08 pm    Post subject: Reply with quote

Istotnie. Wrzuciłem bez keywordów zestaw ebuildów do 0.6.6_beta1 - w skrócie core i wszystkie moduły, które były włączone w domyślnym configu. Reszta modułów jest jako blockery, żeby stare moduły nie zawadzały przy aktualizacji do 0.6.6. Bloki będą usuwane w miarę przywracania modułów.

Dla odważnych keywordy:
Code:
net-im/kadu **
net-im/kadu-qt4_docking **
net-im/kadu-qt4_docking_notify **
net-im/kadu-sql_history **
net-im/kadu-config_wizard **
net-im/kadu-history_migration **
net-im/kadu-history **
net-im/kadu-auto_hide **
net-im/kadu-autoaway **
net-im/kadu-spellchecker **
net-im/kadu-core **
net-im/kadu-sms **
net-im/kadu-alsa_sound **
net-im/kadu-gadu_protocol **
net-im/kadu-hints **
net-im/kadu-jabber_protocol **
net-im/kadu-dbus **
net-im/kadu-sound **
net-im/kadu-idle **
net-im/kadu-docking **
net-im/kadu-tabs **
net-im/kadu-server_monitor **
net-im/kadu-ext_sound **
net-im/kadu-exec_notify **
net-im/kadu-mediaplayer **
net-im/kadu-amarok2_mediaplayer **
net-im/kadu-kde_notify **
net-im/kadu-phonon_sound **

_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin


Last edited by mziab on Thu Apr 15, 2010 6:43 pm; edited 2 times in total
Back to top
View user's profile Send private message
kuku
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2004
Posts: 142

PostPosted: Thu Apr 15, 2010 4:29 pm    Post subject: Reply with quote

Quote:

Dla odważnych keywordy:

i moze szybkie info gdzie to wkleic ?
Back to top
View user's profile Send private message
Pryka
l33t
l33t


Joined: 08 Jun 2007
Posts: 625
Location: /dev/null

PostPosted: Thu Apr 15, 2010 6:29 pm    Post subject: Reply with quote

Code:
/etc/portage/package.keywords


Dokumentacja się kłania
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Sat Apr 17, 2010 2:26 pm    Post subject: Reply with quote

O dziwo powiem wam, że komunikator działa lepiej, niż się spodziewałem. No, może poza tym że dźwięki raz działają, a raz nie. Do tego przy każdym włączaniu programu muszę potwierdzać kontakty jabber. Poza tym kontakty trochę długo się ładują oraz czasami się wysypuje. No ale jak na betę - można wybzaczyć

PS. Ktoś wie jak wyłączyć opcję Grup? Nie grupuję kontaktów, tak więc nie chciałbym wyświetlać ich w grupie ALL.

Btw. dzięki za wstawkę ;)
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Sat Apr 17, 2010 2:43 pm    Post subject: Reply with quote

qubaaa: Konfiguracja/Wygląd/Lista kontaktów i odhacz Wyświetlaj zakładki grup. Sam to wyłączałem, bo mnie denerwowało :)
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Mon Apr 19, 2010 6:11 pm    Post subject: Reply with quote

Dzięki. No teraz już tylko czekać na poprawę stabilności + szybkości (historia) i będzie naprawdę fajny komunikator.
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Tue Jun 01, 2010 3:20 pm    Post subject: Reply with quote

Dodałem ebuildy do Kadu 0.6.6_beta2, a razem z nim cztery nowe moduły - autoresponder, desktop_docking, last_seen i tlen_protocol. Całość dostępna jak zwykle w roslinie.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
tomberry
n00b
n00b


Joined: 30 Aug 2010
Posts: 4

PostPosted: Mon Aug 30, 2010 6:37 am    Post subject: Reply with quote

Witam

Mam problem z kompilacją kadu 0.6.5.4

po emerge kadu wyskakuje taki błąd:

Code:
...........
[ 82%] Built target tabs                                                                                   
[ 82%] Building CXX object kadu-core/CMakeFiles/kadu.dir/about.cpp.o
/var/tmp/portage/net-im/kadu-0.6.5.4/work/kadu/kadu-core/main.cpp: In function ‘int main(int, char**)’:   
/var/tmp/portage/net-im/kadu-0.6.5.4/work/kadu/kadu-core/main.cpp:330: error: ‘fchmod’ was not declared in this scope
/var/tmp/portage/net-im/kadu-0.6.5.4/work/kadu/kadu-core/main.cpp:419: error: ‘mkdir’ was not declared in this scope
/var/tmp/portage/net-im/kadu-0.6.5.4/work/kadu/kadu-core/main.cpp:420: error: ‘mkdir’ was not declared in this scope
make[2]: *** [kadu-core/CMakeFiles/kadu.dir/main.cpp.o] Błąd 1
make[2]: *** Oczekiwanie na niezakończone zadania....
make[1]: *** [kadu-core/CMakeFiles/kadu.dir/all] Błąd 2
make: *** [all] Błąd 2
 * ERROR: net-im/kadu-0.6.5.4 failed:
 *   Make failed!
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 3035:  Called cmake-utils_src_compile
 *   environment, line  844:  Called _execute_optionaly 'src_compile'
 *   environment, line  317:  Called enable_cmake-utils_src_compile
 *   environment, line 1211:  Called cmake-utils_src_make
 *   environment, line  863:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *
 * If you need support, post the output of 'emerge --info =net-im/kadu-0.6.5.4',
 * the complete build log and the output of 'emerge -pqv =net-im/kadu-0.6.5.4'.
 * The complete build log is located at '/var/tmp/portage/net-im/kadu-0.6.5.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-im/kadu-0.6.5.4/temp/environment'.
 * S: '/var/tmp/portage/net-im/kadu-0.6.5.4/work/kadu'




macie jakieś sugestie ?


--- Edytowane przez moderatora:
Proszę używać BBCode.
Kurt Steiner
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon Aug 30, 2010 7:53 am    Post subject: Reply with quote

To błąd wywołany przez zmiany w glibc 2.12. Odmaskuj kadu-core-0.6.5.4-r2, w którym jest zawarty odpowiedni fix.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
tomberry
n00b
n00b


Joined: 30 Aug 2010
Posts: 4

PostPosted: Mon Aug 30, 2010 1:23 pm    Post subject: Reply with quote

Wygląda mi na to że ostatnią wersją w głównym drzewie portage jest 0.6.5.4 natomiast w drzewie roslin 0.6.5.3. Nie widzę u siebie wersji 0.6.5.4-r2 powinienem ją ściągnąć i zainstalować ręcznie ?

Oczywiście emerge --sync oraz layman -S zostało wpisane.
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon Aug 30, 2010 2:03 pm    Post subject: Reply with quote

Nic podobnego, w roslinie jest 0.6.5.4. Wersji 0.6.5.3 nie ma w repo od marca. Spróbuj usunąć i ponownie dodać repozytorium.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
tomberry
n00b
n00b


Joined: 30 Aug 2010
Posts: 4

PostPosted: Mon Aug 30, 2010 3:59 pm    Post subject: Reply with quote

Faktycznie po usunięciu i dodaniu repozytorium pokazały się nowe wersje 654 66beta4 i 66beta5. Niestety ciągle mam z tym problem chociaż może trochę z innej beczki, nie potrafię zainstalować nic z roslin tak jakby wcale nie istniał.

w /etc/make.conf mam wpisaną linijke source /var/lib/layman/make.conf

w /var/lib/layman/make.conf jest wpis

Code:

PORTDIR_OVERLAY="
/var/lib/layman/roslin
/var/lib/layman/sunrise
$PORTDIR_OVERLAY
"


Niestety po wpisaniu emerge =net-im/kadu-0.6.6_beta5
Code:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=net-im/kadu-0.6.6_beta5".


Gdy wpiszę emerge kadu próbuje się instalować wersja z drzewa głównego

w /etc/portage/package.unmask oraz w /etc/portage/package.keywords sa wpisy net-im/kadu
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Mon Aug 30, 2010 4:46 pm    Post subject: Reply with quote

Zgaduję, że po "source /var/lib/layman/make.conf" masz inną deklarację PORTDIR_OVERLAY.

Pokaż:
Code:
emerge --info | grep PORTDIR_OVERLAY

_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
tomberry
n00b
n00b


Joined: 30 Aug 2010
Posts: 4

PostPosted: Mon Aug 30, 2010 9:18 pm    Post subject: Reply with quote

To było dokładnie to, po zmianie PORTDIR_OVERLAY nareszcie działa layman no i skompilowało się nowe kadu.


Dziękuję za pomoc !
Back to top
View user's profile Send private message
zonexy
n00b
n00b


Joined: 17 Sep 2010
Posts: 6

PostPosted: Fri Sep 17, 2010 5:48 pm    Post subject: Reply with quote

Witam podpialem sie do tematu bo mam problem z kompilacja kadu 6.5.4

blad w emerge: http://wklej.org/id/390194/

emerge --info: http://wklej.org/id/390196/

bardzo prosze o pomoc i możliwie dokładne opisanie czynności które powinienem wykonać(dopiero zaczynam zabawe z gentoo)
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Fri Sep 17, 2010 8:17 pm    Post subject: Reply with quote

Po logu nie wygląda na to, żebyś używał ebuilda z roslina.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
one_and_only
Apprentice
Apprentice


Joined: 13 May 2007
Posts: 249
Location: PL/Krakow

PostPosted: Fri Sep 17, 2010 8:31 pm    Post subject: Reply with quote

Z innej beczki. Qt-4.7.0_rc1, kadu 0.6.6_beta7. Wszystko ładnie się skompilowało, ale próba załadowania modułu gadu_protocol kończy się błędem:
Code:
 undefined symbol _ZN9QXmlQueryD1Ev


BTW, jest jakaś opcja do emerge żeby po skompilowaniu nie czyścił katalogu gdzie się buduje?
Back to top
View user's profile Send private message
lazy_bum
l33t
l33t


Joined: 16 Feb 2005
Posts: 690

PostPosted: Tue Sep 21, 2010 9:29 pm    Post subject: Reply with quote

one_and_only wrote:

BTW, jest jakaś opcja do emerge żeby po skompilowaniu nie czyścił katalogu gdzie się buduje?

Code:
keeptemp
       Do not delete the ${T} directory after the merge process.

keepwork
       Do not delete the ${WORKDIR} directory after the merge process. ${WORKDIR} can then be reused since this feature  disables  most
       of  the  clean phase that runs prior to each build. Due to lack of proper cleanup, this feature can interfere with normal emerge
       operation and therefore it should not be left enabled for more than a short period of time.

Więcej w man make.conf.
_________________
roslin uberlay | grubelek
Back to top
View user's profile Send private message
qubaaa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2006
Posts: 148

PostPosted: Tue Oct 12, 2010 8:08 am    Post subject: Reply with quote

Jakiś apdejt co do ebuildów kadu?
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 638

PostPosted: Tue Oct 12, 2010 5:52 pm    Post subject: Reply with quote

Spokojnie, trzymam rękę na pulsie i staram się na bieżąco wrzucać nowe bety ;) Właśnie dorzuciłem _beta8.
_________________
Gentoo Linux 13.0 | 3.14.0 | glibc 2.17 | gcc 4.8.2

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
acei
Tux's lil' helper
Tux's lil' helper


Joined: 16 Sep 2007
Posts: 90

PostPosted: Fri Oct 29, 2010 8:07 pm    Post subject: Reply with quote

Chyba coś się pozmieniało we wszystkich changelog-ach na beta9


Code:
>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /var/lib/layman/roslin/net-im/kadu-core/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 6855
!!! Expected: 6724

!!! Digest verification failed:
!!! /var/lib/layman/roslin/net-im/kadu-history/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 3310
!!! Expected: 3173

itd

_________________
GA965P+E6320+Geil 2*1GB CL4+ATI HD6570 ~amd64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 5 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum