Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] Getting higher refresh rates using vesafb driver
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 12, 13, 14  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Flux-
n00b
n00b


Joined: 22 Nov 2003
Posts: 22
Location: Helsinki, Finland

PostPosted: Sat Sep 18, 2004 11:29 am    Post subject: Reply with quote

I tried to get my vesafb working at 800x600@120Hz, but I just get 60Hz always. Then I noticed that my graphic card not might be a VBE 3.0 compatible (I'm using Ati 3D Rage Pro AGP 1X/2X).

From dmesg I get:
Code:

vesafb: ATI Technologies Inc., MACH64GT, 01.00 (OEM: ATI MACH64)
vesafb: VBE version: 2.0
vesafb: protected mode interface info at c000:4785
vesafb: pmi: set display start = c00c4829, set palette = c00c48a1
vesafb: pmi: ports = 7885 781f 78b4 78b8 7818 7814 78c0 78c3 78c1
vesafb: monitor limits: vf = 0 Hz, hf = 0 kHz, clk = 0 MHz
vesafb: scrolling: ywrap using protected mode interface, yres_virtual=10485
vesafb: framebuffer at 0xfd000000, mapped to 0xc8800000, size 8192k
fb0: VESA VGA frame buffer device


And from fbset:
Code:

mode "800x600-56"
    # D: 36.001 MHz, H: 35.157 kHz, V: 56.252 Hz
    geometry 800 600 800 10485 8
    timings 27777 128 24 22 1 72 2
    hsync high
    vsync high
    rgba 6/0,6/0,6/0,0/0
endmode


So seems like my graphic card isn't a VBE 3.0 compatible. Is it impossible for me to get over 60Hz with vesafb? I have used 85Hz in X with the same graphic card (not using X atm).
Back to top
View user's profile Send private message
adrenalin
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2002
Posts: 129

PostPosted: Sat Sep 18, 2004 1:14 pm    Post subject: Reply with quote

Flux- wrote:


So seems like my graphic card isn't a VBE 3.0 compatible. Is it impossible for me to get over 60Hz with vesafb?


Yes that is what the vesafb patch docs say. Are you sure that you are using a rage pro and not a mach as your dmesg suggests? Why dont you use a native driver? aty128fb works for my rage 128 pro card.
Back to top
View user's profile Send private message
memborg
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jun 2003
Posts: 121
Location: Aalborg, Denmark

PostPosted: Thu Sep 30, 2004 12:54 pm    Post subject: Reply with quote

Mjallo

How do I get a bootsplash on my frambuffer console these are my options

Code:

grub.conf

default 0
timeout 5

splashimage=(hd0,0)/grub/splash.xpm.gz

title=Gentoo

root (hd0,0)
kernel /kernel-2.6.8 root=/dev/hda3 video=vesafb:ywrap,mttr,1600x1200-32@60 splash=verbose
initrd=/boot/initrd


kernel

<*> RAM disk support
   (4096) Default RAM disk size (kbytes)
   [*]   Initial RAM disk (initrd) support
   [*] Support for Large Block Devices
...
 <*>   VESA VGA graphics support
   VESA driver type (vesafb-tng)  --->
   (1600x1200-32@60) VESA default mode
...
 <*> Virtual Frame Buffer support (ONLY FOR TESTING!)
   Console display driver support  --->
   Logo configuration  --->
   [*] Support for the framebuffer splash

fbset

mode "1600x1200-60"
    # D: 162.022 MHz, H: 75.010 kHz, V: 60.008 Hz
    geometry 1600 1200 1600 2621 32
    timings 6172 304 64 46 1 192 3
    hsync high
    vsync high
    rgba 8/16,8/8,8/0,0/0
endmode

I have tried to use the gentoo-highqaulity bootsplash but it doesn't show any splash...

Code:

/sbin/splash -s -f /etc/bootsplash/gentoo-highquality/config/bootsplash-1600x1200.cfg >> /boot/initrd


doesn't seem like anuone want to help...
Back to top
View user's profile Send private message
Halanegri
Guru
Guru


Joined: 03 Mar 2003
Posts: 351
Location: Reykjavík, Iceland

PostPosted: Sun Oct 24, 2004 7:56 am    Post subject: Reply with quote

memborg: You're asking about this in the wrong thread. This is about vesafb, not bootsplash/fbsplash. :?
Back to top
View user's profile Send private message
Halanegri
Guru
Guru


Joined: 03 Mar 2003
Posts: 351
Location: Reykjavík, Iceland

PostPosted: Sun Oct 24, 2004 8:14 am    Post subject: Reply with quote

Hey, I have a Dell Inspiron 8600c with an ATi Radeon 9600 128mb Pro. How can I use my native 1680x1050 resolution with vesafb/vesafb-tng/radeonfb ?

I've tried calculating the timings and putting an entry in /usr/src/linux/drivers/video/modedb.c, and then passing "video:vesafb,1680x1050-32@60" as an option but it always gives me a blank screen. 1680x1050 doesn't show up in /proc/fb0/modes.


EDIT: Never mind, it seems to work automatically out of the box with radeonfb, no patching needed, I didn't even have to specify a video mode in my bootloader.
Back to top
View user's profile Send private message
AvantLegion
n00b
n00b


Joined: 12 Nov 2003
Posts: 59

PostPosted: Tue Mar 15, 2005 12:07 am    Post subject: Reply with quote

Halanegri wrote:
Hey, I have a Dell Inspiron 8600c with an ATi Radeon 9600 128mb Pro. How can I use my native 1680x1050 resolution with vesafb/vesafb-tng/radeonfb ?

I've tried calculating the timings and putting an entry in /usr/src/linux/drivers/video/modedb.c, and then passing "video:vesafb,1680x1050-32@60" as an option but it always gives me a blank screen. 1680x1050 doesn't show up in /proc/fb0/modes.


EDIT: Never mind, it seems to work automatically out of the box with radeonfb, no patching needed, I didn't even have to specify a video mode in my bootloader.


Do your KDE, GNOME, etc, still work?

I have an Inspiron 6000 with a Radeon x300 Mobility, and a 1680x1050 native LCD.

radeonfb works for me, but conflicts with the fglrx driver anytime I try to do anything substantial in X (like a DE like KDE or GNOME)
Back to top
View user's profile Send private message
ikaro
Advocate
Advocate


Joined: 14 Jul 2003
Posts: 2526
Location: Denmark

PostPosted: Tue Mar 15, 2005 4:16 pm    Post subject: Reply with quote

if you had waited just a little bit more.... :lol:
_________________
linux: #232767
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 12, 13, 14
Page 14 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum