Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UPDATE] Getting higher refresh rates using vesafb driver
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 11, 12, 13, 14  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Wed Jul 07, 2004 7:26 pm    Post subject: Reply with quote

MaxDamage wrote:
Somebody got the 2.6.7 gentoo-dev-sources patched and working?

You can manually find the line 'static struct fb_ops vesafb_ops (...)' in drivers/video/vesafb.c and remove the word 'static' to make it work.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Thu Jul 08, 2004 12:20 pm    Post subject: Reply with quote

I applied the gentoo patch, made the change, and then genkernel worked smoothly. I will see if the patch works in the next reboot.
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
Dinini
Apprentice
Apprentice


Joined: 11 Jun 2003
Posts: 236

PostPosted: Thu Jul 08, 2004 12:23 pm    Post subject: Reply with quote

Jazz wrote:
Code:
root@Matrix{/home/jazz}> /usr/X11R6/bin/xvidtune -show | ./modeline2fb.pl >> /etc/fb.modes
Illegal division by zero at ./modeline2fb.pl line 22, <STDIN> line 1.
Any ideas?

Are you sure you're running that command in an Xwindows terminal session? That's the error you'd receive if the "/usr/X11R6/bin/xvidtune -show" command produced an error message rather than a valid modeline. Try it by itself first to verify output before piping the output to ./modeline2fb.pl
Back to top
View user's profile Send private message
deNniZ
n00b
n00b


Joined: 25 Jun 2004
Posts: 5
Location: Kerpen

PostPosted: Thu Jul 08, 2004 3:10 pm    Post subject: Reply with quote

nojon wrote:
This may be of interest to nVidia users :

As some of you may know nVidia graphics cards are a mess when it comes to switching between a MultiHead / Twinview display and the vesafb-console window - it simply gets corrupted. And now the good thing : vesafb-tng solves this bug - the vesa console does not get corrupted anymore when switching between X and framebuffer console !

Good news for nVidia users !!!

Considering the fact that the vesafb-tng patch solves a major bug for probably a huge number of linux boxes how good are the chances that this patch will be applied to vanilla linux ?


I can agree i tried it and my pc never crashed again when exiting XFree with twinview enabled, this is really really nice! Now i can use twinview! The only problem is, if i use a fbdevice higher than 800x600 everything is like before (my PC crashes when exiting X). Dunno why...

Ok for the stats:

I have a
GF4ti4200 AGP 8x (NV28)
Gentoo-dev-sources 2.6.7 patched for fb-tng

If sumone needs more infos ask me!

Yeah twinview rocks FB-tng rocks u rock!

keep it up!
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Fri Jul 09, 2004 9:15 pm    Post subject: Reply with quote

I haven't been able to change the refresh rate. I must be doing something wrong, lot of resolution just corrupt the framebuffer ad the ones that work do at 60Hz. I have some questions:

Has some relation the parameter in the kernel line
Code:
video=vesafb:ywrap,mtrr,1024x768-16@75
with the ones defined in /etc/fb.modes?

I may probably have messed the config files up. How could I regenerate fb.modes?

Could somebody post the grub line for the kernel and the fb.modes part that correspond?

When I try fbset 1152x864 with the config generated by the perl scrypt, I get this message:
Code:
ioctl FBIOPUT_VSCREENINFO: Invalid argument
The config is what I'm using in X.
Code:
mode "1152x864"
   # D: 108.30 MHz, H: 70.51 kHz, V: 78.00 Hz
   geometry 1152 864 1152 864 32
   timings 9233 88 56 26 2 240 12
endmode
I don't know what's the problem.


Thanx a lot.
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
Rafje
Tux's lil' helper
Tux's lil' helper


Joined: 19 May 2004
Posts: 109
Location: .be

PostPosted: Sat Jul 10, 2004 3:06 pm    Post subject: Reply with quote

Works great. Thanks Spock_!

Just wanted to let you know that the gentoo-dev-sources 2.6.7-r9 don't accept the vesafb-tng patch:
Code:
mokka linux-2.6.7-gentoo-r9 # pwd
/usr/src/linux-2.6.7-gentoo-r9
mokka linux-2.6.7-gentoo-r9 # bzip2 -dc /root/DL/vesafb-tng-0.9-rc2-2.6.7-gentoo.patch.bz2 | patch -p1
patching file arch/i386/boot/video.S
patching file Documentation/fb/vesafb.txt
patching file drivers/video/fbmem.c
patching file drivers/video/Kconfig
patching file drivers/video/Makefile
patching file drivers/video/vesafb.c
Hunk #6 FAILED at 246.
Hunk #7 succeeded at 468 (offset -3 lines).
Hunk #8 succeeded at 495 (offset -3 lines).
Hunk #9 succeeded at 516 (offset -3 lines).
Hunk #10 succeeded at 818 (offset -3 lines).
Hunk #11 succeeded at 857 (offset -3 lines).
Hunk #12 succeeded at 887 (offset -3 lines).
Hunk #13 succeeded at 1153 (offset -3 lines).
1 out of 13 hunks FAILED -- saving rejects to file drivers/video/vesafb.c.rej
patching file drivers/video/vesafb-thread.c
patching file include/video/vesa.h
mokka linux-2.6.7-gentoo-r9 #
The gentoo-dev-sources 2.6.7-r8 accepted the patch without problems.

Cheers
Back to top
View user's profile Send private message
dec
n00b
n00b


Joined: 18 Jul 2003
Posts: 63

PostPosted: Sat Jul 10, 2004 4:32 pm    Post subject: Reply with quote

Code:
tom@elmo tom $ dmesg | grep vesa
Kernel command line: root=/dev/hda3 video=vesafb:ywrap,vram:800x600-16@70
vesafb: Leadtek Research Inc., NV15 (GeForce4) Board, Chip Rev A0 (OEM: WinFast VGA BIOS.)
vesafb: VBE version: 3.0
vesafb: protected mode interface info at c000:bca0
vesafb: pmi: set display start = c00cbce5, set palette = c00cbd6a
vesafb: pmi: ports = 3b4 3b5 3ba 3c0 3c1 3c4 3c5 3c6 3c7 3c8 3c9 3cc 3ce 3cf 3d0 3d1 3d2 3d3 3d4 3d5 3da
vesafb: hardware doesn't support DCC transfers
vesafb: monitor limits: vf = 0 Hz, hf = 0 kHz, clk = 0 MHz
vesafb: total memory: 838860800
vesafb: scrolling: ywrap using protected mode interface, yres_virtual=1048576
vesafb: cannot reserve video memory at 0xd8000000
vesafb: abort, cannot ioremap video memory 0x32000000 @ 0xd8000000
vesafb: probe of vesafb0 failed with error -5


Any ideas? :) this is on 2.6.7-cko6 (based on -ck5)

Thanks guys :)
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Sat Jul 10, 2004 5:45 pm    Post subject: Reply with quote

I'm a bit lost. What I should do is
- Apply the patch to the source tree.
- Compile the kernel.
- Add the needed option to the grub.conf file.

I'm missing something? What about the /usr/src/linux/scripts/vesa_modeline_gen.pl script? Isn't needed anymore? The modes I use in the video option inside grub.conf has something to do with the names of the modes of /etc/fb.modes?

**EDIT**

Ok, I tested some resolutions and I got:

- 1152x864 and 1600x1200 don't work. Probably because they aren't standart vesa modes.

- All the other res work but at 60Hz. Cannot set the frequency neither in the kernel line, the "default" option into menuconfig nor the fbset command. Always default to 60Hz. Any idea?

**EDIT2**

fbset gives a funny output:
Code:
mode "1024x768-85"
    # D: 94.500 MHz, H: 68.677 kHz, V: 84.997 Hz
    geometry 1024 768 1024 768 8
    timings 10582 208 48 36 1 96 3
    hsync high
    vsync high
    rgba 6/0,6/0,6/0,0/0
endmode


1) 1024x768@85 (as suggested in the menuconfig default setting) will become 1024x768-85. I should then write 1024x768-16@85?

2) rgba 6/0,6/0,6/0,0/0 reminds me another post in this thread. Sorry spock_, I'm in the same case than Dojo, but he didn't come back to tell how the problem was solved (if solved).
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
phlashback
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jul 2002
Posts: 142
Location: Normal

PostPosted: Sun Jul 11, 2004 9:27 am    Post subject: Reply with quote

dec

Kernel command line:
root=/dev/hda3 video=vesafb:ywrap,vram:800x600-16@70

should be:
root=/dev/hda3 video=vesafb:ywrap,vram:16,800x600-16@70

HTH
_________________
The terrible thing about hell is that when you're there you can't even tell as you move through this life you love so you could be there and not even know
Back to top
View user's profile Send private message
gjn
n00b
n00b


Joined: 13 Jul 2004
Posts: 2

PostPosted: Tue Jul 13, 2004 9:36 pm    Post subject: Reply with quote

i have problmes applying the patch. here is what i get (on the gentoo-dev-sources-r8):

root@miles linux # bzip2 -dc /home/gjn/patch.bz2 | patch -p1
patching file arch/i386/boot/video.S
patching file Documentation/fb/vesafb.txt
patching file drivers/video/fbmem.c
patching file drivers/video/Kconfig
patching file drivers/video/Makefile
Hunk #1 succeeded at 44 (offset 1 line).
patching file drivers/video/vesafb.c
Hunk #6 FAILED at 246.
Hunk #7 succeeded at 474 (offset 3 lines).
Hunk #8 succeeded at 501 (offset 3 lines).
Hunk #9 succeeded at 522 (offset 3 lines).
Hunk #10 succeeded at 824 (offset 3 lines).
Hunk #11 succeeded at 863 (offset 3 lines).
Hunk #12 succeeded at 893 (offset 3 lines).
Hunk #13 succeeded at 1159 (offset 3 lines).
1 out of 13 hunks FAILED -- saving rejects to file drivers/video/vesafb.c.rej
patching file drivers/video/vesafb-thread.c
patching file include/video/vesa.h

i can't compile the kernel anymore. i will try to fix this myself.

edit: stupid things posted.
Back to top
View user's profile Send private message
gjn
n00b
n00b


Joined: 13 Jul 2004
Posts: 2

PostPosted: Tue Jul 13, 2004 10:32 pm    Post subject: Reply with quote

Update:

I was able to repatch the kernel. quite bizzare though. I copied the original files from the -r9 to the -r8 sources and then applied the patch again.

this time, it worked. hmm. I recompiled the kernel, and guess what:

I boot now at 1280x1024 with 85 kHz. That's what i wanted. Thanks spock_ for the patch.

Any idea when this patch will be included into the g-d-sources?
Back to top
View user's profile Send private message
Neo_0815
l33t
l33t


Joined: 24 Feb 2003
Posts: 815
Location: Leipzig

PostPosted: Wed Jul 14, 2004 12:12 am    Post subject: Reply with quote

Kernel Version ist g-d-2.6.7-r10, latest patch installed properly for tng.

But now i am getting:

Kernel command line: root=/dev/hde2 video=vesafb:1024x768-16@85,mttr splash=silent elevator=cfq gentoo=nodevfs
vesafb: NVidia Corporation, NV15 Reference Board, Chip Rev A0 (OEM: NVidia)
vesafb: VBE version: 3.0
vesafb: protected mode interface info at c000:0f03
vesafb: pmi: set display start = c00c0f3c, set palette = c00c0fb2
vesafb: pmi: ports = 3b4 3b5 3ba 3c0 3c1 3c4 3c5 3c6 3c7 3c8 3c9 3cc 3ce 3cf 3d0 3d1 3d2 3d3 3d4 3d5 3da
vesafb: hardware supports DCC2 transfers
vesafb: EDID vendor sign: STN
vesafb: monitor limits: vf = 160 Hz, hf = 70 kHz, clk = 110 MHz
vesafb: total memory: 67108864
vesafb: probe of vesafb0 failed with error -22

vram:16, ypan - all the same error.

Whats does -22 mean ? With rrc all is working right - but tng doesnt work for me at the moment.

Any help appreciated.

best regards
Back to top
View user's profile Send private message
dec
n00b
n00b


Joined: 18 Jul 2003
Posts: 63

PostPosted: Wed Jul 14, 2004 7:56 am    Post subject: Reply with quote

phlashback wrote:
dec

Kernel command line:
root=/dev/hda3 video=vesafb:ywrap,vram:800x600-16@70

should be:
root=/dev/hda3 video=vesafb:ywrap,vram:16,800x600-16@70

HTH


Thanks buddy, greatly appreciated. :)
Back to top
View user's profile Send private message
garo
Moderator
Moderator


Joined: 15 Jul 2002
Posts: 860
Location: Edegem,BELGIUM

PostPosted: Wed Jul 14, 2004 5:31 pm    Post subject: Reply with quote

Which patch should i use for a 32-bits system with a 2.6.5 kernel ?

EDIT: I found it.
It seams that the vesafb-rrc-0.1.6-2.6.x patch also works on 32-bits systems
_________________
My favorite links this month:
- Surf Random
- Web-based SSH
- Stop Spam
Back to top
View user's profile Send private message
Neocorp
n00b
n00b


Joined: 15 Jul 2004
Posts: 8
Location: Erlangen / Germany

PostPosted: Fri Jul 16, 2004 4:50 pm    Post subject: Reply with quote

I must admit im quite new to gentoo, so please excuse me if I asked something that has been answered already in a different way.

Im trying to patch gentoo-2.6.7-r11 sources, and it gives mit this error:

bash-2.05b# bzip2 -dc /home/neocorp/Downloads/vesafb-tng-0.9-rc2-2.6.7-gentoo.patch.bz2 | patch -p1
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -Naur linux-2.6.7-orig/arch/i386/boot/video.S linux-2.6.7-vesafb/arch/i386/boot/video.S
|--- linux-2.6.7-orig/arch/i386/boot/video.S 2004-06-22 21:56:34.000000000 +0200
|+++ linux-2.6.7-vesafb/arch/i386/boot/video.S 2004-06-27 16:04:59.000000000 +0200
--------------------------
File to patch:


The weird thing is, patching worked with the r9-sources i was using before, but compiling didnt. Im using the vesafb-tng-0.9-rc2-2.6.7.patch.bz2 patch. (Is this wrong?)
Back to top
View user's profile Send private message
Neocorp
n00b
n00b


Joined: 15 Jul 2004
Posts: 8
Location: Erlangen / Germany

PostPosted: Sat Jul 17, 2004 12:58 pm    Post subject: Reply with quote

wow, it works better now, though CHUNK 6 fails at 246:

]
Code:
bash-2.05b# bzip2 -dc /home/neocorp/Downloads/vesafb-tng-0.9-rc2-2.6.7-gentoo.patch.bz2 | patch -p1
patching file arch/i386/boot/video.S
patching file Documentation/fb/vesafb.txt
patching file drivers/video/fbmem.c
patching file drivers/video/Kconfig
patching file drivers/video/Makefile
patching file drivers/video/vesafb.c
Hunk #6 FAILED at 246.
Hunk #7 succeeded at 468 (offset -3 lines).
Hunk #8 succeeded at 495 (offset -3 lines).
Hunk #9 succeeded at 516 (offset -3 lines).
Hunk #10 succeeded at 818 (offset -3 lines).
Hunk #11 succeeded at 857 (offset -3 lines).
Hunk #12 succeeded at 887 (offset -3 lines).
Hunk #13 succeeded at 1153 (offset -3 lines).
1 out of 13 hunks FAILED -- saving rejects to file drivers/video/vesafb.c.rej
patching file drivers/video/vesafb-thread.c
patching file include/video/vesa.h
Back to top
View user's profile Send private message
snowracer
n00b
n00b


Joined: 18 Jul 2004
Posts: 1
Location: Czech Republic

PostPosted: Sun Jul 18, 2004 5:46 pm    Post subject: Problems with patch & gentoo-dev-sources Reply with quote

I have the same problem with gentoo-dev-source-2.6.7-r11, however the patch works fine with -r8. After editing the vesafb.c file it can even be compiled and work fine for me.
Back to top
View user's profile Send private message
Sh4doW
n00b
n00b


Joined: 13 Mar 2003
Posts: 36

PostPosted: Tue Jul 20, 2004 8:44 pm    Post subject: undefined mode number Reply with quote

hey ...

first of all ... thank you SOOOO VERY VERY MUCH!

a) (as deNniZ already mentioned) flickering screen is gone when returning from X!
b) 1024x768 @ 100Hz? YESSSSSS!

but ... there's a problem ... let's move on ...

i'm running gentoo-dev-sources-2.6.7-r11 patched with vesafb-tng-0.9-rc2-2.6.7-gentoo.patch.bz2 (i had some problems with vesafb.c but, everything worked out ok - at least kernel compiled without problems).

after reboot i get this message from kernel:
Code:

...
you passed an undefined mode number
...

... and that's about it ... no bootsplash, no 1024x768 ... no nothing. i can change mode, or press space/enter to move on ...

now for my lilo.conf :
Code:

...
vga=791
...
append = "notmpfs quiet video=vesafb:1024x768-32@100 splash=silent"
...

i've also thied different video settings like 1024x768-16(@100), and the one that kindow works is bare video=vesafb:1024x768 where i get 1024x768 interlaced @ 87 Hz ... but that's all. (i still get "undefined mode number" message at boot)

now for fb.modes :
Code:

...
mode "1024x768"
   # D: 113.31 MHz, H: 81.40 kHz, V: 100.00 Hz
   geometry 1024 768 1024 768 32
   timings 8825 184 72 42 1 112 3
endmode
...

i've also tried different combinations here like 1024x768-32@100,1024x768-100,1024x768-32,... you name it ... nothing.

well ... anyway ... when my system is up&running i can run
Code:

fbset 1024x768 (or some other mode like 800x600,...)

and my console is up to 1024x768 ... working like a charm @ 100Hz, but ... i can't get it to work at boot time.

any ideas? mostly i'm looking for some help around that append thing that you pass to kernel in lilo.conf ... can someone provide me with some other parameters that work for them on nvidia?

thanks in advance.
_________________
only sheep need a leader.
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Tue Jul 20, 2004 8:57 pm    Post subject: Re: undefined mode number Reply with quote

Sh4doW wrote:
any ideas? mostly i'm looking for some help around that append thing that you pass to kernel in lilo.conf ... can someone provide me with some other parameters that work for them on nvidia?


First of all, get rid of the vga= option. vesafb-tng supports only the video= parameter, vga= is irrelevant and will only cause problems. If after removing vga= and setting video to video=vesafb:1024x768-32@100 you still won't get 100 Hz during boot-time, please post/send me the output of `dmesg | grep vesa`.
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
Sh4doW
n00b
n00b


Joined: 13 Mar 2003
Posts: 36

PostPosted: Wed Jul 21, 2004 12:01 am    Post subject: Reply with quote

removed vga line from lilo.conf and got rid of "you passed an undefined mode number" message.

it's not that i don't get 100hz at boot-time i don't even get 1024x768 ...

anyway here's my dmesg for vesa :
Code:

Kernel command line: auto BOOT_IMAGE=Gentoo ro root=307 notmpfs quiet video=vesafb:1024x768-32@100 splash=silent
vesafb: Leadtek Research Inc., NV25 Board, Chip Rev    (OEM: WinFast VGA BIOS.)
vesafb: VBE version: 3.0
vesafb: protected mode interface info at c000:edb0
vesafb: pmi: set display start = c00cedf5, set palette = c00cee7a
vesafb: pmi: ports = b4c3 b503 ba03 c003 c103 c403 c503 c603 c703 c803 c903 cc03 ce03 cf03 d003 d103 d203 d303 d403 d503 da03 ff03
vesafb: hardware doesn't support DCC transfers
vesafb: monitor limits: vf = 0 Hz, hf = 0 kHz, clk = 0 MHz
vesafb: total memory: 67108864
vesafb: scrolling: redraw
vesafb: framebuffer at 0xd0000000, mapped to 0xd8807000, size 65536k


and here's some more info on bootsplash ...
Code:

bootsplash 3.1.4-2004/02/19-spock-0.1: looking for picture.... silentjpeg size 192688 bytes, found (1024x768, 192748 bytes, v3).
bootsplash: error while decompressing silent picture: height mismatch (3)
bootsplash: error while decompressing picture: height mismatch (3) .
bootsplash: error while decompressing picture: height mismatch (3) .
Console: switching to colour frame buffer device 61x21


i hope this helps ... somehow.

btw, thanks for quick reply.
_________________
only sheep need a leader.
Back to top
View user's profile Send private message
spock_
Retired Dev
Retired Dev


Joined: 13 Jun 2003
Posts: 84
Location: Poland, Earth

PostPosted: Wed Jul 21, 2004 10:07 am    Post subject: Reply with quote

Sh4doW wrote:
Code:

vesafb: scrolling: redraw
vesafb: framebuffer at 0xd0000000, mapped to 0xd8807000, size 65536k


And after that, there's no mode-switch to 1024x768? Do you have any other framebuffer drivers compiled into the kernel? Have you tried 1024x768 with other refresh rates (or with no refresh rate at all)?
_________________
"In the beginning the Universe was created. This has made a lot of people very angry and been widely regarded as a bad move."
Back to top
View user's profile Send private message
Sh4doW
n00b
n00b


Joined: 13 Mar 2003
Posts: 36

PostPosted: Wed Jul 21, 2004 10:53 am    Post subject: Reply with quote

i recompiled the kernel (made sure that only vesafb was selected) ... added the default value 1024x768@100 ... same thing.

i've tried 85Hz and it works fine, but as soon as i try to pass the color depth parameter (like 1024x768-16@85 or -32) i'm back at 640x480 ... meaning, bootup logo won't show up since it's 16bit picture ...

if i use only video=vesafb:1024x768 or even without video parameter i'm stuck with 1024x768@87 interlaced untill i change it with fbset.

i've also tried 800x600@140 ... doesn't work ... could it be that kernel parameter only takes 2 digits for refresh rate (i'd think so after reading the documentation ... <rr>?

what about that
Code:
vesafb: monitor limits: vf = 0 Hz, hf = 0 kHz, clk = 0 MHz

thing i get ... i've seen people get some different numbers here, do you think this is related?
_________________
only sheep need a leader.
Back to top
View user's profile Send private message
crahen
n00b
n00b


Joined: 11 Jan 2004
Posts: 51

PostPosted: Sat Jul 31, 2004 3:34 am    Post subject: VBE 2.0 Reply with quote

Is it possible to still use this patch to get modes like 1400x1050 on LCDs when your laptops video card only supports VBE 2.0?
Back to top
View user's profile Send private message
crahen
n00b
n00b


Joined: 11 Jan 2004
Posts: 51

PostPosted: Sat Jul 31, 2004 1:33 pm    Post subject: Re: VBE 2.0 Reply with quote

crahen wrote:
Is it possible to still use this patch to get modes like 1400x1050 on LCDs when your laptops video card only supports VBE 2.0?

VBE 3.0 only I guess... darn
Back to top
View user's profile Send private message
snekiepete
Guru
Guru


Joined: 07 May 2003
Posts: 306
Location: WISCONSIN

PostPosted: Sat Jul 31, 2004 11:25 pm    Post subject: Reply with quote

Im getting 1400x1050 with it
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 11, 12, 13, 14  Next
Page 12 of 14

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum