Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
-mvis cflags
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
erm67
Tux's lil' helper
Tux's lil' helper


Joined: 01 Nov 2005
Posts: 130
Location: somewhere in Berlusconia.

PostPosted: Sat Sep 27, 2008 9:24 pm    Post subject: -mvis cflags Reply with quote

Just installed gentoo sparc 2008.0 stage3 on my old Ultra2, good work I find it really improved.
I'd like to use these CFLAGS found on this forum:
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -mvis -Wa,-Av8plusa -O2 -pipe"

my question is should I now
emerge -e world
and recompile everything or it isn't required?
If I should than I will probably switch to ~sparc as well .....
_________________
Truck!!
A posse ad esse non valet consequentia
Πάντα ῥεῖ
Back to top
View user's profile Send private message
zyko
l33t
l33t


Joined: 01 Jun 2008
Posts: 617
Location: Munich, Germany

PostPosted: Sun Sep 28, 2008 5:58 pm    Post subject: Reply with quote

It's not required to re-emerge your existing system. It should work just fine if you don't. If you switch to ~sparc, you'll end up recompiling almost everything.
Back to top
View user's profile Send private message
erm67
Tux's lil' helper
Tux's lil' helper


Joined: 01 Nov 2005
Posts: 130
Location: somewhere in Berlusconia.

PostPosted: Sun Sep 28, 2008 6:54 pm    Post subject: Reply with quote

Too late already emerging ...
I 'm recompiling everything rigth after a stage 3 install so it is only 129 packages and 70 are already done.
I was browsing the package list and many useful packages are only ~sparc
, I did not switched to a full ~sparc however because I fear large packages recompilations every other day, I'd like to use it for other things beside emerging.
I have other problems to solve rigth now:
Silo doesn't boot it stops rigth after initializing memory....
I am also recompiling the kernel with the .config from the live cd rigth now (and emerging -e world).
My Ultra2 enterprise had 2 disks but 1 broke a few months ago so there is only 1, I was thinking maybe it is in the second controller and this confuses silo .....
EDIT
It turned out I had set the boot-device prom variable to "cdrom disk net" so it was waiting for a cd to be inserted, silly thing .....
I tried boot disk 0 in OBP and it didn't booted while boot disk1 did, so I swapped the disks, changed the boot-device variable back to "disk net" and now it boots :-)
_________________
Truck!!
A posse ad esse non valet consequentia
Πάντα ῥεῖ
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum