Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
volume settings lost on startx
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rubing
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2008
Posts: 77
Location: Bham, AL

PostPosted: Sat Sep 27, 2008 5:13 pm    Post subject: volume settings lost on startx Reply with quote

Team Gentoo,

I am using XFCE4. Everytime I start it (startx) it starts up with the volume turned all the way down. And I have to go into Volume Control on the Multimedia menu to turn it up. THis is annoying as all hell!!!! Can someone please tell me how to fix it so that the volume settings are remembered?

THANK YOU!
Back to top
View user's profile Send private message
erik258
Advocate
Advocate


Joined: 12 Apr 2005
Posts: 2650
Location: Twin Cities, Minnesota, USA

PostPosted: Sat Sep 27, 2008 5:29 pm    Post subject: Reply with quote

I think you'll find that your sound will be turned all the way down, and probably muted as well, regardless of whether you use XFCE4 or not. If this is indeed true, you need to use the /etc/init.d/alsasound initscript (probably in the boot or default runlevel) to restore mixer volume levels on boot. ALSA automatically starts sound drivers with the mixers turned down all the way. Before you use startx next time, run:
Code:
/etc/init.d/alsasound start
and then:
Code:
alsamixer
and turn up the volumes, then press escape, and make sure to start alsa on boot next time with:
Code:
rc-update add alsasound default


But, if you find that before you startx, volume settings are fine, then it would seem to be an XFCE4 problem with which I am afraid I cannot assist.

Best of luck!
_________________
Configuring a Firewall? Try my iptables configuration
LinuxCommando.com is my blog for linux-related scraps and tidbits. Stop by for a visit!
Back to top
View user's profile Send private message
notHerbert
Advocate
Advocate


Joined: 11 Mar 2008
Posts: 2228
Location: 45N 73W

PostPosted: Sat Sep 27, 2008 5:36 pm    Post subject: Reply with quote

How do you start your X session, with a *dm, or startx?
Back to top
View user's profile Send private message
rubing
Tux's lil' helper
Tux's lil' helper


Joined: 10 Aug 2008
Posts: 77
Location: Bham, AL

PostPosted: Sat Sep 27, 2008 11:39 pm    Post subject: Reply with quote

I do not have any alsa scripts in my init.d directory?

i start xfce by just using startx
Back to top
View user's profile Send private message
erik258
Advocate
Advocate


Joined: 12 Apr 2005
Posts: 2650
Location: Twin Cities, Minnesota, USA

PostPosted: Sun Sep 28, 2008 12:02 am    Post subject: Reply with quote

Quote:
I do not have any alsa scripts in my init.d directory?

perhaps then you need to emerge alsa-utils?

The script /etc/init.d/alsasound should do this, as long as in /etc/conf.d/alsasound you have a line like:
Code:
RESTORE_ON_START="yes"

(and not one later on setting it to "no", of course)
_________________
Configuring a Firewall? Try my iptables configuration
LinuxCommando.com is my blog for linux-related scraps and tidbits. Stop by for a visit!
Back to top
View user's profile Send private message
notHerbert
Advocate
Advocate


Joined: 11 Mar 2008
Posts: 2228
Location: 45N 73W

PostPosted: Mon Sep 29, 2008 10:10 am    Post subject: Reply with quote

Also, after you emerge and configure alsa-utils, you can preset the volume in $HOME/.xinitrc
Code:
amixer set PCM 50%
amixer set Master 100%
Back to top
View user's profile Send private message
RedSquirrel
Guru
Guru


Joined: 22 Apr 2008
Posts: 336

PostPosted: Mon Sep 29, 2008 7:08 pm    Post subject: Reply with quote

rubing,

http://www.gentoo.org/doc/en/alsa-guide.xml
Back to top
View user's profile Send private message
holyholy
n00b
n00b


Joined: 08 Nov 2012
Posts: 1

PostPosted: Thu Nov 08, 2012 4:27 am    Post subject: Re: volume settings lost on startx Reply with quote

rubing wrote:
Team Gentoo,

I am using XFCE4. Everytime I start it (startx) it starts up with the volume turned all the way down. And I have to go into Volume Control on the Multimedia menu to turn it up. THis is annoying as all hell!!!! Can someone please tell me how to fix it so that the volume settings are remembered?

THANK YOU!



Hi,

I know maybe it's too late, here the answer.

Recently, I have the same problem, in my case I use openbox.

My alsasound run at boot time and my alsa conf are goods.

But I have found the problem !

It's locatide in this directory, /etc/xdg/autostart.

You will find a lot of file, with extension .desktop

Take a look to pulseaudio*.desktop

In my case, it was pulseaudio.desktop !

Tray to change all pulseaudio, for example pulseaudio.desktop.old and pulseaudio-kde.desktop.old in order to eliminate the guilty.

Then test with startx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum