Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New open source version of zarafa
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Thu Sep 25, 2008 4:55 pm    Post subject: New open source version of zarafa Reply with quote

www.zarafa.com released their open source version which I guess can now be compiled on Gentoo. Has anybody made an ebuild to be submitted? Will there ever be a submittable ebuild? If nobody is thinking of doing so, is there a way that I can try and make an ebuild?
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
frenkel
Veteran
Veteran


Joined: 13 May 2003
Posts: 1034
Location: .nl

PostPosted: Thu Sep 25, 2008 8:30 pm    Post subject: Reply with quote

Normally ebuilds like this are submitted to http://bugs.gentoo.org. I can't find anything there right now, so I don't think somebody made an ebuild yet. If you feel brave you can try to write one yourself. If you succeed, please post it to http://bugs.gentoo.org, so that other people can profit from it and it can (hopefully) be included in the portage tree.
Some guidance can be found here: http://devmanual.gentoo.org/ebuild-writing/
Back to top
View user's profile Send private message
sven_sol
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 120
Location: Royston, Herts. UK

PostPosted: Sun Sep 28, 2008 10:50 am    Post subject: Reply with quote

I'm no ebuild writer, but libvmime and libical need to be patched with their own mods. Not a big problem for me, I doubt many people use libvmime or libical that much (DON'T quote me on that ;-)). All of the patches that the Zarafa guys have made actually make it work better :-)

The links for their already patched files are on their Wiki with some build tips.

The source code filename currently does not have any specific build versions on there - Just 6.20 no 6.20.12345.

Depends:libical, libvmime, mysql, some MTA (postfix recommended), uuid-dev. php, apache or other web server for webmail, ldap for authentication (can use unix or internal/mysql).


Stephen Solberg
(Just for the record, I'm a certified Zarafa engineer so I'll help with as much as I can to get this up and running!)
_________________
Tua mater tam antiqua ut linguam latinam loquatur

Linux User: #405647
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Sun Sep 28, 2008 2:11 pm    Post subject: Reply with quote

I tried to compile manualy, I made custom ebuild for libvmime with zarafa patches and installed it together with libical from portage (I didn't found their patches for libical) but zarafa would not compile. The error I am getting is
Code:
make[3]: Entering directory `/temp/zarafa-6.20/provider/server'
/bin/sh ../../libtool --mode=link g++  -g -O2 -g -Wall -Wno-write-strings  -pedantic -Wno-long-long -pthread   -o zarafa-server -ldl -Wl,-E ECServer.o ECSoapServerConnection.o -luuid   ../../provider/libserver/libserver.la ../../provider/soap/libgsoap.la ../../provider/soap/libsoapserver.la ../../provider/common/libzarafacommon.la ../../common/libcommon_util.la ../../common/libcommon_mapi.la ../../common/libcommon_ssl.la -Wl,-O1 -Wl,--as-needed -rdynamic -L/usr/lib64/mysql -lmysqlclient -lz -lcrypt -lnsl -lm -L/usr/lib64 -lssl -lcrypto -lcrypto -lssl 
g++ -g -O2 -g -Wall -Wno-write-strings -pedantic -Wno-long-long -pthread -o zarafa-server -Wl,-E ECServer.o ECSoapServerConnection.o -Wl,-O1 -Wl,--as-needed -rdynamic  -ldl -luuid ../../provider/libserver/.libs/libserver.a ../../provider/soap/.libs/libgsoap.a ../../provider/soap/.libs/libsoapserver.a ../../provider/common/.libs/libzarafacommon.a ../../common/.libs/libcommon_util.a ../../common/.libs/libcommon_mapi.a ../../common/.libs/libcommon_ssl.a -L/usr/lib64/mysql /usr/lib64/mysql/libmysqlclient.so -lz -lcrypt -lnsl -lm -L/usr/lib64 -lcrypto -lssl -Wl,--rpath -Wl,/usr/lib64/mysql -Wl,--rpath -Wl,/usr/lib64/mysql
../../common/.libs/libcommon_util.a(platform.linux.o): In function `CoCreateGuid(_s_GUID*)':
/temp/zarafa-6.20/common/platform.linux.cpp:101: undefined reference to `uuid_generate'
collect2: ld returned 1 exit status
make[3]: *** [zarafa-server] Error 1
make[3]: Leaving directory `/temp/zarafa-6.20/provider/server'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/temp/zarafa-6.20/provider'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/temp/zarafa-6.20'
make: *** [all] Error 2


uuid.h is provided by e2fsprogs-libs, could that be the problem maybe? I will try to do some ebuild, if it turns out ugly it will be for me only :) until someone come up with something better, but I want first to compile it manualy...
Back to top
View user's profile Send private message
sven_sol
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 120
Location: Royston, Herts. UK

PostPosted: Sun Sep 28, 2008 4:58 pm    Post subject: Reply with quote

thats engineer.. not developer.. :roll:

did you have the e2fsprogs installed? that normally sorts that one out.

don't suppose you could post up your ebuild so far could you?
_________________
Tua mater tam antiqua ut linguam latinam loquatur

Linux User: #405647
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Sun Sep 28, 2008 5:33 pm    Post subject: Reply with quote

I didn't started with ebuild yet, I wanted first to compile manualy, to see first what should be installed and where, I only have libvmime from sunrise, I just made changes for zarafa patches and I changed version... It didn't seem to me that zarafa links for libvmime and libical are pre patched versions, with that SRC_URI compile will fail, but then I just added their patches to vanilla libvmime-0.7.1 and now is ok.

libvmime-0.7.1.ebuild
Code:

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils

ZARAFA_PATCHES="zarafa-vmime-patches.tar.gz"

DESCRIPTION="A powerful C++ class library for working with MIME messages and services like IMAP, POP or SMTP."
HOMEPAGE="http://www.vmime.org/"
SRC_URI="mirror://sourceforge/vmime/${P}.tar.bz2
      http://developer.zarafa.com/download/${ZARAFA_PATCHES}"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="debug doc examples sasl ssl"

RDEPEND="sasl? ( net-libs/libgsasl )
       ssl? ( net-libs/gnutls )
      virtual/libiconv"
DEPEND="${RDEPEND}
      doc? ( app-doc/doxygen )"

src_unpack() {
   unpack ${A}
   mv *.diff ${S}
   cd "${S}"
   for x in *.diff; do
      epatch ${x} || die "epatch ${x} failed";
   done
   sed -i \
      -e "s|doc/\${PACKAGE_TARNAME}|doc/${PF}|" \
      -e "s|doc/\$(GENERIC_LIBRARY_NAME)|doc/${PF}|" \
      configure Makefile.in || die "sed failed"
}

src_compile() {
   econf \
      $(use_enable debug) \
      $(use_enable sasl) \
      $(use_enable ssl tls) \
      --enable-platform-posix \
      --enable-messaging \
      --enable-messaging-proto-pop3 \
      --enable-messaging-proto-smtp \
      --enable-messaging-proto-imap \
      --enable-messaging-proto-maildir \
      --enable-messaging-proto-sendmail \
      || die "econf failed"
   emake || die "emake failed"
   if use doc ; then
      doxygen vmime.doxygen || die "doxygen failed"
   fi
}

src_install() {
   emake DESTDIR="${D}" install || die "emake install failed"
   if use doc ; then
      dohtml doc/html/*
   fi

   insinto /usr/share/doc/${PF}
   use examples && doins -r examples
}


I do have e2fsprogs and libs and also have uuid/uuid.h ...
Back to top
View user's profile Send private message
sven_sol
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 120
Location: Royston, Herts. UK

PostPosted: Mon Sep 29, 2008 9:13 am    Post subject: Reply with quote

Here are the patches for libical

http://developer.zarafa.com/download/zarafa-ical-patches.tar.gz


Not had chance to try your ebuild or crack on with the code, but give me a chance :wink:


EDIT: Some instructions for building the iCal stuff
Code:
unpack sources and apply patches
rm src/libical/icalderivedparameter.c src/libical/icalderivedproperty.c src/libical/icalderivedvalue.c
aclocal
autoheader
autoconf
libtoolize --copy --automake --force
automake --add-missing --copy --force
CFLAGS="-DNDEBUG -g -Wall -O2" ./configure --prefix=/usr --enable-python-bindings=no
make

_________________
Tua mater tam antiqua ut linguam latinam loquatur

Linux User: #405647
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Mon Sep 29, 2008 3:27 pm    Post subject: Reply with quote

Thx, I already found patches, but where did you read that instructions? I ask because there is some messy thing about libical, zarafa uses version from softwarestudio.org (down at the moment) and I dig something about this from google cache . In version 0.23a the author fixed some bugs in these files your instructions sad need to be removed (icalderivedparameter.c etc.), but he just re-uploaded libical-0.23... Now, in these files static should be changed to extern to be able to compile on amd64 , machine which I am using, one of zarafa patches patch extern back into static and I am trying to patch it again 8O .
I did compiled libical manualy but my ebuild will always fail to patch. I also noticed that python bindings should be disabled and the test program will fail to build. Can anyone tell me is this the right way to disable build test? (there is no configure option for this)
Code:
--- src/Makefile.in.orig        2001-04-03 02:20:55.000000000 +0200
+++ src/Makefile.in     2008-09-28 23:28:30.000000000 +0200
@@ -82,7 +82,7 @@
 @WITH_PYTHON_TRUE@PYTHON_DIR = python
 @WITH_PYTHON_FALSE@PYTHON_DIR =

-SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR) test
+SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR)
 mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
 CONFIG_HEADER = ../config.h
 CONFIG_CLEAN_FILES =


I will continue to play with this in my free time, if I put something together I will post back.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Tue Sep 30, 2008 9:43 pm    Post subject: Reply with quote

libical-0.23.ebuild
Code:

# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

inherit eutils autotools

ZARAFA_PATCHES="zarafa-ical-patches.tar.gz"

DESCRIPTION="a implementation of basic iCAL protocols"
HOMEPAGE="http://www.softwarestudio.org"
SRC_URI="http://download.zarafa.com/mirror/${P}.tar.gz
      http://developer.zarafa.com/download/${ZARAFA_PATCHES}"

LICENSE="|| ( MPL-1.1 LGPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="static"

src_unpack() {
   unpack ${A}
   mv *.diff ${S}
   cd "${S}"
   for x in *.diff; do
      epatch ${x} || die "epatch ${x} failed";
   done
   epatch ${FILESDIR}/disable-test.patch
}

src_compile() {
   for x in icalderivedparameter.c icalderivedvalue.c icalderivedproperty.c; do
      rm ${WORKDIR}/${P}/src/libical/${x};
   done
   eautoreconf
   econf \
      --disable-python-bindings \
      $(use_enable static) \
      || die "econf failed"
   emake || die "emake failed"
}

src_install() {
   emake DESTDIR="${D}" install || die "emake install failed."
   dodoc AUTHORS ChangeLog NEWS README TEST THANKS TODO doc/*.txt
}


disable-test.patch
Code:

--- configure.in.orig   2008-09-30 22:29:20.000000000 +0200
+++ configure.in   2008-09-30 23:03:08.000000000 +0200
@@ -98,7 +98,5 @@
 src/libicalss/Makefile
 src/libicalvcal/Makefile
 src/python/Makefile
-src/test/Makefile
-test-data/Makefile
 ])
 
--- Makefile.am.orig   2001-02-22 06:00:41.000000000 +0100
+++ Makefile.am   2008-09-30 23:10:04.000000000 +0200
@@ -5,5 +5,5 @@
    TEST \
    TODO
 
-SUBDIRS = design-data doc scripts test-data src examples
+SUBDIRS = design-data doc scripts src examples
 
--- Makefile.in.orig   2001-04-03 02:20:47.000000000 +0200
+++ Makefile.in   2008-09-30 23:17:05.000000000 +0200
@@ -83,7 +83,7 @@
 EXTRA_DIST =     ChangeLog    README    TEST    TODO
 
 
-SUBDIRS = design-data doc scripts test-data src examples
+SUBDIRS = design-data doc scripts src examples
 ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
 mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
 CONFIG_HEADER = config.h

--- src/Makefile.in.orig   2001-04-03 02:20:55.000000000 +0200
+++ src/Makefile.in   2008-09-30 23:18:50.000000000 +0200
@@ -82,7 +82,7 @@
 @WITH_PYTHON_TRUE@PYTHON_DIR = python
 @WITH_PYTHON_FALSE@PYTHON_DIR =
 
-SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR) test
+SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR)
 mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
 CONFIG_HEADER = ../config.h
 CONFIG_CLEAN_FILES =

--- src/Makefile.am.orig   2001-04-03 02:20:07.000000000 +0200
+++ src/Makefile.am   2008-09-30 23:28:55.000000000 +0200
@@ -4,4 +4,4 @@
 PYTHON_DIR =
 endif
 
-SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR) test
+SUBDIRS = libical libicalss libicalvcal $(PYTHON_DIR)


Ebuild for libical. I am still getting the same error about uuid_generate but configure says

checking for uuid_create... no
checking for uuid_create in -luuid... no
checking for uuid_generate in -luuid... yes
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Tue Sep 30, 2008 11:50 pm    Post subject: Reply with quote

Hopefully I will get a chance to try it at work tomorrow also. I'll contact Milo at Zarafa to see if he could help maybe also.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Wed Oct 01, 2008 8:50 am    Post subject: Reply with quote

Great, I compiled zarafa successfully on x86 machine at work, so there is something that must be done for amd64, or maybe wrong version of e2fsprogs-libs, I will check this later.
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Wed Oct 01, 2008 6:11 pm    Post subject: Reply with quote

You did it with or without an ebuild?
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Thu Oct 02, 2008 7:13 am    Post subject: Reply with quote

Without ebuild, I didn't have time but this weekend I will try to make one, I thought first to make init scripts, I saw examples for fedora and suse, I think it is not that complicated to modify them for gentoo.
Back to top
View user's profile Send private message
M
Guru
Guru


Joined: 12 Dec 2006
Posts: 427

PostPosted: Sat Oct 04, 2008 9:25 am    Post subject: Reply with quote

I made some ebuilds, it compiles on x86 but it still fails on amd64, I guess it is a simple fix but I can't solve it. I posted ebuilds on bugzilla http://bugs.gentoo.org/show_bug.cgi?id=239514 . I didn't found their webaccess and webaccess-mobile tarballs for download, they are included in packages for fedora, suse etc. Maybe we can fetch them in ebuild, rpm2targz-em and then install them via webapp-config but for now I just do this manually...
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Thu Oct 30, 2008 5:53 pm    Post subject: Reply with quote

So you made the ebuilds and they work for me on amd64 as well. I was going to write a Gentoo Wiki article on it. Would there be a better way to get it popular enough to catch a maintainer's attention?
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
sven_sol
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 120
Location: Royston, Herts. UK

PostPosted: Mon Nov 03, 2008 9:38 am    Post subject: Reply with quote

For those that are experiencing problems with the WebAccess and HTML tags not working correctly, I think this may help...

http://bugs.php.net/bug.php?id=45996
http://thread.gmane.org/gmane.comp.gnome.lib.xml.general/14610
http://blog.code-head.com/fixing-libxml-php-bug-and-issues-with-html-entities-downgrading-libxml
http://bugs.typo3.org/view.php?id=9359

LibXML2 has a bug in 2.7.0 and 2.7.1, I think its fixed in 2.7.2 - I'm about to go and test it now.

Hope that helps ;-)


Sven
_________________
Tua mater tam antiqua ut linguam latinam loquatur

Linux User: #405647
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Fri Nov 07, 2008 5:08 am    Post subject: Reply with quote

http://en.gentoo-wiki.com/wiki/Zarafa

Wrote an article that has been tagged for wikification.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
maiku
Guru
Guru


Joined: 24 Mar 2004
Posts: 500
Location: Long Island, NY

PostPosted: Mon Nov 17, 2008 3:07 pm    Post subject: Reply with quote

sven_sol wrote:
For those that are experiencing problems with the WebAccess and HTML tags not working correctly, I think this may help...

http://bugs.php.net/bug.php?id=45996
http://thread.gmane.org/gmane.comp.gnome.lib.xml.general/14610
http://blog.code-head.com/fixing-libxml-php-bug-and-issues-with-html-entities-downgrading-libxml
http://bugs.typo3.org/view.php?id=9359

LibXML2 has a bug in 2.7.0 and 2.7.1, I think its fixed in 2.7.2 - I'm about to go and test it now.

Hope that helps ;-)


Sven
I have dev-libs/libxml2-2.7.2 installed and it still has that issue. I don't think that's it.
_________________
- Mike A. Leonetti
Back to top
View user's profile Send private message
PietdeBoer
Apprentice
Apprentice


Joined: 20 Oct 2005
Posts: 244
Location: Eindhoven, the Netherlands

PostPosted: Thu Dec 11, 2008 1:28 pm    Post subject: Reply with quote

wow its working almost perfectly :)


the only thing i dislike about zarafa is that it can not handle auth smtp servers....

do you guys have a good suggestion how i can make zarafa somehow send mail through a smtp server with authentication?

Im using postfix/mysql and db plugin
_________________
_ Got Root? _
Back to top
View user's profile Send private message
sven_sol
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2005
Posts: 120
Location: Royston, Herts. UK

PostPosted: Wed Dec 24, 2008 9:01 pm    Post subject: Reply with quote

maiku wrote:
sven_sol wrote:
For those that are experiencing problems with the WebAccess and HTML tags not working correctly, I think this may help...

http://bugs.php.net/bug.php?id=45996
http://thread.gmane.org/gmane.comp.gnome.lib.xml.general/14610
http://blog.code-head.com/fixing-libxml-php-bug-and-issues-with-html-entities-downgrading-libxml
http://bugs.typo3.org/view.php?id=9359

LibXML2 has a bug in 2.7.0 and 2.7.1, I think its fixed in 2.7.2 - I'm about to go and test it now.

Hope that helps ;-)


Sven
I have dev-libs/libxml2-2.7.2 installed and it still has that issue. I don't think that's it.


Just to let you know, it is to do with that library. Downgrade to the 2.6 lib and life will be a lot better!

On the SMTP/auth front, have a local SMTP service relay it on for you. Much easier.

Sven
_________________
Tua mater tam antiqua ut linguam latinam loquatur

Linux User: #405647
Back to top
View user's profile Send private message
PietdeBoer
Apprentice
Apprentice


Joined: 20 Oct 2005
Posts: 244
Location: Eindhoven, the Netherlands

PostPosted: Tue Dec 30, 2008 6:09 am    Post subject: Reply with quote

Sven,

iam trying to get postfix to relay the mail for me, the problem is postfix tries to look up every mail that i send in the mysql database and ofcourse can't find all my recipients there.. so it wont relay anything else then my "known" domains.


main.cf

Code:
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

append_dot_mydomain = no

smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

mydomain = xxx.biz
myhostname = bertje
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/relay_password
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
virtual_alias_maps = mysql:/etc/postfix/mysql-aliases.cf
myorigin = xxx.biz
mydestination = $myhostname, $myhostname.local, localhost, $mydomain
mynetworks = 127.0.0.0/8
inet_interfaces = all

mailbox_command = /usr/bin/zarafa-dagent -R ${recipient}
mailbox_transport = zarafa:
zarafa_destination_recipient_limit = 1

_________________
_ Got Root? _
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum