Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200809-03 ] RealPlayer: Buffer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Thu Sep 04, 2008 10:26 pm    Post subject: [ GLSA 200809-03 ] RealPlayer: Buffer overflow Reply with quote

Gentoo Linux Security Advisory

Title: RealPlayer: Buffer overflow (GLSA 200809-03)
Severity: normal
Exploitable: remote
Date: September 04, 2008
Bug(s): #232997
ID: 200809-03

Synopsis

RealPlayer is vulnerable to a buffer overflow allowing for the execution of arbitrary code.

Background

RealPlayer is a multimedia player capable of handling multiple multimedia file formats.

Affected Packages

Package: media-video/realplayer
Vulnerable: < 11.0.0.4028-r1
Unaffected: >= 11.0.0.4028-r1
Architectures: All supported architectures


Description

Dyon Balding of Secunia Research reported an unspecified heap-based buffer overflow in the Shockwave Flash (SWF) frame handling.

Impact

By enticing a user to open a specially crafted SWF (Shockwave Flash) file, a remote attacker could be able to execute arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All RealPlayer users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-video/realplayer-11.0.0.4028-r1"


References

CVE-2007-5400
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum