Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New nvidia drivers 337.12 and overclocking in cli?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Aonoa
Guru
Guru


Joined: 23 May 2002
Posts: 576
Location: Oslo, Norway

PostPosted: Wed Apr 09, 2014 1:04 am    Post subject: New nvidia drivers 337.12 and overclocking in cli? Reply with quote

Hello,

Seeing as the new 337 drivers finally brought overclocking in the GUI nvidia-settings tool; I was wondering if anyone has managed to use nvidia-settings in CLI to overlock your newer nvidia cards?

Thank you.
_________________
Dive into Gentoo Linux and emerge into a new world
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 366

PostPosted: Thu Apr 17, 2014 6:17 pm    Post subject: Reply with quote

Tried to figure out the same. A diff of nvidia-settings -q all seems to show some differences between stock and overclocked, but nothing of use, apparently. Or I haven't tried hard enough.


Btw, the new version even allows overclocking of Quadro cards. Finally!
Back to top
View user's profile Send private message
Aonoa
Guru
Guru


Joined: 23 May 2002
Posts: 576
Location: Oslo, Norway

PostPosted: Mon May 05, 2014 10:02 pm    Post subject: Reply with quote

The latest nvidia-drivers 337.19 and nvidia-settings utility enabled CLI control it seems.

Something like this:
Code:
nvidia-settings -a [gpu:0]/GPUGraphicsClockOffset[3]=50
nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[3]=200

The number in brackets is the performance level for you set the offset, in this case, performance level 3.

It is explained in the man pages for nvidia-settings.
_________________
Dive into Gentoo Linux and emerge into a new world
Back to top
View user's profile Send private message
haarp
Guru
Guru


Joined: 31 Oct 2007
Posts: 366

PostPosted: Tue May 06, 2014 3:36 pm    Post subject: Reply with quote

Works for me:

Code:
$ optirun nvidia-settings -c :8 -a [gpu:0]/GPUGraphicsClockOffset[2]=90 -a [gpu:0]/GPUMemoryTransferRateOffset[2]=420

  Attribute 'GPUGraphicsClockOffset' (marauder:8[gpu:0]) assigned value 90.

  Attribute 'GPUMemoryTransferRateOffset' (marauder:8[gpu:0]) assigned value 420.


I'm using nvidia-drivers-337.12 with nvidia-settings 337.19. Make sure you're using the correct state (2 in my case), the others are read-only.
Back to top
View user's profile Send private message
Aonoa
Guru
Guru


Joined: 23 May 2002
Posts: 576
Location: Oslo, Norway

PostPosted: Tue May 06, 2014 3:40 pm    Post subject: Reply with quote

Yeah, I was trying to set it for all the performance levels at first. It works only with performance level 3 for me, perhaps since that is the active one.
_________________
Dive into Gentoo Linux and emerge into a new world
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum