Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Slow internet connection in linux
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
astbis
n00b
n00b


Joined: 20 Jan 2004
Posts: 14
Location: Kolding, Denmark

PostPosted: Thu Jul 31, 2008 1:38 pm    Post subject: Slow internet connection in linux Reply with quote

Hi Forum

I'm puzzled. In a school environment i have a bunch of computers to manage and since we moved location and internetconnection. All linux machines are running at about 200kbit/s downstream and 6Mbit upstream where it should be 6/6Mbit/s. Every machine that runs windows can utilize the entire 6/6Mbit connection.
On my laptop i am running Gentoo Linux 2.6.22 and have only problems at school, but not on every other internet access. To circumvent the problem i've installed a proxy server on a Windows machine. After that i could get normal speeds in Firefox also on "speedtest.net". But this can't be a permanent solutions since it affects our new LTSP server which runs openSuse 11.0 with kiwi-ltsp.

How is that possible?

I've read a lot of posts about IPv6 and slow connections but can't find heads or tales in it. Our openSuse box has IPv6 disabled also in the Gentoo box kernel. Routing table looks normal.

Please help. It would be a bad sign if i had to explain to my boss that linux had a problem instead of MS.

If you need any log files or information please let me know.
Back to top
View user's profile Send private message
CrankyPenguin
Apprentice
Apprentice


Joined: 19 Jun 2003
Posts: 238

PostPosted: Fri Aug 01, 2008 9:09 pm    Post subject: Laptop is suggestive. Reply with quote

The fact that your laptop behaves differently elsewhere (presumably with no major config changes) suggests to me that it is not the machines at fault. I am not aware of any dynamic "scaling down" in linux that should make a difference. This suggests to me that you look to the network layout. How are the machines connected? Are they all going through the same router? And is the router assigning ips or is it the other way around? One potential is that the assignment of machines is somehow favoring the windows boxes, perhaps by giving each one a separate ip while causing the linux boxes to share thus creating network conflicts.

In any case I would start by looking at the network setup, the upstream box and the assignment of ips and names to the machines as your laptop's behavior is inconsistent with a system specific problem.

If, perhaps, the upstream machine (i.e. the gateway) is running a windows protocol then that might explain it too.
_________________
Linux, the OS for the obsessive-compulsive speed freak in all of us.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum