Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
swfdec 6.8 with ffmpeg WITHOUT gstreamer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Thu Jul 31, 2008 10:13 pm    Post subject: swfdec 6.8 with ffmpeg WITHOUT gstreamer Reply with quote

swfdec 0.6.8 was very recently released and added to portage, and surprisingly direct ffmpeg has not actually been removed (however it has been removed from 0.7.2 and up...).

I modified the 0.6.8 ebuild to use ffmpeg directly, and also included a teensy little patch which enables it to compile against ffmpeg 0.4.9_p20080326.

With it I can play videos on youtube just fine, with both audio and video, and with no gstreamer on my system.

Anyways, here's the ebuild if anyone else is interested in this;
http://hamiltonshells.ca/~hopeless/ebuilds/media-libs/swfdec
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
denstark
l33t
l33t


Joined: 02 Jun 2003
Posts: 654
Location: sd.ca.us

PostPosted: Fri Aug 01, 2008 12:06 am    Post subject: Reply with quote

I care <3
_________________
Blog
Code:
denstark> starbuck authorizes torture?
rokstar> sure they do, you tried their coffee?
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Tue Aug 05, 2008 9:33 am    Post subject: Reply with quote

Wow, first time I can view flash content on ppc decently :D

Normal sites work fine, but youtube & friends still do not work. I think it's a problem with the two players embedded one in another. Not sure what to do.

Cheers,
cjubon
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Tue Aug 05, 2008 4:50 pm    Post subject: Reply with quote

cjubon wrote:
Wow, first time I can view flash content on ppc decently :D

Normal sites work fine, but youtube & friends still do not work. I think it's a problem with the two players embedded one in another. Not sure what to do.

Cheers,
cjubon
Thar's odd, youtube works perfectly for me with this.

Could you post the output of the following?;
Code:
emerge -pv ffmpeg swfdec swfdec-mozilla mozilla-firefox

_________________
"You have to invite me in"
Back to top
View user's profile Send private message
cjubon
Guru
Guru


Joined: 03 Jul 2007
Posts: 440
Location: Vienna/Europe

PostPosted: Tue Aug 05, 2008 7:36 pm    Post subject: Reply with quote

Sure. Here we go:
Code:
cjubon@g4:~$ emerge -pv ffmpeg swfdec swfdec-mozilla xulrunner mozilla-firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/ffmpeg-0.4.9_p20080326  USE="X a52 aac altivec encode ieee1394 mp3 sdl threads truetype vorbis x264 zlib -amr -bindist -debug -doc -hardcoded-tables -imlib -ipv6 (-mmx) -network -test -theora -xvid" 0 kB
[ebuild   R   ] net-libs/xulrunner-1.9.0.1  USE="dbus startup-notification -custom-optimization -gnome -ipv6 -java" 0 kB
[ebuild   R   ] media-libs/swfdec-0.6.8  USE="alsa ffmpeg gtk -doc -oss -pulseaudio" 0 kB [1]
[ebuild   R   ] www-client/mozilla-firefox-3.0.1  USE="dbus startup-notification xulrunner -bindist -custom-optimization -gnome -iceweasel -ipv6 -java -mozdevelop -restrict-javascript" LINGUAS="de -af -ar -be -ca -cs -da -el -en -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -id -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-www/swfdec-mozilla-0.6.0  USE="xulrunner" 0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Machine is an Apple G4 PB. Thanks for you help.

BTW, should I disable "treads" on non-smp machines?
_________________
Mandrake Dec 2001 · Debian "Woody" Aug 2002 · Gentoo Jan 2004 · Funtoo Oct 2009
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4916

PostPosted: Thu Aug 07, 2008 1:55 pm    Post subject: Reply with quote

cool thanks, but now I hear no sound :-/
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Thu Aug 07, 2008 2:55 pm    Post subject: Reply with quote

cjubon wrote:
Sure. Here we go:
Code:
cjubon@g4:~$ emerge -pv ffmpeg swfdec swfdec-mozilla xulrunner mozilla-firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/ffmpeg-0.4.9_p20080326  USE="X a52 aac altivec encode ieee1394 mp3 sdl threads truetype vorbis x264 zlib -amr -bindist -debug -doc -hardcoded-tables -imlib -ipv6 (-mmx) -network -test -theora -xvid" 0 kB
[ebuild   R   ] net-libs/xulrunner-1.9.0.1  USE="dbus startup-notification -custom-optimization -gnome -ipv6 -java" 0 kB
[ebuild   R   ] media-libs/swfdec-0.6.8  USE="alsa ffmpeg gtk -doc -oss -pulseaudio" 0 kB [1]
[ebuild   R   ] www-client/mozilla-firefox-3.0.1  USE="dbus startup-notification xulrunner -bindist -custom-optimization -gnome -iceweasel -ipv6 -java -mozdevelop -restrict-javascript" LINGUAS="de -af -ar -be -ca -cs -da -el -en -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -id -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-www/swfdec-mozilla-0.6.0  USE="xulrunner" 0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Machine is an Apple G4 PB. Thanks for you help.
Everything there is pretty much the same as mine, so I really don't know what's wrong...

Quote:
BTW, should I disable "treads" on non-smp machines?
AFAIK you should leave it enabled, and anyways they were the desktop defaults long before multi-core cpus became available.

DaggyStyle wrote:
cool thanks, but now I hear no sound :-/
Damnit, am I the only person this actually "just works" for?

Was audio working for you with swfdec in any setup in the past?
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4916

PostPosted: Thu Aug 07, 2008 4:56 pm    Post subject: Reply with quote

Hopeless wrote:
cjubon wrote:
Sure. Here we go:
Code:
cjubon@g4:~$ emerge -pv ffmpeg swfdec swfdec-mozilla xulrunner mozilla-firefox

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-video/ffmpeg-0.4.9_p20080326  USE="X a52 aac altivec encode ieee1394 mp3 sdl threads truetype vorbis x264 zlib -amr -bindist -debug -doc -hardcoded-tables -imlib -ipv6 (-mmx) -network -test -theora -xvid" 0 kB
[ebuild   R   ] net-libs/xulrunner-1.9.0.1  USE="dbus startup-notification -custom-optimization -gnome -ipv6 -java" 0 kB
[ebuild   R   ] media-libs/swfdec-0.6.8  USE="alsa ffmpeg gtk -doc -oss -pulseaudio" 0 kB [1]
[ebuild   R   ] www-client/mozilla-firefox-3.0.1  USE="dbus startup-notification xulrunner -bindist -custom-optimization -gnome -iceweasel -ipv6 -java -mozdevelop -restrict-javascript" LINGUAS="de -af -ar -be -ca -cs -da -el -en -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -id -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 0 kB
[ebuild   R   ] net-www/swfdec-mozilla-0.6.0  USE="xulrunner" 0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Machine is an Apple G4 PB. Thanks for you help.
Everything there is pretty much the same as mine, so I really don't know what's wrong...

Quote:
BTW, should I disable "treads" on non-smp machines?
AFAIK you should leave it enabled, and anyways they were the desktop defaults long before multi-core cpus became available.

DaggyStyle wrote:
cool thanks, but now I hear no sound :-/
Damnit, am I the only person this actually "just works" for?

Was audio working for you with swfdec in any setup in the past?


yes, btw, what version of alsa do you have, I think it started since I've upgraded my alsa to version 1.0.17, moreover, sound doesn't work either with the gstreamer included version.
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4916

PostPosted: Thu Aug 07, 2008 7:41 pm    Post subject: Reply with quote

WORKS LIKE A CHARM have no idea why and how it got fixed... probably gremlins
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
Sadako
Advocate
Advocate


Joined: 05 Aug 2004
Posts: 3753
Location: sleeping in the bathtub

PostPosted: Thu Aug 07, 2008 8:15 pm    Post subject: Reply with quote

DaggyStyle wrote:
WORKS LIKE A CHARM have no idea why and how it got fixed... probably gremlins
Heh, I was just gonna say I'm still using alsa 1.16 for everything (headers, lib, etc), but nevermind.

Glad it works for someone other than myself.

cjubon;
Could you start firefox from an xterm (or whetever, just to see stdout & stderr), and see what's reported when you try to play a youtube clip?
_________________
"You have to invite me in"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum