Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200806-11 ] IBM JDK/JRE: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1577

PostPosted: Wed Jun 25, 2008 11:26 am    Post subject: [ GLSA 200806-11 ] IBM JDK/JRE: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: IBM JDK/JRE: Multiple vulnerabilities (GLSA 200806-11)
Severity: normal
Exploitable: remote
Date: June 25, 2008
Bug(s): #186277, #198644, #216112
ID: 200806-11

Synopsis


Multiple vulnerabilities have been found in IBM Java Development Kit (JDK)
and Java Runtime Environment (JRE), resulting in the execution of arbitrary
code.


Background


The IBM Java Development Kit (JDK) and the IBM Java Runtime Environment
(JRE) provide the IBM Java platform.


Affected Packages

Package: dev-java/ibm-jdk-bin
Vulnerable: < 1.5.0.7
Unaffected: >= 1.5.0.7
Unaffected: >= 1.4.2.11 < 1.4.2.12
Architectures: All supported architectures

Package: dev-java/ibm-jre-bin
Vulnerable: < 1.5.0.7
Unaffected: >= 1.5.0.7
Unaffected: >= 1.4.2.11 < 1.4.2.12
Architectures: All supported architectures


Description


Because of sharing the same codebase, IBM JDK and JRE are affected by
the vulnerabilities mentioned in GLSA 200804-20.


Impact


A remote attacker could entice a user to run a specially crafted applet
on a website or start an application in Java Web Start to execute
arbitrary code outside of the Java sandbox and of the Java security
restrictions with the privileges of the user running Java. The attacker
could also obtain sensitive information, create, modify, rename and
read local files, execute local applications, establish connections in
the local network, bypass the same origin policy, and cause a Denial of
Service via multiple vectors.


Workaround


There is no known workaround at this time.


Resolution


All IBM JDK 1.5 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/ibm-jdk-bin-1.5.0.7"

All IBM JDK 1.4 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/ibm-jdk-bin-1.4.2.11"

All IBM JRE 1.5 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/ibm-jre-bin-1.5.0.7"

All IBM JRE 1.4 users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-java/ibm-jre-bin-1.4.2.11"


References

GLSA 200804-20


Last edited by GLSA on Mon Jun 10, 2013 4:28 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum