Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 369
Location: Graben-Neudorf, Germany

PostPosted: Wed May 28, 2008 12:08 pm    Post subject: KDE 4.1 portage Reply with quote

I'm trying to get the portage version of the KDE 4.1 ebuilds running.

Here I store my experiences, and how to replicate them.

Please feel incited to write your own experiences.

Sources:
For adding the overlay via layman, you can just use the command

Code:
layman -a kdesvn-portage


(thanks to hays!)

A website (from #gentoo-kde4-live on freenode): http://kde.gentooexperimental.org/

[edit]This thread has now been locked and split. Read kde-testing and kdesvn-portage overlays thread (part 2) for the follow-up - Jorge (jmbsvicetto).[/edit]
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.


Last edited by ArneBab on Thu Jul 24, 2008 8:31 am; edited 4 times in total
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed May 28, 2008 12:56 pm    Post subject: Reply with quote

Moved from Desktop Environments to Unsupported Software.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 369
Location: Graben-Neudorf, Germany

PostPosted: Wed May 28, 2008 2:12 pm    Post subject: Reply with quote

Thanks!
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
ch4os
Tux's lil' helper
Tux's lil' helper


Joined: 11 Jul 2006
Posts: 90
Location: Gdansk, Poland

PostPosted: Wed May 28, 2008 3:24 pm    Post subject: Reply with quote

4.0.71 isn't 4.1 alpha1?
Back to top
View user's profile Send private message
ufoman
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2006
Posts: 80

PostPosted: Wed May 28, 2008 3:51 pm    Post subject: Reply with quote

AFAIK beta1 is 4.0.80...
_________________
Registered Linux User #417638
amd64 no-multilib
desktop: Gigabyte GA-MA770-UD3 v2.0, Athlon II X2 250 @3,6GHz, 4GB DDR2 800, Radeon HD 4850, Seagate Barracuda 7200.11 320GB
Back to top
View user's profile Send private message
Delian
n00b
n00b


Joined: 24 Jul 2006
Posts: 12

PostPosted: Wed May 28, 2008 4:04 pm    Post subject: Reply with quote

Yes!.. it's what I've said in another thread :D
the beta1 is 4.0.80..

I hope the new ebuilds will came up soon :/
Back to top
View user's profile Send private message
Eckos
Apprentice
Apprentice


Joined: 25 Jan 2008
Posts: 197
Location: Houston, Texas, USA

PostPosted: Thu May 29, 2008 3:20 am    Post subject: Reply with quote

I hope they fix the ugly menu because theres like no borders at all and its unattractive. And Fix the bug about how the clock and the notification area just flickers and sometimes just go black and disappear.
_________________
AMD Athlon 64 X2 3800+ | 2GB DDR2 533MHz RAM | GCC-4.3.2 | Gentoo x86_64 | KDE 4.1.2
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Thu May 29, 2008 4:36 pm    Post subject: Reply with quote

Eckos wrote:
I hope they fix the ugly menu because theres like no borders at all and its unattractive. And Fix the bug about how the clock and the notification area just flickers and sometimes just go black and disappear.


Which revision did you tried? 4.0.80? Which graphic card? Did you already filled a bugreport about that?
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
cruzki123
Apprentice
Apprentice


Joined: 16 May 2008
Posts: 233

PostPosted: Thu May 29, 2008 7:12 pm    Post subject: Reply with quote

I have a problem with plasma and fonts. In the taskbar seems to be black (ie I don't see fonts, only icons) and in the menu to select plasmoids the fonts of the description are white :S
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Thu May 29, 2008 8:48 pm    Post subject: Reply with quote

Could someone please mention the url for this overlay (and possibly edit the first post)? Using Pastebin and the like is not really a good idea for things that should be available more than just a few hours. I get a 404 already when trying to access the file :(
Back to top
View user's profile Send private message
Eckos
Apprentice
Apprentice


Joined: 25 Jan 2008
Posts: 197
Location: Houston, Texas, USA

PostPosted: Fri May 30, 2008 12:09 am    Post subject: Reply with quote

Matteo Azzali wrote:
Eckos wrote:
I hope they fix the ugly menu because theres like no borders at all and its unattractive. And Fix the bug about how the clock and the notification area just flickers and sometimes just go black and disappear.


Which revision did you tried? 4.0.80? Which graphic card? Did you already filled a bugreport about that?


It was from 4.0.3 and up. And no I haven't tried 4.0.8 yet because no link anywhere and not in the tree. nVidia GeForce 6150 LE. Its off a HP a1700n motherboard in my pc. And no I haven't because I figured someone already has. Maybe when I can get ahold of KDE-4.0.8 I will see if it fixes.


Anyone know if 4.0.8 accepts Qt-4.4.0 so I can go back to it?
_________________
AMD Athlon 64 X2 3800+ | 2GB DDR2 533MHz RAM | GCC-4.3.2 | Gentoo x86_64 | KDE 4.1.2
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 369
Location: Graben-Neudorf, Germany

PostPosted: Fri May 30, 2008 12:43 am    Post subject: Reply with quote

I uploaded the list myself and updated the URL.

Please tell me if it works for you.

Code:
layman -o http://draketo.de/files/kde4-live.xml -a kde4-live

_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Fri May 30, 2008 9:21 am    Post subject: Reply with quote

ArneBab wrote:
I uploaded the list myself and updated the URL.

Please tell me if it works for you.

Code:
layman -o http://draketo.de/files/kde4-live.xml -a kde4-live


Thanks, that works.

I found out this overlay already exists in the official overlay list though. It is listed* as "kdesvn-portage" but seems otherwise identical (same contact, same url). So running

Code:
layman -a kdesvn-portage
should yield the same result.


* Since kdesvn-portage is an unofficial overlay, it will not be listed by "layman -L" . But one can list all overlays (including unofficial ones) by using "layman -k -L"
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Fri May 30, 2008 8:06 pm    Post subject: Reply with quote

I am trying the live ebuilds (*9999) since alpha1 is a bit old by now. Following problems so far:
- kdelibs-9999 fails with a sandbox violation. With FEATURES="-sandbox" it installs fine though.
- libkonq-9999 fails due to a failing patch attempt (fix_includes_install.patch fails with apps/lib/konq/CMakeLists.txt), disabling the patch seems to be ok, the "forgotten" includes are gone anyway
- solid-hardware-9999 fails with a rsync error due to $DISTDIR/svn-src/KDE/kdebase/kdebase/runtime/solid-hardware/ missing. The directory exists at websvn.kde.org, but apparently was not checked out by portage.
- kde-menu-icons-9999 fails with the same problem as solid-hardware-9999 ($DISTDIR/svn-src/KDE/kdebase/kdebase/runtime/menu/ missing), this unfortunately is a dependency for plasma
- kiconfinder-9999, too (missing $DISTDIR/svn-src/KDE/kdebase/kdebase/runtime/kiconfinder/)
- kode-9999 fails due to a wrong path for svn (portage tries to fetch from svn://anonsvn.kde.org/home/kde/branches/KDE/4.0/kdepim - but it should not fetch from the 4.0 branch anyway for the live ebuilds, especially not for kdepim, as there is no kdepim for kde 4.0), thus nothing from kdepim emerges as everything depends on kode.
- a few more packages (dragonplayer, some games, surely some more) fail due to not fetched files

I will try to emerge some more stuff and get the missing stuff working as well and report back.
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 369
Location: Graben-Neudorf, Germany

PostPosted: Fri May 30, 2008 10:33 pm    Post subject: Reply with quote

Good to know!

I'll change the first post (again) to include the official one.

Status: At the moment my computer is compiling the SVN ebuilds, and though I had a few build errors, many did work.

I hope the beta ebuilds get avaible, soon.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Sat May 31, 2008 12:05 pm    Post subject: Reply with quote

smorg wrote:

I will try to emerge some more stuff and get the missing stuff working as well and report back.


I think I cannot emerge anything more now. The biggest problems are the failures of kde-base/kde-menu-icons-9999, which is needed for plasma (which in turn is needed for quite a few other packages) and kde-base/kode-9999 which is needed for everything within the pim module.

I have tried to manually download the files for kde-menu-icons-9999 as they are not fetched by svn, but then emerge fails at installing the package:

Code:

>>> Install kde-menu-icons-9999 into /var/tmp/portage/kde-base/kde-menu-icons-9999/image/ category kde-base
make: *** Keine Regel, um »install« zu erstellen.  Schluss.
 *
 * ERROR: kde-base/kde-menu-icons-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 3095:  Called kde4-base_src_install
 *             environment, line 2125:  Called cmake-utils_src_install
 *             environment, line  761:  Called die
 * The specific snippet of code:
 *       emake install DESTDIR="${D}" || die "Make install failed";
 *  The die message:
 *   Make install failed


Since plasma is missing, I could not use the desktop yet :-(
Back to top
View user's profile Send private message
dig_lam
n00b
n00b


Joined: 03 Aug 2005
Posts: 4

PostPosted: Sat May 31, 2008 8:20 pm    Post subject: kdepimlibs fails Reply with quote

Hi!
everything went good until to kdepimlibs :(

cmake fails because of target "akonadi-kde".
any idea ??

EDIT: I think, svn updated. OK now :)
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Sun Jun 01, 2008 9:17 pm    Post subject: Reply with quote

Hi everyone,

I found the source of my problems: a stale eclass in a personal overlay which I used to build kde from the 4.0 branch. That one overwrote an eclass from this overlay and pulled everything from branch/4.0/. So I am trying to compile from trunk this time and will report back if I hit any problems.
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Mon Jun 02, 2008 11:05 am    Post subject: Reply with quote

This time everything emerged without problems and I am currently using a trunk version. So far it seems more polished and more stable than KDE 4.0.4 :-)
Back to top
View user's profile Send private message
DZhon
n00b
n00b


Joined: 15 Oct 2007
Posts: 11
Location: Russia, Azov

PostPosted: Mon Jun 02, 2008 3:29 pm    Post subject: Reply with quote

4.0.80 aka beta1 ebuilds are released :evil:

(SLOT kde-4.1)

may be they more stable than 4.0.4 ))
Back to top
View user's profile Send private message
Cyberwizzard
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 244
Location: Netherlands

PostPosted: Mon Jun 02, 2008 8:52 pm    Post subject: Reply with quote

I hate to ask this but erm.... Is it safe for 4.0 users to upgrade to the 4.1 beta line? I mean, I know that lots of stuff is unfinished and some things will blow up your house but in general, can it be used or is it a no-go still?
Back to top
View user's profile Send private message
pgraham
n00b
n00b


Joined: 01 Mar 2007
Posts: 23

PostPosted: Tue Jun 03, 2008 2:21 am    Post subject: Reply with quote

DZhon wrote:
4.0.80 aka beta1 ebuilds are released :evil:

(SLOT kde-4.1)

may be they more stable than 4.0.4 ))


Are they a part of the normal tree or the overlay? If part of the tree what do we need to unmask?
_________________
Philip Graham
Back to top
View user's profile Send private message
smorg
n00b
n00b


Joined: 03 Apr 2006
Posts: 40
Location: Germany

PostPosted: Tue Jun 03, 2008 1:01 pm    Post subject: Reply with quote

pgraham wrote:
DZhon wrote:
4.0.80 aka beta1 ebuilds are released :evil:

(SLOT kde-4.1)

may be they more stable than 4.0.4 ))


Are they a part of the normal tree or the overlay? If part of the tree what do we need to unmask?


The ebuilds are in the overlay. I doubt that any part of kde alpha, beta or rc will show up in the normal tree.
Back to top
View user's profile Send private message
mrsaccess
n00b
n00b


Joined: 03 Sep 2005
Posts: 27
Location: Greece

PostPosted: Tue Jun 03, 2008 5:29 pm    Post subject: Reply with quote

I installed yesterday the kde-meta svn version from the kdesvn-portage overlay. Everything went fine except Kalzium which isn't that serious. I even emerged digikam, k3b, amarok and ktorrent svn! It may be my idea but I think than svn compiled faster than 4.0.

I was wondering though, is there an easy command to update all the kdesvn packages when I want to?
_________________
Hardware: The parts of your pc you can kick.
Back to top
View user's profile Send private message
zephir
n00b
n00b


Joined: 03 Jun 2008
Posts: 27
Location: near Barcelona (Spain)

PostPosted: Tue Jun 03, 2008 6:55 pm    Post subject: Reply with quote

Hi!
I'm installing the 4.0.80 svn version, and I found a problem when trying to install kde-base/step-4.0.80
I get this error:
Code:
[ 90%] Building CXX object step/step/CMakeFiles/step.dir/unitscalc.o
In file included from /usr/include/cln/cln.h:27,
                 from /usr/include/libqalculate/Number.h:17,
                 from /usr/include/libqalculate/MathStructure.h:16,
                 from /usr/include/libqalculate/Calculator.h:149,
                 from /usr/include/libqalculate/qalculate.h:17,
                 from /var/tmp/portage/kde-base/step-4.0.80/work/step-4.0.80/step/step/unitscalc.cc:23:
/usr/include/cln/string.h: In static member function 'static void* cln::cl_heap_string::operator new(size_t)':
/usr/include/cln/string.h:21: error: manejo de excepciones desactivado, use -fexceptions para activar
make[2]: *** [step/step/CMakeFiles/step.dir/unitscalc.o] Error 1
make[2]: *** Se espera a que terminen otras tareas....
make[1]: *** [step/step/CMakeFiles/step.dir/all] Error 2
make: *** [all] Error 2

The problem was with the flag "qalculate", when I compiled again without it, there's no problems. But I don't know if it is a general bug or a problem in my computer. If anyone knows why it can be, please tell it here ^^

P.S. Sorry for the lines in spanish >_<
P.P.S. Very good work for the overlay!
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 28, 29, 30  Next
Page 1 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum