Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Quakeforge on iBookG4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
AliasXZ
l33t
l33t


Joined: 08 Feb 2005
Posts: 836
Location: England, Huddersfield

PostPosted: Mon May 26, 2008 1:49 pm    Post subject: Quakeforge on iBookG4 Reply with quote

I have done extensive searching on this but haven't found a solution

I am using an iBookG4 14" - snd-aoa in-kernel sound driver

The problem is I cannot get audio in quakeforge, I have tried the 3 different sound opts, alsa, oss and sdl, non of which work.

Alsa complains about mmap:

Code:
Sound Initialization
Could not mmap /dev/dsp: Invalid argument


When i use sdl, it looks for the oss module?

When I use oss, it fails with the same message as sdl, failing to load the oss module.
How would I solve this?

Also, could someone tell me which quake1 engines are available for ppc?

cheers for help :)
_________________
Main:
Kernel: 3.12.13 amd64
RAM: 4GB
Lappy:
iBookG4 7447A @ 1.42G
------------------------------
Please add (solved) to your first post when your issue is resolved 8)
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3734

PostPosted: Mon May 26, 2008 2:04 pm    Post subject: Reply with quote

i have no clue about games, but apparently this one only works with oss interface ( there are many out there that only work with oss iirc), so maybe the only thing you have to do is enable alsa´s oss emulation in the kernel and in your system to get it running.

I suppose this also will requiere you to enable oss USE flag for sdl and rebuild it ( and any other dependencies the game may have) to get it working. Be sure that the alsa scripts enable oss emulation when launched.

hope that helps ...

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
AliasXZ
l33t
l33t


Joined: 08 Feb 2005
Posts: 836
Location: England, Huddersfield

PostPosted: Mon May 26, 2008 5:43 pm    Post subject: Reply with quote

sorry i forgot to mention oss emulation was already enabled

bump :?
_________________
Main:
Kernel: 3.12.13 amd64
RAM: 4GB
Lappy:
iBookG4 7447A @ 1.42G
------------------------------
Please add (solved) to your first post when your issue is resolved 8)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum