Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mips 2008 experimental
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue May 13, 2008 2:50 pm    Post subject: mips 2008 experimental Reply with quote

hi,
2007.1-dev is full of issues, so we'd better try 2008 experimental
today I've fresh installed the 2008, and there a bit of issue

1) rm -fr doen't remove directory of an ext3 volume, it causes a lot of issues, i don't know why, i fixed replacing /bin/rm with my 2006.1 version

2) /etc/init.d/bootmisc has issue

if [[ -z $(ps --no-heading -C "${daemon}") ]] ; then
if [[ -f ${x} || -L ${x} ]] ; then
rm -f "${x}"
fi
fi

this is the part that shows errors during the init phase, ${daemon} is void ...


i have to emerge other stuff
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue May 13, 2008 5:10 pm    Post subject: Reply with quote

3) emerging kgcc64 stales without nay progress


see the build log

QA Notice: USE Flag 'n32' not in IUSE for sys-devel/kgcc64-4.1.2
>>> Unpacking source...
>>> Unpacking gcc-4.1.2.tar.bz2 to /var/tmp/portage/sys-devel/kgcc64-4.1.2/work
>>> Unpacking gcc-4.1.2-patches-1.0.1.tar.bz2 to /var/tmp/portage/sys-devel/kgcc64-4.1.2/work
QA Notice: USE Flag 'vanilla' not in IUSE for sys-devel/kgcc64-4.1.2
Applying Gentoo patches ...
00_all_gcc-4.1-alpha-mieee-default.patch ...
00_all_gcc-trampolinewarn.patch ...
01_all_gcc4-ice-hack.patch ...
02_all_gcc4-ppc64-m32-m64-multilib-only.patch ...
03_all_gcc4-java-nomulti.patch ...
04_all_gcc42-boehmgc-include.patch ...
05_all_gcc42-multilib-print-search-dirs.patch ...
06_all_gcc4-slow-pthread-self.patch ...
10_all_gcc4-libltdl-multilib.patch ...
11_all_gcc-netbsd-symbolic.patch ...
12_all_gcc-libstdc++-ld-version.patch ...
13_all_gcc4-libjava-ia64-backtrace.patch ...
15_all_gcc42-builtin-frame-address.patch ...
20_all_cris-dont-force-limits-header.patch ...
29_all_gcc4-pr19664.patch ...
34_all_arm-bigendian.patch ...
39_all_gcc-pr28516.patch ...
40_all_gcc4-debian-hppa-cbranch.patch ...
41_all_gcc4-debian-hppa-cbranch2.patch ...
42_all_gcc4-pr27627.patch ...
48_all_gcc4-hppa-mfctl.patch ...
49_all_gcc41-pr30473.patch ...
51_all_gcc-3.4-libiberty-pic.patch ...
[..]
91_all_mips-ip28_cache_barriers-v4.patch ...
95_all_gcc-mips-dwarf-info.patch ...
95_all_gcc-mips-dwarf-old-info.patch ...
Done with patching
QA Notice: USE Flag 'hardened' not in IUSE for sys-devel/kgcc64-4.1.2
Replacing obsolete head/tail with POSIX compliant ones
- fixed contrib/test_summary
- fixed boehm-gc/configure
- fixed fastjar/configure
- fixed fixincludes/configure
- fixed gcc/configure
- fixed gnattools/configure
- fixed intl/configure
- fixed libada/configure
- fixed libcpp/configure
- fixed libffi/configure
- fixed libgfortran/configure
- fixed libiberty/configure
- fixed libjava/configure
- fixed libmudflap/configure
- fixed libobjc/configure
- fixed libssp/configure
- fixed libstdc++-v3/configure
- fixed zlib/configure
- fixed ltcf-c.sh
- fixed ltcf-cxx.sh
- fixed ltcf-gcj.sh
- fixed ltmain.sh
- fixed boehm-gc/Makefile.in
- fixed fastjar/Makefile.in
- fixed fixincludes/Makefile.in
- fixed gcc/Makefile.in
- fixed gnattools/Makefile.in
- fixed intl/Makefile.in
- fixed libada/Makefile.in
- fixed libcpp/Makefile.in
- fixed libffi/Makefile.in
- fixed libgfortran/Makefile.in
- fixed libiberty/Makefile.in
- fixed libjava/Makefile.in
- fixed libmudflap/Makefile.in
- fixed libobjc/Makefile.in
- fixed libssp/Makefile.in
- fixed libstdc++-v3/Makefile.in
- fixed zlib/Makefile.in
patching gcc version: 4.1.2 (Gentoo 4.1.2 p1.0.1)
Running elibtoolize in: gcc-4.1.2
Applying install-sh-1.5.4.patch ...
Applying ltmain-1.5.patch ...
Applying portage-1.5.10.patch ...
Applying sed-1.5.6.patch ...
Applying test-1.4.1.patch ...
Applying tmp-1.3.5.patch ...
Using GNU config files from /usr/share/libtool
No config.sub found in /var/tmp/portage/sys-devel/kgcc64-4.1.2/work/gcc-4.1.2, skipping ...
No config.guess found in /var/tmp/portage/sys-devel/kgcc64-4.1.2/work/gcc-4.1.2, skipping ...
Fixing misc issues in configure files
Applying gcc-configure-texinfo.patch ...

at this point the machine simply stales





emerging mc/ufed other stuff has not this issue


Last edited by ddc on Thu May 15, 2008 7:33 am; edited 1 time in total
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Tue May 13, 2008 6:06 pm    Post subject: Reply with quote

4) emerge --sync; emerge portage

it makes "emerge" not to be working at all: WOW, crazy has i have never seen


I can immediately back before this operation has been invoked
but I wonder how to have something working here ...
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed May 14, 2008 9:18 am    Post subject: Reply with quote

it seems the main issue is from glibc

2006.1 and 2007.0 are masking >=glibc-2.4, >=gcc-4

i see the 2008 is using glibc-2.6 gcc-4.1.2 ... ummm if you make an attempt at something you try to do it, often without success

and well, you can't emerge a lot without declaring mips has an unstable arch, i mean ~mips, so we it is clear we we have to manage a lot of tries a lot at our first -emerge-update-world- attempt


Last edited by ddc on Wed May 14, 2008 10:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Wed May 14, 2008 10:08 pm    Post subject: Reply with quote

I am hardly working to prepare something more modern than my last 2006.1

I've manually fixed a lot of issues, progressively updating ebuilds and controlling the stability of the stuff. Octane is progressively updating to 2008.0 ...

well .... i do not trust the last gcc/python ... i am coding with the solid rock gcc-3.4.6/kgcc64-3.4.6 with a "o32" profile user land

... all i have a bit of problem with kernel more modern than 2.6.17.14 ... the 2.6.23 is simply not booting here without any lines to understand what is happening ... i have to rebuild it with debug support enabled and check the internals ... i will try with binutils updated, actually i am using binutils 2.16

anybody with news, experiences, suggestions about ip30 & gentoo for 2008 things ?


ok, we run gentoo on sgi/mips for kicks 'cause we are sgi/mips addict, but i confide we can still do great things with sgi/mips =P


Last edited by ddc on Thu May 15, 2008 6:21 am; edited 1 time in total
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Thu May 15, 2008 6:09 am    Post subject: Reply with quote

after hardly testing it in a chroot of mine, today i can trust python 2.5.2 is well running: it will immediately used in my system land ...

also I ve noticed this related thread about 2008 & kernel compiling problem
maybe useful be linked to it http://forums.gentoo.org/viewtopic-t-679415.html


about kernel 2.6.23 ...

Versions of packages source-2.6.23 depends on:
- binutils = 2.18.1~cvs20071027-2
- bzip2 = 1.0.3-6

Versions of packages source-2.6.23 recommends:
- gcc = 4.1.*
- make = 3.81-2

here I am just a bit out of specifics
- binutils = 2.16 (available 2.18, to be tested)
- bzip2 = 1.0.3-r6 (available 1.0.5, to be tested)
- gcc = 3.4.6 (available 4.1.2, to be hardly tested)
- make = 3.80 (available 3.81, to be tested)
- libc = 2.3.6-r4 (available 2.6.1, to be hardly tested)
Back to top
View user's profile Send private message
ddc
Guru
Guru


Joined: 29 Aug 2006
Posts: 527

PostPosted: Mon May 19, 2008 5:44 pm    Post subject: Reply with quote

ok, dev chain hardly tested and stabilized (gcc, binutils, glibc, python, etc)
then stage3 has been rebuilt in safe and hard tested way

it's perfectly working, now
the only problem: the profile has been modified a lot

anyway, this way "world" in update emerging progress ...

anybody interested/need it ? MP me

p.s. still having a bit of issue with kernel 2.6.23 ... i think i back to 2.6.22.4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum