Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200805-03 ] Multiple X11 terminals: Local privilege escalation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1613

PostPosted: Wed May 07, 2008 7:26 pm    Post subject: [ GLSA 200805-03 ] Multiple X11 terminals: Local privilege e Reply with quote

Gentoo Linux Security Advisory

Title: Multiple X11 terminals: Local privilege escalation (GLSA 200805-03)
Severity: normal
Exploitable: local
Date: May 07, 2008
Updated: May 10, 2008
Bug(s): #216833, #217819, #219746, #219750, #219754, #219760, #219762
ID: 200805-03

Synopsis

A vulnerability was found in aterm, Eterm, Mrxvt, multi-aterm, RXVT, rxvt-unicode, and wterm, allowing for local privilege escalation.

Background

Aterm, Eterm, Mrxvt, multi-aterm, RXVT, rxvt-unicode, and wterm are X11 terminal emulators.

Affected Packages

Package: x11-terms/aterm
Vulnerable: < 1.0.1-r1
Unaffected: >= 1.0.1-r1
Architectures: All supported architectures

Package: x11-terms/eterm
Vulnerable: < 0.9.4-r1
Unaffected: >= 0.9.4-r1
Architectures: All supported architectures

Package: x11-terms/mrxvt
Vulnerable: < 0.5.3-r2
Unaffected: >= 0.5.3-r2
Architectures: All supported architectures

Package: x11-terms/multi-aterm
Vulnerable: < 0.2.1-r1
Unaffected: >= 0.2.1-r1
Architectures: All supported architectures

Package: x11-terms/rxvt
Vulnerable: < 2.7.10-r4
Unaffected: >= 2.7.10-r4
Architectures: All supported architectures

Package: x11-terms/rxvt-unicode
Vulnerable: < 9.02-r1
Unaffected: >= 9.02-r1
Architectures: All supported architectures

Package: x11-terms/wterm
Vulnerable: < 6.2.9-r3
Unaffected: >= 6.2.9-r3
Architectures: All supported architectures


Description

Bernhard R. Link discovered that RXVT opens a terminal on :0 if the "-display" option is not specified and the DISPLAY environment variable is not set. Further research by the Gentoo Security Team has shown that aterm, Eterm, Mrxvt, multi-aterm, rxvt-unicode, and wterm are also affected.

Impact

A local attacker could exploit this vulnerability to hijack X11 terminals of other users.

Workaround

There is no known workaround at this time.

Resolution

All aterm users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/aterm-1.0.1-r1"
All Eterm users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/eterm-0.9.4-r1"
All Mrxvt users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/mrxvt-0.5.3-r2"
All multi-aterm users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/multi-aterm-0.2.1-r1"
All RXVT users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/rxvt-2.7.10-r4"
All rxvt-unicode users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/rxvt-unicode-9.02-r1"
All wterm users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=x11-terms/wterm-6.2.9-r3"


References

CVE-2008-1142
CVE-2008-1692


Last edited by GLSA on Sun May 11, 2008 4:19 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum