Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200805-01 ] Horde Application Framework: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Mon May 05, 2008 9:26 pm    Post subject: [ GLSA 200805-01 ] Horde Application Framework: Multiple vul Reply with quote

Gentoo Linux Security Advisory

Title: Horde Application Framework: Multiple vulnerabilities (GLSA 200805-01)
Severity: normal
Exploitable: remote
Date: May 05, 2008
Bug(s): #212635, #213493
ID: 200805-01

Synopsis

Multiple vulnerabilities in the Horde Application Framework may lead to the execution of arbitrary files, information disclosure, and allow a remote attacker to bypass security restrictions.

Background

The Horde Application Framework is a general-purpose web application framework written in PHP, providing classes for handling preferences, compression, browser detection, connection tracking, MIME and more.

Affected Packages

Package: www-apps/horde
Vulnerable: < 3.1.7
Unaffected: >= 3.1.7
Architectures: All supported architectures

Package: www-apps/horde-groupware
Vulnerable: < 1.0.5
Unaffected: >= 1.0.5
Architectures: All supported architectures

Package: www-apps/horde-kronolith
Vulnerable: < 2.1.7
Unaffected: >= 2.1.7
Architectures: All supported architectures

Package: www-apps/horde-mnemo
Vulnerable: < 2.1.2
Unaffected: >= 2.1.2
Architectures: All supported architectures

Package: www-apps/horde-nag
Vulnerable: < 2.1.4
Unaffected: >= 2.1.4
Architectures: All supported architectures

Package: www-apps/horde-webmail
Vulnerable: < 1.0.6
Unaffected: >= 1.0.6
Architectures: All supported architectures


Description

Multiple vulnerabilities have been reported in the Horde Application Framework:
  • David Collins, Patrick Pelanne and the HostGator.com LLC support team discovered that the theme preference page does not sanitize POST variables for several options, allowing the insertion of NULL bytes and ".." sequences (CVE-2008-1284).
  • An error exists in the Horde API allowing users to bypass security restrictions.


Impact

The first vulnerability can be exploited by a remote attacker to read arbitrary files and by remote authenticated attackers to execute arbitrary files. The second vulnerability can be exploited by authenticated remote attackers to perform restricted operations.

Workaround

There is no known workaround at this time.

Resolution

All Horde Application Framework users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-3.1.7"
All horde-groupware users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-groupware-1.0.5"
All horde-kronolith users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-kronolith-2.1.7"
All horde-mnemo users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-mnemo-2.1.2"
All horde-nag users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-nag-2.1.4"
All horde-webmail users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-webmail-1.0.6"


References

CVE-2008-1284


Last edited by GLSA on Sun Oct 26, 2008 4:20 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum