Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200804-15 ] libpng: Execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1540

PostPosted: Tue Apr 15, 2008 2:26 am    Post subject: [ GLSA 200804-15 ] libpng: Execution of arbitrary code Reply with quote

Gentoo Linux Security Advisory

Title: libpng: Execution of arbitrary code (GLSA 200804-15)
Severity: high
Exploitable: remote
Date: April 15, 2008
Bug(s): #217047
ID: 200804-15

Synopsis

A vulnerability in libpng may allow for execution of arbitrary code in certain applications that handle untrusted images.

Background

libpng is a free ANSI C library used to process and manipulate PNG images.

Affected Packages

Package: media-libs/libpng
Vulnerable: < 1.2.26-r1
Unaffected: >= 1.2.26-r1
Architectures: All supported architectures


Description

Tavis Ormandy of the Google Security Team discovered that libpng does not handle zero-length unknown chunks in PNG files correctly, which might lead to memory corruption in applications that call png_set_read_user_chunk_fn() or png_set_keep_unknown_chunks().

Impact

A remote attacker could entice a user or automated system to process a specially crafted PNG image in an application using libpng and possibly execute arbitrary code with the privileges of the user running the application. Note that processing of unknown chunks is disabled by default in most PNG applications, but some such as ImageMagick are affected.

Workaround

There is no known workaround at this time.

Resolution

All libpng users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-libs/libpng-1.2.26-r1"


References

CVE-2008-1382
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum