Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200804-10 ] Tomcat: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Thu Apr 10, 2008 10:26 pm    Post subject: [ GLSA 200804-10 ] Tomcat: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Tomcat: Multiple vulnerabilities (GLSA 200804-10)
Severity: normal
Exploitable: local, remote
Date: April 10, 2008
Updated: May 28, 2009
Bug(s): #196066, #203169
ID: 200804-10

Synopsis

Multiple vulnerabilities in Tomcat may lead to local file overwriting, session hijacking or information disclosure.

Background

Tomcat is the Apache Jakarta Project's official implementation of Java Servlets and Java Server Pages.

Affected Packages

Package: www-servers/tomcat
Vulnerable: < 6.0.16
Unaffected: >= 5.5.26 < 5.5.27
Unaffected: >= 6.0.16
Unaffected: >= 5.5.27 < 5.5.28
Architectures: All supported architectures


Description

The following vulnerabilities were reported:
  • Delian Krustev discovered that the JULI logging component does not properly enforce access restrictions, allowing web application to add or overwrite files (CVE-2007-5342).
  • When the native APR connector is used, Tomcat does not properly handle an empty request to the SSL port, which allows remote attackers to trigger handling of a duplicate copy of one of the recent requests (CVE-2007-6286).
  • If the processing or parameters is interrupted, i.e. by an exception, then it is possible for the parameters to be processed as part of later request (CVE-2008-0002).
  • An absolute path traversal vulnerability exists due to the way that WebDAV write requests are handled (CVE-2007-5461).
  • Tomcat does not properly handle double quote (") characters or %5C (encoded backslash) sequences in a cookie value, which might cause sensitive information such as session IDs to be leaked to remote attackers and enable session hijacking attacks (CVE-2007-5333).


Impact

These vulnerabilities can be exploited by:
  • a malicious web application to add or overwrite files with the permissions of the user running Tomcat.
  • a remote attacker to conduct session hijacking or disclose sensitive data.


Workaround

There is no known workaround at this time.

Resolution

All Tomcat 5.5.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/tomcat-5.5.26"
All Tomcat 6.0.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/tomcat-6.0.16"


References

CVE-2007-5333
CVE-2007-5342
CVE-2007-5461
CVE-2007-6286
CVE-2008-0002


Last edited by GLSA on Fri May 29, 2009 4:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum