Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200804-08 ] lighttpd: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1558

PostPosted: Thu Apr 10, 2008 4:26 pm    Post subject: [ GLSA 200804-08 ] lighttpd: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: lighttpd: Multiple vulnerabilities (GLSA 200804-08)
Severity: normal
Exploitable: remote
Date: April 10, 2008
Bug(s): #212930, #214892
ID: 200804-08

Synopsis

Multiple vulnerabilities in lighttpd may lead to information disclosure or a Denial of Service.

Background

lighttpd is a lightweight high-performance web server.

Affected Packages

Package: www-servers/lighttpd
Vulnerable: < 1.4.19-r2
Unaffected: >= 1.4.19-r2
Architectures: All supported architectures


Description

Julien Cayzax discovered that an insecure default setting exists in mod_userdir in lighttpd. When userdir.path is not set the default value used is $HOME. It should be noted that the "nobody" user's $HOME is "/" (CVE-2008-1270). An error also exists in the SSL connection code which can be triggered when a user prematurely terminates his connection (CVE-2008-1531).

Impact

A remote attacker could exploit the first vulnerability to read arbitrary files. The second vulnerability can be exploited by a remote attacker to cause a Denial of Service by terminating a victim's SSL connection.

Workaround

As a workaround for CVE-2008-1270 you can set userdir.path to a sensible value, e.g. "public_html" .

Resolution

All lighttpd users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-servers/lighttpd-1.4.19-r2"


References

CVE-2008-1270
CVE-2008-1531
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum