Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
перестал работать звук
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
mediumuser
n00b
n00b


Joined: 04 Apr 2008
Posts: 3

PostPosted: Fri Apr 04, 2008 10:01 am    Post subject: перестал работать звук Reply with quote

# dmesg | less

Code:
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:1b.0 to 64
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:1b.0 to 64
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...
ACPI: PCI interrupt for device 0000:00:1b.0 disabled
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 22 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:1b.0 to 64
hda_codec: Unknown model for ALC268, trying auto-probe from BIOS...


# lsmod
Code:
Module                  Size  Used by
snd_pcm_oss            33920  0
snd_mixer_oss          12672  1 snd_pcm_oss
snd_seq_dummy           2692  0
snd_seq_oss            24960  0
snd_seq_midi_event      5504  1 snd_seq_oss
snd_seq                37616  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          6028  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_hda_intel         253084  0
snd_pcm                57352  2 snd_pcm_oss,snd_hda_intel
snd_timer              15492  2 snd_seq,snd_pcm
snd                    38148  8 snd_pcm_oss,snd_mixer_oss,snd_seq_oss,snd_seq,snd_seq_device,snd_hda_intel,snd_pcm,snd_timer
snd_page_alloc          7304  2 snd_hda_intel,snd_pcm


# mplayer hhh.avi

Code:
[AO_ALSA] alsa-lib: pcm_dmix.c:831:(snd_pcm_dmix_open) unable to create IPC semaphore
[AO_ALSA] Ошибка начала воспроизведения: Function not implemented
mcop warning: user defined signal handler found for SIG_PIPE, overriding
[AO ARTS] can't connect to aRts soundserver
DVB card number must be between 1 and 4
AO: [null] 11025Hz 2ch s16le (2 bytes per sample)
Начало воcпроизведения...
VDec: запрос vo config - 352 x 288 (предпочтимое цветовое пространство: Planar YV12)
VDec: использую Planar YV12 в качестве выходного csp (не 0)
Movie-Aspect не определён - премасштабирование не применяется.
VO: [xv] 352x288 => 352x288 Planar YV12
X11 error: BadAccess (attempt to access private resource denied)


кароче проблема такая, пропал звук в приложениях kde, а mplayer ко всему ещё и не проигрывает видео
во время запуска kaffein все проигрывается, но звука нет, хотя cat /dev/urandom > /dev/dsp работает(в динамиках появляется шум) т.е. получается что драйвер(модуль) работает, а alsa server нет(имхо)
Господа, что можете подсказать?
Back to top
View user's profile Send private message
adequate
n00b
n00b


Joined: 22 Apr 2008
Posts: 12

PostPosted: Tue Apr 29, 2008 8:23 pm    Post subject: Reply with quote

Если перекомпилировал ядро, рекомендуется переустановить alsa-driver IMHO.
Как у тебя alsa установлена? Как портеж или в ядре?
_________________
BSDHome
Back to top
View user's profile Send private message
f0rk
Apprentice
Apprentice


Joined: 15 Nov 2004
Posts: 273
Location: Moscow

PostPosted: Tue Apr 29, 2008 8:39 pm    Post subject: Reply with quote

до этого происшествия ничего не собирал "звукового"?
да, и напиши с какими флагами alsa-lib собран.
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Wed Apr 30, 2008 2:28 am    Post subject: Re: перестал работать звук Reply with quote

Code:
[AO_ALSA] alsa-lib: pcm_dmix.c:831:(snd_pcm_dmix_open) unable to create IPC semaphore


IPC в ядре включено?
Code:
grep CONFIG_SYSVIPC .config
Back to top
View user's profile Send private message
Estariol
n00b
n00b


Joined: 28 Feb 2008
Posts: 10
Location: Kyiv/Moscow

PostPosted: Thu May 01, 2008 5:43 pm    Post subject: Reply with quote

Хм, кстати у меня на днях похожая беда случилась при попытке проапгрэйдить ядро с 2.6.22 на 2.6.24. Конфиг новому ядру подсовывал старый, snd_hda_intel загружался, но звук не появлялся.

Времени разбираться не было, поэтому я просто откатился на назад на 2.6.22
Back to top
View user's profile Send private message
asm64
n00b
n00b


Joined: 25 Apr 2008
Posts: 26
Location: г.Кемерово

PostPosted: Mon May 05, 2008 3:32 pm    Post subject: Reply with quote

Проапрейдился с 2.6.24 до 2.6.25. Пропали OSS устройства /dev/mixer /dev/oss. ALSA была вкомпиленая, а OSS эмуляция модулями. Вкомпилил всё в ядро - запело!

Для исключения сторонних проблем, АЛСУ лучше проверять утилитой aplay.
Back to top
View user's profile Send private message
wx64
n00b
n00b


Joined: 08 May 2008
Posts: 2
Location: Paris

PostPosted: Thu May 08, 2008 10:24 pm    Post subject: Any success in solving the IPC semaphore error? Reply with quote

Hello,

I get exactly the same alsa sound error as you have when I run a sound application

Code:

ALSA lib pcm_dmix.c:831:(snd_pcm_dmix_open) unable to create IPC semaphore


Any success in solving the issue?
Unfortunately I could not understand everything in your discussion as my russian is not so good :)

Thanks a lot!
Back to top
View user's profile Send private message
_Sir_
Guru
Guru


Joined: 17 Jan 2005
Posts: 337
Location: Russia, Togliatti

PostPosted: Sat May 24, 2008 7:24 am    Post subject: Re: Any success in solving the IPC semaphore error? Reply with quote

wx64 wrote:
Hello,I get exactly the same alsa sound error as you have when I run a sound application
Code:

ALSA lib pcm_dmix.c:831:(snd_pcm_dmix_open) unable to create IPC semaphore
This is mostly because of lack IPC support in kernel. Under the command
Code:
sudo su -
cd /usr/src/linux
make menuconfig
go to General setup ---> and check up if you enable [*] System V IPC
Than you have to obviosly recompile your kernel. Hope, this will help
_________________
(Sir) * Life is placeholder for Love *
Back to top
View user's profile Send private message
_Sir_
Guru
Guru


Joined: 17 Jan 2005
Posts: 337
Location: Russia, Togliatti

PostPosted: Mon May 26, 2008 7:10 pm    Post subject: Reply with quote

Estariol wrote:
Хм, кстати у меня на днях похожая беда случилась при попытке проапгрэйдить ядро с 2.6.22 на 2.6.24. Конфиг новому ядру подсовывал старый, snd_hda_intel загружался, но звук не появлялся.
В более поздних ядрах код High Definition Audio в ядре довольно основательно подработали, и старые конфиги просто не годятся. Чтобы уменьшить число телодвижений и не нарываться на подобные вещи, полезно подсунув старый .config выполнять команду
Code:
make oldconfig
Все новые опции в ядре будут построчно выведены для того, чтобы пользователь мог решить их судьбу :) y/n/m, как обычно.
_________________
(Sir) * Life is placeholder for Love *
Back to top
View user's profile Send private message
Xrundic
n00b
n00b


Joined: 26 Apr 2012
Posts: 3
Location: Петропавловск-Камчатский

PostPosted: Thu Apr 26, 2012 7:57 am    Post subject: alsa Reply with quote

Может быть не в тему, но то же проблемы со звуком в mplayer.
А всё началось, что собирал и пересобирал пакеты к KDE 4.8.2. В итоге простой проигрыватель audacious по умолчанию звук не проигрывает, появляется звук только после указания в настройках к алса устройства PCM : hw:0,0 (ALC 1200 Analog) и микшера: hw:0 (HDA Intel). При запуске alsamixer от пользователя появляется одна колонка <Master> с Card: PulseAudio Chip:PulseAudio.
Далее при запуске от простого пользователя mplayer любого фильма или аудиофайла звук не проигрывается. В консоле ошибок по выводу звука не выдаёт. При запуске mplayer от root-а всё идёт нормально звук и изображение.

Если что-то упустил, то укажите для помощи в решении простой проблемы.
_________________
самая страшная пустота - это пустота в голове.
Back to top
View user's profile Send private message
Xrundic
n00b
n00b


Joined: 26 Apr 2012
Posts: 3
Location: Петропавловск-Камчатский

PostPosted: Fri Apr 27, 2012 3:12 am    Post subject: Reply with quote

Решение своей проблемы нашёл в удалении из системы pulseaudio и пересборкой пакетов alsa-* и mplayer.
_________________
самая страшная пустота - это пустота в голове.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum