Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error when using emerge foo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
@bu
n00b
n00b


Joined: 02 Jul 2002
Posts: 3
Location: Karlsruhe

PostPosted: Tue Jul 02, 2002 10:07 am    Post subject: error when using emerge foo Reply with quote

I unmerged python (yes, I know: not a good idea but the key was pressed :() but managed to reinstall it by copying all python2.2 files from the stage3... file to the appropriate positions.

Python works but when I try to use "emerge foo" to install software I get the following error:

phoenix root # emerge portage
Traceback (most recent call last):
File "/usr/bin/emerge", line 1217, in ?
mydepgraph=depgraph(myaction,myopts)
File "/usr/bin/emerge", line 357, in __init__
self.fakedbapi=portage.fakedbapi()
AttributeError: 'module' object has no attribute 'fakedbapi'

I don't know if this has something to do with my "python-problem"
but I would be very happy if someone can help me - what is a Gentoo-Linux system with old software ;)

Thanks a lot!
@bu
Back to top
View user's profile Send private message
phantasm
n00b
n00b


Joined: 21 Jun 2002
Posts: 71
Location: Cincinnati

PostPosted: Tue Jul 02, 2002 1:16 pm    Post subject: Reply with quote

did you upgrade portage? If so see here

http://forums.gentoo.org/viewtopic.php?t=6002
Back to top
View user's profile Send private message
@bu
n00b
n00b


Joined: 02 Jul 2002
Posts: 3
Location: Karlsruhe

PostPosted: Tue Jul 02, 2002 2:04 pm    Post subject: solution to the problem with your help... Reply with quote

Thank you very much - that was a very good hint:
Everything is working fine now ;))

I've read the thread you mentioned before but I didn't know that the subject discussed there could also help me... but well, it did: I tried the ebuild command and got an error message which led me to the root of the error:
The python scripts in /usr/lib/python2.2/site-packages were damaged.

I downloaded the current portage .bzip2 from cvs, extracted the
needed .py files and here we go, an "emerge portage" worked!

Thanks a lot again,
@bu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum