Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logging out of X diplay dies. Solution needed.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Thu Mar 13, 2008 3:47 pm    Post subject: Logging out of X diplay dies. Solution needed. Reply with quote

I just upgraded to the latest stable version of xorg server and nvidia drivers. I DONT run kdm or gdm or xdm or anything like it. I log out of X and expect to be taken back to the command prompt however instead my monitor looses the connection to the system as if the driver was unloaded or the video card was shut down.

This never use to happen which leads me to believe there is some new "feature" that is enabled by default. Anyone have any idea what that may be?


Last edited by KWhat on Sun Mar 16, 2008 7:59 pm; edited 3 times in total
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 376
Location: Graben-Neudorf, Germany

PostPosted: Thu Mar 13, 2008 4:26 pm    Post subject: Reply with quote

I had a similar problem when I ran kde-svn, but I don't know if it's related.

It also happened when I switched between x-sessions very much.

Which kind of graphics card do you use?

I have a ATI-card and I just switched to the radeonhd driver.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Thu Mar 13, 2008 8:53 pm    Post subject: Reply with quote

i am using an nvidia card with nvidia drivers and this only happens when i log out.
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Fri Mar 14, 2008 6:30 am    Post subject: Reply with quote

Ok so this is starting to get entertaining.... I traced the issue back to SLI being enabled, but thats not really the entertaining part. While SLI was disabled i decided to test and see how fast it was using glxgears. Yes i know its not a benchmark application. Anyway with that said glxgears now scores 1500 fps better than with SLI enabled! Yah wow is right. Anyway i still need a solution to the original problem.

Thanks.
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 376
Location: Graben-Neudorf, Germany

PostPosted: Fri Mar 14, 2008 8:17 am    Post subject: Reply with quote

Could you take a moment to explain what SLI is?
And maybe why it might have sped up glxgears.

If it doesn't take too much time.

I don't know that much about the internals of X, but I'd like to understand the purpose of things which affect me.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Fri Mar 14, 2008 3:42 pm    Post subject: Reply with quote

Its not that uncommon nor is it that difficult to locate information about it.

http://en.wikipedia.org/wiki/Scalable_Link_Interface

I am not posting here to teach, i am posting here for solutions.
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 376
Location: Graben-Neudorf, Germany

PostPosted: Mon Mar 17, 2008 10:20 am    Post subject: Reply with quote

Thanks!

The name SLI just told me nothing and I thought was some X11-feature, not something in your graphics card, but still you're right: I should have googled "SLI" - it would have given me the info I needed.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
Aquiles
Apprentice
Apprentice


Joined: 23 Feb 2007
Posts: 230
Location: Somewhere, surrounded by my circumstances.

PostPosted: Mon Mar 17, 2008 10:42 am    Post subject: Reply with quote

I don't know if this will solve you anything, but I had a similar issue with my Nvidia 8800 GTS, that is, after loggin out of the X session, or just ctrl+alt+f1 to a console, my monitor was put to sleep mode, as if it had been disconnected. I don't know what causes this, but I do know that after configuring my xorg.conf using nvidia-xconfig the issue was sorted out, and now it is working fine. I suspect this is a Hsync or Vsync related issue.
_________________
Aquiles
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Tue Mar 18, 2008 3:06 am    Post subject: Solution: nvidia sucks? Reply with quote

I played around with the module options as some people reported having similar issues at startup but i had no luck.

Code:

Option          "UseDisplayDevice"      "DFP"
Option         "ConnectedMonitor"      "DFP"


I tried running through the nvidia xorg config but that yielded similar results to my existing config file and had the same bug/issue.

I am beginning to thing that the solution is to first mask the current nvidia driver version > 100 and then buy a new NON-nvidia card. It seems that nvidia's drivers have gotten progressively worse and ATI has stepped up their driver development.
Back to top
View user's profile Send private message
NathanZachary
Moderator
Moderator


Joined: 30 Jan 2007
Posts: 2336
Location: /home/zach

PostPosted: Tue Mar 18, 2008 4:34 am    Post subject: Reply with quote

I agree with the first part of your statement that it might be best to mask the current version and go back one. However, I have machines with nVidia and ATi cards and the ATi ones are always a huge pain compared to the nVidia ones. Maybe you will have better luck than I with ATi, though.
_________________
“Truth, like infinity, is to be forever approached but never reached.” --Jean Ayres (1972)
---avatar cropped from =AimanStudio---
Back to top
View user's profile Send private message
eddo
n00b
n00b


Joined: 03 Mar 2008
Posts: 51

PostPosted: Tue Mar 18, 2008 7:15 am    Post subject: Reply with quote

I have this problem too. When I logout after a startx I get a "no signal detected" message from my monitor. Have to reboot to wake it up again, really annoying. This is on my Geforce 8500GT. I'm sure it's a driver thing since I used to get exactly the same problem on a different distribution.
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Tue Mar 18, 2008 3:28 pm    Post subject: Reply with quote

Thanks for the response eddo. Are you using SLI? It seems to only happen to me when sli is enabled, and when sli is enabled i take a 15% performance hit. Can you please verify.

*** Update
I have posted on http://www.nvnews.net/vbulletin/showthread.php?t=109956 where i have recieved no response so I am going to file a bug with nvidia and i would suggest that if you are still having the same issue you do the same. The tool to use is nvidia-bug-report.sh installed with the drivers.
Back to top
View user's profile Send private message
eddo
n00b
n00b


Joined: 03 Mar 2008
Posts: 51

PostPosted: Tue Mar 18, 2008 11:50 pm    Post subject: Reply with quote

No SLI, just a single card.
Back to top
View user's profile Send private message
eddo
n00b
n00b


Joined: 03 Mar 2008
Posts: 51

PostPosted: Thu Jul 24, 2008 9:56 pm    Post subject: Reply with quote

Was there ever any progress made on this? I noticed the other for the first time ever than when I was doing a shutdown I saw the shutdown text come up, which was a welcome change. Still not fixed though, just a one-off fluke it seems.
Back to top
View user's profile Send private message
eddo
n00b
n00b


Joined: 03 Mar 2008
Posts: 51

PostPosted: Wed Jul 30, 2008 11:44 am    Post subject: Reply with quote

I've recently switched from an AMD64 installation to x86 and I can now quit back to console/change ttyl without crashing. Could this be yet another 64-bit bug?

To be fair, it does still crash occasionally (I think if I change something in xorg.conf then relaunch X, it will crash), but I think that's a seperate bug.
Back to top
View user's profile Send private message
KWhat
Guru
Guru


Joined: 04 Sep 2005
Posts: 563
Location: Los Angeles

PostPosted: Wed Jul 30, 2008 2:45 pm    Post subject: Reply with quote

I reported a bug to nvidia on the subject a while back. My power supply conveniently went out and fried my 6800's so I ended up upgrading to an 8800 which fixed the problem. As far as a resolution goes im not sure it was setting it to sleep mode for me because it only happened in sli mode. Oh and yes i was amd64 as well. I think we can just chalk this one up to a proprietary driver bug.
Back to top
View user's profile Send private message
riczan
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2005
Posts: 134
Location: Sicily. Nothing personal...

PostPosted: Mon Feb 09, 2009 7:07 pm    Post subject: Reply with quote

I have the same problem on a laptop, with nvidia 9800GTS.

Has anyone found a solution to this yet (besides frying the card and buying a new one)?

I'm using x86, so I don't think this is specific to 64bits.

I've tried disabling all frame buffers and also tried with the vesafb and uvesafb with no progress.

When I use the nv driver I can log out and ctr-alt-fn to the console with no problems.

Note that only the monitor is off, I can shutdown by typying on the keyboard (blindly) or by ssh-ing to it from a different pc and typing shutdown. I can even restart startx and get back the screen, but loging off again ends up in the dead monitor.

I've narrowed the differences between using nv and nvidia drivers in the Xorg.log to the frame buffer used inside X (if that makes any sense).

when using nvidia driver it uses a library wfb
when using nv it uses a library fb.

Is it possible to force nvidia to use the fb library used by nv? I think this could help.

Finally, this laptop also has problems with the ACPI... the laptop doesn't know when the adapter AC is connected... Could this be the reason?
hibernate also doesn't wake up the monitor (hibernating from the consoles, I should try inside X), but this is probably another threat

Thanks
_________________
SAGER 5793
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 818
Location: Vancouver, BC

PostPosted: Mon Feb 09, 2009 7:45 pm    Post subject: Reply with quote

I had this problem on my 8800GTS and disabled all framebuffer support, framebuffer console support, and bootsplash support. After that the problem went away.

The nvidia drivers really don't like any of that.
Back to top
View user's profile Send private message
riczan
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2005
Posts: 134
Location: Sicily. Nothing personal...

PostPosted: Tue Feb 10, 2009 2:06 am    Post subject: Reply with quote

Thanks for the suggestion but I tried again and this didn't work.

See the difference between using nv (works) and nvidia driver (doesn't work)
With nv
Code:

(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3

With nvidia
Code:

(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.3.0, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules/extensions//libwfb.so
(II) Module wfb: vendor="NVIDIA Corporation"
        compiled for 7.1.99.2, module version = 1.0.0


Could wfb be the problem? That's all the difference I can see in the X.org.log (besides all the xgl stuff).

I tried again no frabuffer with drivers 177 and 180 and got the same result.

I don't know what else to try.

There is an option on the x11.xorg file:
Load "wfb"

which I have commented out but it still loads the wfb.

Maybe commenting it out is not the same as disabling it.?

Does any one know any other fancy nvidia options that I could try.
Help
_________________
SAGER 5793
Back to top
View user's profile Send private message
riczan
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2005
Posts: 134
Location: Sicily. Nothing personal...

PostPosted: Wed Feb 11, 2009 3:27 am    Post subject: Reply with quote

I found this sort of work around

on the terminal right before typing startx
Code:

vbetool vbestate save >somefile


now startx
logout
you screen is now off, that is the problem

blindly type:
Code:

vbetool vbestate restore <somefile


your monitor should be on now.

I guess this could work if I can find an smart way to do this automatically without me trying to type blindly.

Suggestions? Something like putting this on a script right after logout or perhaps configuring a button to do it?

you obviously need to emerge vbetool but it is on portage. Also, you need to be root, I think.
_________________
SAGER 5793
Back to top
View user's profile Send private message
riczan
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2005
Posts: 134
Location: Sicily. Nothing personal...

PostPosted: Fri May 08, 2009 4:06 pm    Post subject: Reply with quote

After upgrading to xorg 1.5 my work around of vbetool stopped working :(

I really want to get this fixed. After some google I realized that this is a common problem in several linux distributions.

The problem seems to be related to using dvi in some flat screens. Using the VGA solves the problem but I'm using a laptop, so the dvi connection happens inside the laptop.

One person reports solving this by having a console (with the help of a framebuffer) in native resolution... Only then could he get the console after logging out of Xorg/nvidia-driver. Problem is that my native resolution is 1920x1200!!! I'm not even sure this is an option.

It seems that nvidia-driver can't remember the console mode (perhaps if it is not native) in some LCD screens.

Still, worth a try (the frame buffer trick 1920x1200 (if possible))

I also noticed that "nv" pulls some additional modules automatically that nvidia-driver doesn't. I force the loading of these modules now with nvidia also but so far that didn't help (int10, ddc).

Any ideas? Has any one solved this problem?. Does someone know why vbetool stopped working?
_________________
SAGER 5793
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum