Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200803-14 ] Ghostscript: Buffer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1539

PostPosted: Sat Mar 08, 2008 7:26 pm    Post subject: [ GLSA 200803-14 ] Ghostscript: Buffer overflow Reply with quote

Gentoo Linux Security Advisory

Title: Ghostscript: Buffer overflow (GLSA 200803-14)
Severity: normal
Exploitable: remote
Date: March 08, 2008
Bug(s): #208999
ID: 200803-14

Synopsis

A stack-based buffer overflow has been discovered in Ghostscript, allowing arbitrary code execution.

Background

Ghostscript is a suite of software based on an interpreter for PostScript and PDF.

Affected Packages

Package: app-text/ghostscript-esp
Vulnerable: < 8.15.4-r1
Unaffected: >= 8.15.4-r1
Architectures: All supported architectures

Package: app-text/ghostscript-gpl
Vulnerable: < 8.61-r3
Unaffected: >= 8.61-r3
Architectures: All supported architectures

Package: app-text/ghostscript-gnu
Vulnerable: < 8.60.0-r2
Unaffected: >= 8.60.0-r2
Architectures: All supported architectures


Description

Chris Evans (Google Security) discovered a stack-based buffer overflow within the zseticcspace() function in the file zicc.c when processing a PostScript file containing a long "Range" array in a .seticcscpate operator.

Impact

A remote attacker could exploit this vulnerability by enticing a user to open a specially crafted PostScript file, which could possibly lead to the execution of arbitrary code or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Ghostscript ESP users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-esp-8.15.4-r1"
All Ghostscript GPL users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-gpl-8.61-r3"
All Ghostscript GNU users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/ghostscript-gnu-8.60.0-r2"


References

CVE-2008-0411
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum