Joined: 12 May 2004
|Posted: Mon Mar 03, 2008 1:26 am Post subject: [ GLSA 200803-02 ] Firebird: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: Firebird: Multiple vulnerabilities (GLSA 200803-02)
Date: March 02, 2008
Multiple vulnerabilities in Firebird may allow the remote execution of arbitrary code.
Firebird is a multi-platform, open source relational database.
Vulnerable: < 184.108.40.20681.0-r5
Unaffected: >= 220.127.116.1181.0-r5
Architectures: All supported architectures
Firebird does not properly handle certain types of XDR requests, resulting in an integer overflow (CVE-2008-0387). Furthermore, it is vulnerable to a buffer overflow when processing usernames (CVE-2008-0467).
A remote attacker could send specially crafted XDR requests or an overly long username to the vulnerable server, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
There is no known workaround at this time.
All Firebird users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-db/firebird-18.104.22.16881.0-r5"