Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200803-01 ] Adobe Acrobat Reader: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Mon Mar 03, 2008 12:26 am    Post subject: [ GLSA 200803-01 ] Adobe Acrobat Reader: Multiple vulnerabil Reply with quote

Gentoo Linux Security Advisory

Title: Adobe Acrobat Reader: Multiple vulnerabilities (GLSA 200803-01)
Severity: normal
Exploitable: remote
Date: March 02, 2008
Updated: March 05, 2008
Bug(s): #170177
ID: 200803-01

Synopsis

Adobe Acrobat Reader is vulnerable to remote code execution, Denial of Service, and cross-site request forgery attacks.

Background

Adobe Acrobat Reader is a PDF reader released by Adobe.

Affected Packages

Package: app-text/acroread
Vulnerable: < 8.1.2
Unaffected: >= 8.1.2
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Adobe Acrobat Reader, including:
  • A file disclosure when using file:// in PDF documents (CVE-2007-1199)
  • Multiple buffer overflows in unspecified Javascript methods (CVE-2007-5659)
  • An unspecified vulnerability in the Escript.api plugin (CVE-2007-5663)
  • An untrusted search path (CVE-2007-5666)
  • Incorrect handling of printers (CVE-2008-0667)
  • An integer overflow when passing incorrect arguments to "printSepsWithParams" (CVE-2008-0726)
Other unspecified vulnerabilities have also been reported (CVE-2008-0655).

Impact

A remote attacker could entice a user to open a specially crafted document, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application. A remote attacker could also perform cross-site request forgery attacks, or cause a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Adobe Acrobat Reader users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-text/acroread-8.1.2"


References

CVE-2007-1199
CVE-2007-5659
CVE-2007-5663
CVE-2007-5666
CVE-2008-0655
CVE-2008-0667
CVE-2008-0726


Last edited by GLSA on Thu Mar 06, 2008 4:19 am; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum