Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WineCVS on AMD64.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
SteakTheMooCow
Tux's lil' helper
Tux's lil' helper


Joined: 02 Sep 2005
Posts: 99
Location: /dev/urandom

PostPosted: Sat Oct 15, 2005 12:41 am    Post subject: WineCVS on AMD64. Reply with quote

This works for me :P

The first few times you tried it do this, you'll probably get libXext, libX11 or maybe
Code:

make[2]: *** No rule to make target `../../dlls/ddraw/tests/ddraw_test.exe.so', needed by `ddraw_test.exe.so'.  Stop.
make[2]: Leaving directory `/cvs/wine/programs/winetest'
make[1]: *** [winetest/__install__] Error 2
make[1]: Leaving directory `/cvs/wine/programs'
make: *** [programs/__install__] Error 2


I'd assume ATi just need to run the same link...

First, we need the CVS.
Code:

export CVSROOT=:pserver:cvs@cvs.winehq.org:/home/wine
cvs login

Password is "cvs"
Now go to the directory you want the CVS installed into... (the first line is what I do, the second is the CVS)
Code:

mkdir /cvs ; cd /cvs
cvs -z 0 checkout wine

Now this tends to take a while... so start setting up the emulation libraries below...
Once its done, we can go to 'compiling'

The Emulation Libraries
Code:
emerge emul-linux-x86-baselibs emul-linux-x86-compat emul-linux-x86-glibc emul-linux-x86-gtklibs emul-linux-x86-qtlibs emul-linux-x86-sdl emul-linux-x86-soundlibs emul-linux-x86-xlibs


However, if you run WineCVS, its not enough just to have the X11/Xext files in play. You also need freetype. Problem solved.
Code:
cp /usr/lib/libfreetype.* /emul/linux/x86/usr/lib/

Yes, that does mean the libfreetype files are 64 bit.[1]

Compiling
Ok, first of all go to the directory, which for me is /cvs/wine. I don't use the ./tools/wineinstall method that's recommended, because it just doesn't work on an AMD64. Anyway, first of all give it a shot without touching anything, you might get lucky, even if I doubt it, it might work.

Now, you'll get a directdraw/directx error unless it can find libraries for your card. Mine are nvidia, so here's how I did it...
Code:
ln -sf /usr/lib/opengl/nvidia/ /emul/linux/x86/usr/lib/opengl/nvidia


Anyway, I have to run this
Code:
./configure --x-libraries=/emul/linux/x86/usr/lib ; make clean ; make depend ; make


Then its time for "make install."

Now wine runs :) Good luck to everyone else :)

[1] The first freetype file used was from Gentoo from the P4. It failed. I also grabbed one from Slackware 10.2 from the Pentium-M and watched it die.


Tested and running software:
- EKS Sherlock (google for EKS Sherlock... its a Windows/DOS game)
- Steam (Half life 2 DM running, installing CS:S as I write this. Same engine, so if it screws up, I'll let you know.)
_________________
Gentoo HP ProBook 6540b
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Sun Oct 16, 2005 10:43 pm    Post subject: Reply with quote

Hi SteakTheMooCow,

thank you for your explanations.

This is what I did so far:
1) I decided to install winecvs globally so that all users would be able to use it. So, I followed all instructions and install it on /opt/cvs
2) I succesfully installed it but have two errors:
First one now firefox-bin does not run anymore due to this error message:
Code:
No running windows found
/opt/firefox/firefox-bin: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory
firefox-bin exited with non-zero status (127)

which relates to emul-linux-x86-xlibs. By implementing what you adviced to
Code:
cp /usr/lib/libfreetype.* /emul/linux/x86/usr/lib/
you do not allow other apps to run as you replace 32bit with 64bit.
So, in order to fix this problem I had to re-emerge emul-linux-x86-xlibs and this part was solved. But, still remains the fact that your cp caused an issue with other apps.
Second one when I run winecfg I get this error and not able to continue:
Code:
/usr/local/bin/wine: error while loading shared libraries: libwine.so.1: cannot open shared object file: No such file or directory


So, this to me means three things:
1)
Code:
cp /usr/lib/libfreetype.* /emul/linux/x86/usr/lib/
is not proper for me. How to solve this issue? If I do not apply something similar to this winecvs won't compile.
2) what makes wine complaints and not run?
3) this line: ./configure --x-libraries=/emul/linux/x86/usr/lib does it have to be this way or can I just have ./configure?

thank you,
Spiro
Back to top
View user's profile Send private message
SAngeli
l33t
l33t


Joined: 16 Apr 2004
Posts: 904
Location: Italy

PostPosted: Mon Oct 24, 2005 4:57 pm    Post subject: Reply with quote

Hi,

I solved my problem. I applied a new ebuild wine ebuild 9999 whcih allows cvs install, and wine compiles fine. So, no need anymore to go through all the above steps.

Thank you anyway,
Spiro
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2767
Location: Pittsburgh, PA, USA

PostPosted: Wed Oct 26, 2005 1:46 am    Post subject: Reply with quote

Quote:
I applied a new ebuild wine ebuild 9999 whcih allows cvs install


Thanks for the info. :D
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum