Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200802-11 ] Asterisk: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Tue Feb 26, 2008 11:26 pm    Post subject: [ GLSA 200802-11 ] Asterisk: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Asterisk: Multiple vulnerabilities (GLSA 200802-11)
Severity: high
Exploitable: remote
Date: February 26, 2008
Bug(s): #185713
ID: 200802-11

Synopsis

Multiple vulnerabilities have been found in Asterisk.

Background

Asterisk is an open source telephony engine and tool kit.

Affected Packages

Package: net-misc/asterisk
Vulnerable: < 1.2.21.1-r1
Unaffected: >= 1.2.17-r1 < 1.2.18
Unaffected: >= 1.2.21.1-r1
Architectures: All supported architectures


Description

Multiple vulnerabilities have been found in Asterisk:
  • Russel Bryant reported a stack buffer overflow in the IAX2 channel driver (chan_iax2) when bridging calls between chan_iax2 and any channel driver that uses RTP for media (CVE-2007-3762).
  • Chris Clark and Zane Lackey (iSEC Partners) reported a NULL pointer dereference in the IAX2 channel driver (chan_iax2) (CVE-2007-3763).
  • Will Drewry (Google Security) reported a vulnerability in the Skinny channel driver (chan_skinny), resulting in an overly large memcpy (CVE-2007-3764).
  • Will Drewry (Google Security) reported a vulnerability in the IAX2 channel driver (chan_iax2), that does not correctly handle unauthenticated transactions using a 3-way handshake (CVE-2007-4103).


Impact

By sending a long voice or video RTP frame, a remote attacker could possibly execute arbitrary code on the target machine. Sending specially crafted LAGRQ or LAGRP frames containing information elements of IAX frames, or a certain data length value in a crafted packet, or performing a flood of calls not completing a 3-way handshake, could result in a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.2.17-r1"


References

CVE-2007-3762
CVE-2007-3763
CVE-2007-3764
CVE-2007-4103
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum