Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200802-03 ] Horde IMP: Security bypass
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1582

PostPosted: Mon Feb 11, 2008 11:26 pm    Post subject: [ GLSA 200802-03 ] Horde IMP: Security bypass Reply with quote

Gentoo Linux Security Advisory

Title: Horde IMP: Security bypass (GLSA 200802-03)
Severity: normal
Exploitable: remote
Date: February 11, 2008
Bug(s): #205377
ID: 200802-03

Synopsis

Insufficient checks in Horde may allow a remote attacker to bypass security restrictions.

Background

Horde IMP provides a web-based access to IMAP and POP3 mailboxes.

Affected Packages

Package: www-apps/horde-imp
Vulnerable: < 4.1.6
Unaffected: >= 4.1.6
Architectures: All supported architectures


Description

Ulf Harnhammar, Secunia Research discovered that the "frame" and "frameset" HTML tags are not properly filtered out. He also reported that certain HTTP requests are executed without being checked.

Impact

A remote attacker could entice a user to open a specially crafted HTML e-mail, possibly resulting in the deletion of arbitrary e-mail messages.

Workaround

There is no known workaround at this time.

Resolution

All Horde IMP users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/horde-imp-4.1.6"


References

CVE-2007-6018
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum