Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
local.conf no longer works [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Mon Feb 04, 2008 12:23 am    Post subject: local.conf no longer works [SOLVED] Reply with quote

After the recent upgrade & etc-update (I forgot which one caused the problem, maybe it's gtk or pango), my local.conf no longer works, especially the command that I used to substitute Courier & Courier New with DejaVu Sans Mono (Courier & Courier New hurt my eyes.)
Code:
        <match target="pattern" name="family">
                <test name="family" qual="any">
                        <string>Courier</string>
                </test>
                <edit name="family" mode="assign">
                        <string>DejaVu Sans Mono</string>
                </edit>
        </match>

        <match target="pattern" name="family">
                <test name="family" qual="any">
                        <string>Courier New</string>
                </test>
                <edit name="family" mode="assign">
                        <string>DejaVu Sans Mono</string>
                </edit>
        </match>

Any idea how to solve this?

The local.conf is enabled, btw.
Code:
eselect fontconfig list
Available fontconfig .conf files ( * is enabled ):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-sub-pixel-bgr.conf
  [4]   10-sub-pixel-rgb.conf
  [5]   10-sub-pixel-vbgr.conf
  [6]   10-sub-pixel-vrgb.conf
  [7]   10-unhinted.conf
  [8]   20-fix-globaladvance.conf *
  [9]   20-unhint-small-vera.conf *
  [10]  25-unhint-nonlatin.conf
  [11]  30-metric-aliases.conf *
  [12]  30-urw-aliases.conf *
  [13]  40-nonlatin.conf *
  [14]  45-latin.conf *
  [15]  49-sansserif.conf *
  [16]  50-user.conf *
  [17]  51-local.conf *
  [18]  59-dejavu.conf
  [19]  60-latin.conf *
  [20]  65-fonts-persian.conf *
  [21]  65-nonlatin.conf *
  [22]  69-unifont.conf *
  [23]  70-no-bitmaps.conf
  [24]  70-yes-bitmaps.conf
  [25]  80-delicious.conf *
  [26]  90-synthetic.conf *

Update: Solved by downgrading to the previous version of fontconfig.
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI


Last edited by pandaxiongmao on Thu Mar 13, 2008 12:27 am; edited 2 times in total
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Wed Feb 06, 2008 3:47 pm    Post subject: Reply with quote

Bump. This is weird. Is local.conf finally getting replaced or what?

Strange, it works with Opera, but Firefox seems to ignore it. I'm going to recompile Firefox to see whether it's true or not.

Update: Recompiling Firefox didn't solve the problem.

I found out that the problem only applies to 64-bit version of Firefox.
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Fri Feb 08, 2008 5:14 am    Post subject: Reply with quote

Can anyone help?
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Thu Feb 14, 2008 8:48 am    Post subject: Reply with quote

Bump.
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
Xerionn
n00b
n00b


Joined: 16 Apr 2007
Posts: 68

PostPosted: Thu Feb 14, 2008 12:22 pm    Post subject: Reply with quote

Firefox has the option to allow pages to use their own selected fonts...
Maybe you have this enabled ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum