Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200801-18 ] Kazehakase: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1581

PostPosted: Wed Jan 30, 2008 11:26 pm    Post subject: [ GLSA 200801-18 ] Kazehakase: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Kazehakase: Multiple vulnerabilities (GLSA 200801-18)
Severity: normal
Exploitable: remote
Date: January 30, 2008
Bug(s): #198983
ID: 200801-18

Synopsis


Multiple vulnerabilities in Kazehakase could result in the execution of
arbitrary code.


Background


Kazehakase is a web browser based on the Gecko engine.


Affected Packages

Package: www-client/kazehakase
Vulnerable: < 0.5.0
Unaffected: >= 0.5.0
Architectures: All supported architectures


Description


Kazehakase includes a copy of PCRE which is vulnerable to multiple
buffer overflows and memory corruptions vulnerabilities (GLSA
200711-30).


Impact


A remote attacker could entice a user to open specially crafted input
(e.g bookmarks) with Kazehakase, which could possibly lead to the
execution of arbitrary code, a Denial of Service or the disclosure of
sensitive information.


Workaround


There is no known workaround at this time.


Resolution


All Kazehakase users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=www-client/kazehakase-0.5.0"


References

GLSA-200711-30


Last edited by GLSA on Sun Jul 07, 2013 4:26 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum