Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200801-15 ] PostgreSQL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Tue Jan 29, 2008 10:26 am    Post subject: [ GLSA 200801-15 ] PostgreSQL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Multiple vulnerabilities (GLSA 200801-15)
Severity: high
Exploitable: remote
Date: January 29, 2008
Bug(s): #204760
ID: 200801-15

Synopsis


PostgreSQL contains multiple vulnerabilities that could result in privilege
escalation or a Denial of Service.


Background


PostgreSQL is an open source object-relational database management
system.


Affected Packages

Package: dev-db/postgresql
Vulnerable: < 8.0.15
Unaffected: >= 8.0.15
Unaffected: >= 7.4.19 < 7.4.20
Unaffected: >= 7.3.21 < 7.3.22
Architectures: All supported architectures


Description


If using the "expression indexes" feature, PostgreSQL executes index
functions as the superuser during VACUUM and ANALYZE instead of the
table owner, and allows SET ROLE and SET SESSION AUTHORIZATION in the
index functions (CVE-2007-6600). Additionally, several errors involving
regular expressions were found (CVE-2007-4769, CVE-2007-4772,
CVE-2007-6067). Eventually, a privilege escalation vulnerability via
unspecified vectors in the DBLink module was reported (CVE-2007-6601).
This vulnerability is exploitable when local trust or ident
authentication is used, and is due to an incomplete fix of
CVE-2007-3278.


Impact


A remote authenticated attacker could send specially crafted queries
containing complex regular expressions to the server that could result
in a Denial of Service by a server crash (CVE-2007-4769), an infinite
loop (CVE-2007-4772) or a memory exhaustion (CVE-2007-6067). The two
other vulnerabilities can be exploited to gain additional privileges.


Workaround


There is no known workaround for all these issues at this time.


Resolution


All PostgreSQL users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose "dev-db/postgresql"


References

CVE-2007-3278
CVE-2007-4769
CVE-2007-4772
CVE-2007-6067
CVE-2007-6600
CVE-2007-6601


Last edited by GLSA on Mon Dec 31, 2012 4:25 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum