Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NVidia can't calculate kernel
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 2:55 am    Post subject: NVidia can't calculate kernel Reply with quote

I have seen other posts with similar problems, but I am using linux-2.6.22-gentoo-r8 which I have been using for some time now. I have a .config file, I don't have anything referencing KBUILD_OUTPUT (don't even know what it is) . So far, none of the posts I have seen tell how to fix this when everything is configured correctly. Any ideas? Just tell me what info I need to post and I will. Right now, my system is pretty much messed up. Thanks.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 2:57 am    Post subject: Reply with quote

Oh - lm_sensors is doing the same thing. I think something may be broken, but I don't know what.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Wed Jan 30, 2008 3:06 am    Post subject: Reply with quote

How about posting the actual error message? ;)

Include your "emerge --info" output as well as the exact commands you ran when you received the error(s).
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 3:10 am    Post subject: Reply with quote

Ok - the error message is:
Code:

 * Messages for package x11-drivers/nvidia-drivers-169.09:

 * Could not find a Makefile in the kernel source directory.
 * Please ensure that /usr/src/linux points to a complete set of Linux sources
 *
 * ERROR: x11-drivers/nvidia-drivers-169.09 failed.
 * Call stack:
 *                      ebuild.sh, line 1717:  Called dyn_setup
 *                      ebuild.sh, line  768:  Called qa_call 'pkg_setup'
 *                      ebuild.sh, line   44:  Called pkg_setup
 *   nvidia-drivers-169.09.ebuild, line  122:  Called linux-mod_pkg_setup
 *               linux-mod.eclass, line  465:  Called linux-info_pkg_setup
 *              linux-info.eclass, line  595:  Called die
 * The specific snippet of code:
 *      get_version || die "Unable to calculate Linux Kernel version"
 *  The die message:
 *   Unable to calculate Linux Kernel version
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-169.09/temp/build.log'.


My emerge info is:
Code:

Krypton src # emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.22-gentoo-r8 i686)
=================================================================
System uname: 2.6.22-gentoo-r8 i686 Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz
Timestamp of tree: Tue, 29 Jan 2008 23:30:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r7, 2.5.1-r4
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j3"
PKGDIR="/spare1/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/xeffects /usr/local/portage-unofficial"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa arts avahi bash-completion berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo exif fam fbcon firefox flac fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde kerberos ldap lm_sensors mad midi mikmod mng mono mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode vorbis win32codecs x86 xml xorg xv xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Also - for grins :)

Code:

Krypton src # ls -l /usr/src/
total 12
lrwxrwxrwx  1 root root   22 Jan 29 19:47 linux -> linux-2.6.22-gentoo-r8
drwxr-xr-x 20 root root 4096 Jan 29 19:39 linux-2.6.22-gentoo-r8
drwxr-xr-x 19 root root 4096 Oct 31 00:47 linux-2.6.22-gentoo-r9
drwxr-xr-x 19 root root 4096 Jan 29 19:47 linux-2.6.23-gentoo-r6


Thanks!!!

I have looked and seen similar problems, but they all used xen drivers or didn't configure the kernel. I have both right I think.
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 816
Location: Massachusetts USA

PostPosted: Wed Jan 30, 2008 4:52 am    Post subject: Reply with quote

The file it is looking for is /usr/src/linux/Makefile If you did an emerge --depclean it would have deleted the file.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 5:19 am    Post subject: Reply with quote

The Makefile is there - I tried a make menuconfig and it returned the following:

Code:

Krypton linux # make menuconfig
make -C /usr/src/linux-2.6.23-gentoo-r6 O=/usr/src/linux-2.6.22-gentoo-r8 menuconfig
  GEN     /usr/src/linux-2.6.22-gentoo-r8/Makefile
  HOSTCC  scripts/kconfig/zconf.tab.o
scripts/kconfig/zconf.tab.c: In function 'zconfparse':
scripts/kconfig/zconf.tab.c:1725: error: 'struct symbol' has no member named 'help'
scripts/kconfig/zconf.tab.c: In function 'print_symbol':
scripts/kconfig/zconf.tab.c:2283: error: 'struct symbol' has no member named 'help'
scripts/kconfig/zconf.tab.c:2284: error: 'struct symbol' has no member named 'help'
scripts/kconfig/zconf.tab.c:2285: error: 'struct symbol' has no member named 'help'
scripts/kconfig/zconf.tab.c:2286: error: 'struct symbol' has no member named 'help'
scripts/kconfig/zconf.tab.c:2287: error: 'struct symbol' has no member named 'help'
make[3]: *** [scripts/kconfig/zconf.tab.o] Error 1
make[2]: *** [menuconfig] Error 2
make[1]: *** [menuconfig] Error 2
make: *** [menuconfig] Error 2


Now I am really perplexed - I think I may just have to compile a new kernel and try again...
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 5:27 am    Post subject: Reply with quote

Oh - by that I mean upgrade my kernel....
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 816
Location: Massachusetts USA

PostPosted: Wed Jan 30, 2008 5:46 am    Post subject: Reply with quote

Quote:
Krypton linux # make menuconfig
make -C /usr/src/linux-2.6.23-gentoo-r6 O=/usr/src/linux-2.6.22-gentoo-r8 menuconfig
I'm perplexed about why the makefile is using the directory /usr/src/linux-2.6.23-gentoo-r6 to build linux-2.6.22-gentoo-r8.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Wed Jan 30, 2008 6:14 am    Post subject: Reply with quote

jburns wrote:
Quote:
Krypton linux # make menuconfig
make -C /usr/src/linux-2.6.23-gentoo-r6 O=/usr/src/linux-2.6.22-gentoo-r8 menuconfig
I'm perplexed about why the makefile is using the directory /usr/src/linux-2.6.23-gentoo-r6 to build linux-2.6.22-gentoo-r8.

That is a good one... maybe it is because he is running the older kernel, but his /usr/src/linux symlink is pointing to the newer one? It shouldn't mess up like that though. I'm sure that I did the exact same thing when I upgraded from *-r6 to *-r8. Weird.

Edit: or maybe I built the new kernel before I updated the symlink? I'm not sure now.
Back to top
View user's profile Send private message
tenspd137
Guru
Guru


Joined: 22 Aug 2006
Posts: 370

PostPosted: Wed Jan 30, 2008 10:22 am    Post subject: Reply with quote

yabbadabbadont wrote:

Quote:

jburns wrote:
Quote:
Krypton linux # make menuconfig
make -C /usr/src/linux-2.6.23-gentoo-r6 O=/usr/src/linux-2.6.22-gentoo-r8 menuconfig
I'm perplexed about why the makefile is using the directory /usr/src/linux-2.6.23-gentoo-r6 to build linux-2.6.22-gentoo-r8.

That is a good one... maybe it is because he is running the older kernel, but his /usr/src/linux symlink is pointing to the newer one? It shouldn't mess up like that though. I'm sure that I did the exact same thing when I upgraded from *-r6 to *-r8. Weird.

Edit: or maybe I built the new kernel before I updated the symlink? I'm not sure now.


I did not see that. I tried using eselect to point to linux-2.6.22-gentoo-r9 and linux-2.6.23-gentoo-r6. Ran make menuconfig in both directories, worked fine there. Unfortunatley, I am going out of town, so I am just going to shut my computer down at home (currently logging in over ssh from my laptop at GF's house) and I will try to upgrade my kernel and the whole nine yards when I get back. I'll post my results and see if that overcomes my initial problem of not being able to emerge nvidia-drivers or lm_sensors. Thanks for all the input so far! Otherwise, I'll keep trying to find a solution working with people here.

THANKS AGAIN!! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum