Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200801-14 ] Blam: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1547

PostPosted: Sun Jan 27, 2008 8:26 pm    Post subject: [ GLSA 200801-14 ] Blam: User-assisted execution of arbitrar Reply with quote

Gentoo Linux Security Advisory

Title: Blam: User-assisted execution of arbitrary code (GLSA 200801-14)
Severity: normal
Exploitable: local
Date: January 27, 2008
Bug(s): #199841
ID: 200801-14

Synopsis

Blam doesn't properly handle environment variables, potentially allowing a local attacker to execute arbitrary code.

Background

Blam is an RSS and Atom feed reader for GNOME written in C#.

Affected Packages

Package: net-news/blam
Vulnerable: < 1.8.4
Unaffected: >= 1.8.4
Architectures: All supported architectures


Description

The "/usr/bin/blam" script sets the "LD_LIBRARY_PATH" environment variable incorrectly, which might result in the current working directory (.) being included when searching for dynamically linked libraries of the Mono Runtime application.

Impact

A local attacker could entice a user to run Blam in a directory containing a specially crafted library file which could result in the execution of arbitrary code with the privileges of the user running Blam.

Workaround

Do not run Blam from an untrusted working directory.

Resolution

All Blam users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-news/blam-1.8.4"


References

CVE-2005-4790
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum