Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200801-08 ] libcdio: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1569

PostPosted: Sun Jan 20, 2008 2:26 am    Post subject: [ GLSA 200801-08 ] libcdio: User-assisted execution of arbit Reply with quote

Gentoo Linux Security Advisory

Title: libcdio: User-assisted execution of arbitrary code (GLSA 200801-08)
Severity: normal
Exploitable: remote
Date: January 20, 2008
Bug(s): #203777
ID: 200801-08

Synopsis


A buffer overflow vulnerability has been discovered in libcdio.


Background


libcdio is a library for accessing CD-ROM and CD images.


Affected Packages

Package: dev-libs/libcdio
Vulnerable: < 0.78.2-r4
Unaffected: >= 0.78.2-r4
Architectures: All supported architectures


Description


Devon Miller reported a boundary error in the "print_iso9660_recurse()"
function in files cd-info.c and iso-info.c when processing long
filenames within Joliet images.


Impact


A remote attacker could entice a user to open a specially crafted ISO
image in the cd-info and iso-info applications, resulting in the
execution of arbitrary code with the privileges of the user running the
application. Applications linking against shared libraries of libcdio
are not affected.


Workaround


There is no known workaround at this time.


Resolution


All libcdio users should upgrade to the latest version:
Code:
# emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/libcdio-0.78.2-r4"


References

CVE-2007-6613


Last edited by GLSA on Thu Jun 12, 2014 4:26 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum