Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage broken(?): hundreds of eclass errors!!
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Tue Jul 01, 2003 7:50 am    Post subject: Reply with quote

Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge rsync
seems to work ... for now - till it syncs with the others?
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
Youda
n00b
n00b


Joined: 06 Aug 2002
Posts: 35
Location: Jönköping, Sweden

PostPosted: Tue Jul 01, 2003 7:52 am    Post subject: YES Reply with quote

It worked!!

Thanks m8!

;)
_________________
Carpe Diem
Back to top
View user's profile Send private message
gutano
n00b
n00b


Joined: 17 Jun 2003
Posts: 17
Location: St. Paul, Minnesota

PostPosted: Tue Jul 01, 2003 7:52 am    Post subject: Reply with quote

Talk in the irc about a Dev accidentaly deleting the root portage, or something to that effect. Should be fixed already, however may take a little while to propogate to other mirrors.
Back to top
View user's profile Send private message
madchaz
l33t
l33t


Joined: 01 Jul 2003
Posts: 989
Location: Quebec, Canada

PostPosted: Tue Jul 01, 2003 7:53 am    Post subject: Reply with quote

I can confirm this as to be something bad with the mirrors/the portage tree. I just finished installing a brand spanking new gentoo to test it out and I get this problem. Basicaly, I'm not even done installing yet, lol

I tried to install xfree and ran into this.

I had succesfully gone from a stage one packadge 2 days ago (2003-06-29) so it must not have been broken for very long.

Sucks, I'm just trying out gentoo and already geting in on a major issue ;-)

well, at least now I know it's not MY problem, lol. gentoo still looks promessing however. first time I try it. second linux distro I try. will be a welcome update from my mandrake 8.2 when I can get it working

and don't tell me I shouldn't install it if I don't know linux in and out, I like having to work like nuts to get something working. makes me happy when I finaly figure it out, lol
_________________
Someone asked me once if I suffered from mental illness. I told him I enjoyed every second of it.
www.madchaz.com A small candle of a website. As my lab specs on it.
Back to top
View user's profile Send private message
Niek
Apprentice
Apprentice


Joined: 14 May 2002
Posts: 236
Location: Houten, The Netherlands

PostPosted: Tue Jul 01, 2003 7:56 am    Post subject: Reply with quote

Seems like it's fixed now
Code:
< trevorj> (..) its fixed, but the mirrors need to catch up. ~20 minutes.

_________________
Bezoek ook eens de Nederlandstalige Gentoo IRC channel op irc.freenode.net - #gentoo-nl
Back to top
View user's profile Send private message
swingarm
l33t
l33t


Joined: 08 Jun 2002
Posts: 627
Location: Northern Colorado

PostPosted: Tue Jul 01, 2003 7:56 am    Post subject: Reply with quote

Niek wrote:
Temp solution:
Add SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" to your make.conf



Ok, it looks like that worked but I've tried emerging some packages, here is what I got when I tried upgrading KArchiver:
Code:

-01:51:18--  http://gentoo.mirrors.pair.com//distfiles/karchiver-3.0.3.tar.bz2
           => `/usr/portage/distfiles/karchiver-3.0.3.tar.bz2'
Resolving gentoo.mirrors.pair.com... done.
Connecting to gentoo.mirrors.pair.com[216.92.2.140]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 858,956 [application/x-tar]

100%[====================================>] 858,956      277.39K/s    ETA 00:00

01:51:21 (277.39 KB/s) - `/usr/portage/distfiles/karchiver-3.0.3.tar.bz2' saved [858956/858956]

>>> md5 src_uri ;-) karchiver-3.0.3.tar.bz2
>>> Unpacking source...
>>> Unpacking karchiver-3.0.3.tar.bz2 to /var/tmp/portage/karchiver-3.0.3/work
tar: This does not look like a tar archive
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers
tar: Error exit delayed from previous errors

bzip2: I/O or other error, bailing out.  Possible reason follows.
bzip2: Broken pipe
        Input file = /usr/portage/distfiles/karchiver-3.0.3.tar.bz2, output file = (stdout)

!!! ERROR: app-arch/karchiver-3.0.3 failed.
!!! Function unpack, Line 294, Exitcode 2
!!! failure unpacking karchiver-3.0.3.tar.bz2


I got a similar error while trying to emerge mplayer although strangely enough superadduser emerged ok, can't tell if this is related to this problem.
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Tue Jul 01, 2003 7:59 am    Post subject: Reply with quote

... delted the root of portage tree .. well, at least he didn't play around scratching on the surface ;)
fine to see, that things get fixed quickly around gentoo :)

madchaz wrote:

Sucks, I'm just trying out gentoo and already geting in on a major issue ;-)


and don't tell me I shouldn't install it if I don't know linux in and out, I like having to work like nuts to get something working. makes me happy when I finaly figure it out, lol


Hey, no need to know linux in and out - just know murphy, that's all ;) Since gentoo is bleeding edge, things happen time and again, but usually just single packages and the fixes are faster than with any other distro.

* ElCondor relieved pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
Niek
Apprentice
Apprentice


Joined: 14 May 2002
Posts: 236
Location: Houten, The Netherlands

PostPosted: Tue Jul 01, 2003 8:02 am    Post subject: Reply with quote

swingarm wrote:
Niek wrote:
Temp solution:
Add SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" to your make.conf



Ok, it looks like that worked but I've tried emerging some packages, here is what I got when I tried upgrading KArchiver:
[snip]

I got a similar error while trying to emerge mplayer although strangely enough superadduser emerged ok, can't tell if this is related to this problem.
Had the same problem. Perhaps you are using portage 2.0.48-r2? Seems like -r2 has a problem unpacking tarballs. Here's how I fixed it (as root):
Code:
cd /usr/portage/sys-apps/portage/files/
tar xjpUvf portage-rescue-2.0.47-r10-x86.tbz2 -C /

_________________
Bezoek ook eens de Nederlandstalige Gentoo IRC channel op irc.freenode.net - #gentoo-nl
Back to top
View user's profile Send private message
meulie
l33t
l33t


Joined: 17 Jun 2003
Posts: 845
Location: a Dutchman living in Norway

PostPosted: Tue Jul 01, 2003 8:05 am    Post subject: Reply with quote

Hi everyone!

Yup, got the same problem...

Since it's mentioned in this thread that the problem is fixed but that syncing might take a while, should I just keep on trying with 'emerge sync' until I hit a server that is OK again, or is there a way to force it to use a fixed server? If so, which one(s) are fixed by now?


Greetz,
Evert
Back to top
View user's profile Send private message
Niek
Apprentice
Apprentice


Joined: 14 May 2002
Posts: 236
Location: Houten, The Netherlands

PostPosted: Tue Jul 01, 2003 8:07 am    Post subject: Reply with quote

meulie wrote:
Hi everyone!

Yup, got the same problem...

Since it's mentioned in this thread that the problem is fixed but that syncing might take a while, should I just keep on trying with 'emerge sync' until I hit a server that is OK again, or is there a way to force it to use a fixed server? If so, which one(s) are fixed by now?


Greetz,
Evert
Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge sync

_________________
Bezoek ook eens de Nederlandstalige Gentoo IRC channel op irc.freenode.net - #gentoo-nl
Back to top
View user's profile Send private message
Thyraz
n00b
n00b


Joined: 17 Jun 2003
Posts: 38

PostPosted: Tue Jul 01, 2003 8:12 am    Post subject: Reply with quote

Sometimes reading the whole Thread helps ;)

Quote:

Temp solution:
Add SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" to your make.conf
Back to top
View user's profile Send private message
mona-
n00b
n00b


Joined: 18 Dec 2002
Posts: 40

PostPosted: Tue Jul 01, 2003 8:20 am    Post subject: Reply with quote

I had same problem that "emerge sync" error
and looling for solution.
Nick wrote:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge sync

Thanks, it is very helpful for me. :o
Back to top
View user's profile Send private message
cederberg
Guru
Guru


Joined: 23 Jan 2003
Posts: 349
Location: Stockholm / Sweden

PostPosted: Tue Jul 01, 2003 8:31 am    Post subject: Reply with quote

Niek wrote:
Seems like it's fixed now
Code:
< trevorj> (..) its fixed, but the mirrors need to catch up. ~20 minutes.

I just used the rsync.belnet.be mirror and two other european ones, and neither contains a fix for this problem yet. I'd say the potential delay here is more like ~6 hours (if I recall the portage mirroring standards correctly), which means that this will probably hurt a lot of people before it is over...

Maybe the Zynot suggestion of having various portage trees (and especially at least one "incubation" tree) is not such a bad idea for those of us who tend to prefer stability. Errors like these must be caught somewhere before going out to the whole community (and then being impossible to rectify quickly). IIRC this is the second similar incident during the last couple of months...
Back to top
View user's profile Send private message
Config
Retired Dev
Retired Dev


Joined: 25 May 2003
Posts: 187
Location: Zurich, Switzerland

PostPosted: Tue Jul 01, 2003 8:38 am    Post subject: Reply with quote

You're right. Same happened here, at 10:30am (Switzerland) - so I guess it all needs some time.... I also use an european mirror
_________________
Config - caught by a chronic disease called tuxmania....
Back to top
View user's profile Send private message
tebers
Tux's lil' helper
Tux's lil' helper


Joined: 24 Apr 2002
Posts: 115
Location: Germany, Kirchheim near Munich

PostPosted: Tue Jul 01, 2003 8:40 am    Post subject: Reply with quote

after all, i get now this :-(((
I cannot update the system...

>>> md5 src_uri ;-) glibc-2.2.5.tar.bz2
>>> md5 src_uri ;-) glibc-linuxthreads-2.2.5.tar.bz2
>>> Unpacking source...
>>> Unpacking glibc-2.2.5.tar.bz2 to /var/tmp/portage/glibc-2.2.5-r8/work
tar: This does not look like a tar archive
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers
tar: Error exit delayed from previous errors

bzip2: I/O or other error, bailing out. Possible reason follows.
bzip2: Broken pipe
Input file = /usr/portage/distfiles/glibc-2.2.5.tar.bz2, output file = (stdout)

!!! ERROR: sys-libs/glibc-2.2.5-r8 failed.
!!! Function unpack, Line 39, Exitcode 2
!!! failure unpacking glibc-2.2.5.tar.bz2
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Tue Jul 01, 2003 8:47 am    Post subject: Reply with quote

tebers: do like niek suggested above:
Code:
cd /usr/portage/sys-apps/portage/files/
tar xjpUvf portage-rescue-2.0.47-r10-x86.tbz2 -C /

ignore the error at the end, update portage to 2.0.48-r1 and everything (as far as I can tell) works
[EDIT] don't forget to rsync against the (by now only known workiing) server
Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge sync

_________________
Here I am the victim of my own choices and I'm just starting!


Last edited by ElCondor on Tue Jul 01, 2003 8:54 am; edited 1 time in total
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Tue Jul 01, 2003 8:49 am    Post subject: Reply with quote

Just used an european server and problem continues...


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
qnx
l33t
l33t


Joined: 25 Jun 2002
Posts: 638
Location: Göteborg, Sweden

PostPosted: Tue Jul 01, 2003 8:52 am    Post subject: Reply with quote

Same here.. Just that I synced against some of US mirrors. Problem's still there, and it's 10.52am here (Sweden, GTM+1).
_________________
Registred Linux user #191143!
Abit NF7-S rev. 2.00 (BIOS v. 2.7)
AMD AthlonXP 2500+ (Barton)
PATA Seagate ST3120022A
SATA Seagate ST3200822AS & Silicon Image 3112 chipset
Gentoo Linux :)
Back to top
View user's profile Send private message
blk_jack
Apprentice
Apprentice


Joined: 10 May 2002
Posts: 298
Location: Toronto

PostPosted: Tue Jul 01, 2003 8:55 am    Post subject: Reply with quote

Niek wrote:
Had the same problem. Perhaps you are using portage 2.0.48-r2? Seems like -r2 has a problem unpacking tarballs. Here's how I fixed it (as root):
Code:
cd /usr/portage/sys-apps/portage/files/
tar xjpUvf portage-rescue-2.0.47-r10-x86.tbz2 -C /


JESUS CHRIST. DO *NOT* DO THIS UNLESS YOU BACK UP /ETC/MAKE.* FIRST. IT *WILL* OVERWRITE DEFAULT SETTINGS.

Good god man, don't just blindly tell people to overwrite their fucking /etc directories.
Back to top
View user's profile Send private message
PhanLord
Apprentice
Apprentice


Joined: 19 Nov 2002
Posts: 175

PostPosted: Tue Jul 01, 2003 8:58 am    Post subject: trying to downgrade to 2.0.48-r1 Reply with quote

i have rsynced with rsync16 after i emerged portage 2.0.48-r2 so
portage now wants to downgrade itself however this is the error im getting

emerge portage-2.0.48-r1.ebuild
Calculating dependencies \!!! aux_get(): ebuild for '/portage-2.0.48-r1' does not exist at:
!!! /usr/portage//portage/portage-2.0.48-r1.ebuild
emerge: create(): aux_get() error on /portage-2.0.48-r1; aborting...


anything new regarding all these problems
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Tue Jul 01, 2003 9:03 am    Post subject: Reply with quote

here's a try(!) of a oneinall copy-paste solution for those who got stuck with 2.0.48-r2 (Assuming that you have not modified anything exept make.conf)
Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge sync
grep -v ^# /etc/make.conf > /etc/make.conf.save
cd /usr/portage/sys-apps/portage/files/
tar xjpUvf portage-rescue-2.0.47-r10-x86.tbz2 -C /
cat /etc/make.conf.save >> /etc/make.conf
emerge -u portage
etc-update

update your make.conf to the new version, then again
Code:
cat /etc/make.conf.save >> /etc/make.conf

Anything missing?

(Thanks to blk_jack! I forgot to post the backup of make.conf before)
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
axiom255
n00b
n00b


Joined: 21 Mar 2003
Posts: 41

PostPosted: Tue Jul 01, 2003 9:07 am    Post subject: Reply with quote

Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge rsync


Seems to work for me (as of 09:18 GMT).
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Tue Jul 01, 2003 9:08 am    Post subject: Reply with quote

Well I just need an US updated rsync and mirror to use while the Europeans servers aren't synched.

Anyone please?


_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
blk_jack
Apprentice
Apprentice


Joined: 10 May 2002
Posts: 298
Location: Toronto

PostPosted: Tue Jul 01, 2003 9:11 am    Post subject: Reply with quote

ElCondor wrote:
here's a try(!) of a oneinall copy-paste solution for those who got stuck with 2.0.48-r2 (Assuming that you have not modified anything exept make.conf)
Code:
SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage" emerge sync
grep -v ^# /etc/make.conf > /etc/make.conf.save
cd /usr/portage/sys-apps/portage/files/
tar xjpUvf portage-rescue-2.0.47-r10-x86.tbz2 -C /
cat /etc/make.conf.save >> /etc/make.conf
emerge -u portage
etc-update

update your make.conf to the new version, then again
Code:
cat /etc/make.conf.save >> /etc/make.conf

Anything missing?

(Thanks to blk_jack, i forgot to post the backup of make.conf before)


If, by chance, you've already uncompressed the rescue package of portage and you're not sure what flags you used in USE="" or what compile flags you'd had (You might've gone to greath lengths to create a nice custom CFLAG variable), you can do this to figure them out again.

Code:
cd /var/tmp/portage
grep -ir "USE=" * | more


This will show you what USE flags were used on previous packages. Note that there are a lot of DEFAULT flags you do not want to include in make.conf, so the ones you added yourself should be at the end of the list that looks like:

USE='x86 oss 3dnow apm arts avi crypt cups encode gif
gpm jpeg kde libg++ libwww mikmod mmx mpeg ncurses nls pdflib png quicktime spe
ll truetype xml2 xmms xv zlib gtkhtml gdbm berkdb slang readline bonobo svga tcl
tk java guile mysql sdl tcpd pam ssl perl python esd imlib oggvorbis gnome gtk q
t motif opengl mozilla cdr ipv6 X gtk2'

Note the bold which are the flags I put in my make.conf file.
If you wanna find out what compiler settings you used just do:

Code:
cd /var/tmp/portage
grep -ir "$CFLAGS='" * | grep march | more
Back to top
View user's profile Send private message
dvink
n00b
n00b


Joined: 12 Apr 2003
Posts: 55

PostPosted: Tue Jul 01, 2003 9:16 am    Post subject: Almost reached out for the Jack Daniels Reply with quote

Code:

SYNC="rsync://rsync16.us.gentoo.org/gentoo-portage"


Cheers fellas, I thought that Portage left me for dead, but the above fixed the problem for now. I am not going to rsync for the moment until it has the all clear. I use the belnet server a lot. Anyway, can someone say in very clear terms what _users_ should do for the moment when they see the eclass errors?

Once again, cheers, blurb...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum