Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
x11-drivers/xf86-input-evdev-1.2.0 keyboard problem
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ham_se17
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2005
Posts: 131

PostPosted: Mon Jan 07, 2008 10:48 am    Post subject: x11-drivers/xf86-input-evdev-1.2.0 keyboard problem Reply with quote

After i upgraded to x11-drivers/xf86-input-evdev-1.2.0, my keyboard started to act wierd.
First it turned to "us" layout all the time. Then I reemerged xf86-input-keyboard, xorg-server and libxklavier and I can use the correct layout again. Now, the problem is, that the [SUper] (Windows key) is activated all the time.

xorg.conf
Code:
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "evdev"
    Option      "XkbRules"          "xorg"
    #Option      "XkbModel"          "pc105"
    Option      "XkbLayout"         "dk"
    Option      "XkbVariant"        "nodeadkeys"
EndSection


Xorg.0.log
Code:
(**) Keyboard0: always reports core events
(EE) Keyboard0: cannot open input pEvdev
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "Keyboard0"


I have tried to downgrade xf86-input-evdev to:
- x11-drivers/xf86-input-evdev-1.1.5-r1 and
- x11-drivers/xf86-input-evdev-1.1.5-r2

but X keeps crashing with these versions!

Any solutions?


Last edited by ham_se17 on Mon Jan 07, 2008 9:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
didumos
Guru
Guru


Joined: 19 Jan 2006
Posts: 322
Location: uk

PostPosted: Mon Jan 07, 2008 11:32 am    Post subject: Reply with quote

xf86-input-evdev-1.2.0 apparently needs a different X configuration than previous versions if you don't want to use the HAL backend - what fixed it it for me was adding a "Device" option, like so:
Code:
Section "InputDevice"
        Identifier      "Mouse1"
        Driver          "evdev"
        Option          "Device"        "/dev/input/event0"
        Option          "evBits"        "+1-2"
        Option          "keyBits"       "~272-287"
        Option          "relBits"       "~0-2 ~6 ~8"
EndSection

Section "InputDevice"
        Identifier      "Keyboard1"
        Driver          "evdev"
        Option          "Device"        "/dev/input/event1"
        Option          "evBits"        "+1"
        Option          "keyBits"       "~1-255 ~352-511"
        Option          "XkbLayout"     "gb"
EndSection

You can find out which device node to use by looking at the output of "cat /proc/bus/input/devices".
Back to top
View user's profile Send private message
ham_se17
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2005
Posts: 131

PostPosted: Mon Jan 07, 2008 1:13 pm    Post subject: Reply with quote

That did not help :(
I will try to downgrade some packages so I can revert to the working version
Back to top
View user's profile Send private message
ham_se17
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2005
Posts: 131

PostPosted: Mon Jan 07, 2008 2:52 pm    Post subject: Reply with quote

I masked these packages, and reemerged them, and everything works again :)

Code:
=sys-apps/hal-0.5.10
=app-misc/hal-info-20071011
=app-misc/hal-info-20071030
=x11-drivers/xf86-input-evdev-1.2.0
Back to top
View user's profile Send private message
JohnY
Apprentice
Apprentice


Joined: 26 Jul 2002
Posts: 284

PostPosted: Mon Jan 07, 2008 3:43 pm    Post subject: Reply with quote

I lost the scroll wheel function of my Logitech Marble Mouse (unrecognized model 109). When I masked the packages you listed things went back to normal. I had tried more than a dozen new mouse configs without success.

Masking these
Code:
=sys-apps/hal-0.5.10
=app-misc/hal-info-20071011
=app-misc/hal-info-20071030
=x11-drivers/xf86-input-evdev-1.2.0
'fixed' it, thanks....

JohnY
Back to top
View user's profile Send private message
GrayFox
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 183
Location: Germany

PostPosted: Mon Jan 07, 2008 4:53 pm    Post subject: Reply with quote

Hi,

Those things are really driving me crazy when using gentoo. I mean I was so happy when mounting cryped partition started working again with the new hal but after a reboot it shows it's real face... Why on earth is the kbd driver not working anymore? Ok I can of course use evdev BUT it effectively renders very important things unusable. for example I need to press enter after I authed with my fingerprint and most important Fn-F4 (suspend to ram) doesn't work at all!(just like most other acpi keybinds)
So my problem now is that gnome ALWAYS uses the evdev driver (a gconf entry called kbd.sysbackup is created on login) and refuses to use the kbd driver (have the xorg rules changed here too?).
Is downgrading here really the only option?
_________________
Random Stuff
Back to top
View user's profile Send private message
agnitio
Tux's lil' helper
Tux's lil' helper


Joined: 17 Apr 2004
Posts: 136

PostPosted: Mon Jan 07, 2008 7:01 pm    Post subject: Reply with quote

Why is this marked as solved?

I'm having this issue too but reverting to older versions hardly seems like a proper solution, please unmark this as solved and let's find a real solution.
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Mon Jan 07, 2008 8:42 pm    Post subject: Reply with quote

didumos wrote:
xf86-input-evdev-1.2.0 apparently needs a different X configuration than previous versions if you don't want to use the HAL backend - what fixed it it for me was adding a "Device" option, like so


Elaborate on "if you don't want to use the HAL backend".
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
didumos
Guru
Guru


Joined: 19 Jan 2006
Posts: 322
Location: uk

PostPosted: Mon Jan 07, 2008 9:24 pm    Post subject: Reply with quote

Lepaca Kliffoth wrote:
didumos wrote:
xf86-input-evdev-1.2.0 apparently needs a different X configuration than previous versions if you don't want to use the HAL backend - what fixed it it for me was adding a "Device" option, like so


Elaborate on "if you don't want to use the HAL backend".

Ok. Firstly, HAL refers to sys-apps/hal in portage, the Hardware Abstraction Layer daemon.

To the best of my knowledge, before the 1.2.0 release of the evdev driver it included code that scanned the devices on the system (i.e. /dev/input/event*) to figure out which one to use. This was apparently removed so that the driver could use the new HAL-based input device detection in the 1.4 xserver. But, of course, some people don't need/want HAL on their system and so the evdev-1.2.0 driver has no method by which to find out about which device to use in this case.

However, upstream says this is all just a matter of changing the configuration for the device in xorg.conf, but unfortunately the documentation hasn't been written explaining that and so (as I say in my original post) the only way I have got this evdev-1.2.0 driver working without a HAL-based xserver is by stating the device node that the driver should use in xorg.conf.
Back to top
View user's profile Send private message
ham_se17
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2005
Posts: 131

PostPosted: Mon Jan 07, 2008 9:26 pm    Post subject: Reply with quote

agnitio wrote:
Why is this marked as solved?

I'm having this issue too but reverting to older versions hardly seems like a proper solution, please unmark this as solved and let's find a real solution.

true, it was not properly solved, but it solved it for now.
I tried with a new configuration in my xorg, but i had no luck :( I'm awaiting some more docs for the new config
Back to top
View user's profile Send private message
Lithium07
n00b
n00b


Joined: 25 Aug 2006
Posts: 7

PostPosted: Mon Jan 07, 2008 9:27 pm    Post subject: Reply with quote

I got the same problem, my Cherry Keyboard and Mouse are not fully working and it is unusable. Downgrading fixed the keyboard problem, my mouse problem remained :evil:
Back to top
View user's profile Send private message
ham_se17
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2005
Posts: 131

PostPosted: Mon Jan 07, 2008 9:30 pm    Post subject: Reply with quote

my mouse problems was solved when i (for the second time) reemerged xf86-input-mouse, xf86-input-evdev (I use both) and finally xorg-server
Back to top
View user's profile Send private message
Krampi
n00b
n00b


Joined: 22 Oct 2006
Posts: 3

PostPosted: Mon Jan 07, 2008 10:35 pm    Post subject: Reply with quote

Temporary fix to get other layouts than "us":

Create /etc/hal/fdi/policy/x11-input.fdi
Write something like this to it:
Code:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
    </match>
  </device>
</deviceinfo>


See:
http://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg118695.html
http://www.mail-archive.com/debian-bugs-rc@lists.debian.org/msg118725.html
Back to top
View user's profile Send private message
AaronPPC
Guru
Guru


Joined: 29 May 2005
Posts: 521
Location: Tucson, AZ

PostPosted: Tue Jan 08, 2008 12:08 am    Post subject: Reply with quote

I have a story that might help. This thread actually help me solve two problems:
1. hal-0.5.10 killed my xorg. The only solution was to keep the new hal off my system.
2. Yesterday's evdev update killed my mouse evdev driver. The old driver worked.

After seeing this thread today I decided to install hal-0.5.10 and then reinstall everything that depends on it--which included xorg-server-1.4. That solved both of my problems. Maybe it'll help you.
_________________
--Aaron
Back to top
View user's profile Send private message
heedless
Tux's lil' helper
Tux's lil' helper


Joined: 26 May 2004
Posts: 86

PostPosted: Tue Jan 08, 2008 12:16 pm    Post subject: What solved it for me... Reply with quote

The only thing that solved it for me was adding:
Code:
>app-misc/hal-info-20070618
>=sys-apps/hal-0.5.10


to /etc/portage/package.mask

then remerging: emerge -1auv sys-apps/hal app-misc/hal-info

i'm using x11-drivers/xf86-input-evdev-1.2.0

and my relevant xorg.conf looks like:
Code:
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection


Hope this helps.


Last edited by heedless on Tue Jan 08, 2008 5:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
m3th0s
n00b
n00b


Joined: 29 Jun 2007
Posts: 6

PostPosted: Tue Jan 08, 2008 5:50 pm    Post subject: Reply with quote

hal is the problem, evdev-1.2.0 works fine
hal is also responsible for the weird keyboard thingy

and don't forge to run
Code:
/etc/init.d/hald restart

to make the old hal start (or restart your PC :) )
before reentering X
Back to top
View user's profile Send private message
advance38
n00b
n00b


Joined: 08 Jan 2008
Posts: 1
Location: Köln, Germany

PostPosted: Tue Jan 08, 2008 10:17 pm    Post subject: I've solved it with package upgrades Reply with quote

I'd encountered this problem, but I've solved it by upgrading relevant packages:

Code:

=hal-info-20071030
=hal-0.5.10
=xf86-input-evdev-1.2.0
=xorg-server-1.4.0.90
=xinit-1.0.5-r1 (USE="hal")


and I've also set XkbModel as "evdev" in /etc/X11/xorg.conf, and changed my keyboard configurations as well.
No package masking is needed in my opinion.
Detailed informations are on my blog.
_________________
--
http://dongsupark.de/
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1085

PostPosted: Wed Jan 09, 2008 7:42 pm    Post subject: Reply with quote

didumos wrote:
xf86-input-evdev-1.2.0 apparently needs a different X configuration than previous versions if you don't want to use the HAL backend - what fixed it it for me was adding a "Device" option...

Thanks. That worked for me, too.

EDIT 1 : I think it is due to my hal stopped working. When restarting hal, it complains about acpi and fails:
Code:

acpid: can't open /proc/acpi/event: No such file or directory

Probably it is not time to depreciate "Deprecated /proc/acpi/event support" in kernel options :)
EDIT 2 : Compiled kernel with "Deprecated /proc/acpi/event support" and the other option just next to it. Now hal restarts successfully. But I still have to add a "Device" option. At least it works fine.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
GrayFox
Apprentice
Apprentice


Joined: 24 Jan 2004
Posts: 183
Location: Germany

PostPosted: Thu Jan 10, 2008 2:41 pm    Post subject: Reply with quote

Ok just wanted to let you know in case this is useful to anyone:
I managed to get the keyboard to work following Krampi's advice on x11-input.fdi.
Additionally I set my keyboard driver to "kbd" and my keyboard model to "evdev"(who would've thought this works?!) in xorg.conf. After that I just reset my gnome configuration in gconf (desktop->peripeherals->keyboard->kbd or sth along those lines) and now everything is back to normal.
My Fn+F4 Suspend hotkey still doesn't work but that might be a hal<->acpi issue. I googled about that already but found nothing useful. At least my keyboard layout is back to normal again.
_________________
Random Stuff
Back to top
View user's profile Send private message
EzInKy
Veteran
Veteran


Joined: 11 Oct 2002
Posts: 1734
Location: Kentucky

PostPosted: Thu Jan 10, 2008 4:00 pm    Post subject: Reply with quote

I tried the other fixes but the only thing that worked for my Cherry Cymotion linux keyboard was to mask and downgrade hal. What I found strange though was that my Debian Sid partition has the same hal version installed but seems to have handled the upgrade seamlessly.
_________________
Time is what keeps everything from happening all at once.
Back to top
View user's profile Send private message
OnlyOne
n00b
n00b


Joined: 13 Jan 2007
Posts: 59

PostPosted: Thu Jan 10, 2008 8:18 pm    Post subject: Reply with quote

My case:
After update: ru layout doesn't work.
in us layout arrows and some buttons doesn't work,
enter hits randomly sometimes.

emerge -u all after emerge -u hal doesn't work.
x11-input.fdi havn't try, because even us keyboard layout wasn't working well.
mask all new hal hal-info evdev works fine!
Back to top
View user's profile Send private message
mathfeel
l33t
l33t


Joined: 03 Aug 2004
Posts: 698

PostPosted: Thu Jan 10, 2008 9:18 pm    Post subject: Reply with quote

My case, it 's not only happening to the keyboard, but the mouse (trackpoint) that previously worked fine:

Code:
(**) Option "CorePointer"
(**) TrackPoint: always reports core events
(EE) TrackPoint: cannot open input pEvdev
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "TrackPoint"
(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) TouchPad auto-dev sets device to /dev/input/event6
(**) Option "Device" "/dev/input/event6"
(**) Option "SHMConfig" "on"
(**) Option "LeftEdge" "1700"
(**) Option "RightEdge" "5300"
(**) Option "TopEdge" "1700"
(**) Option "BottomEdge" "4200"
(**) Option "FingerLow" "25"
(**) Option "FingerHigh" "30"
(**) Option "MaxTapTime" "180"
(**) Option "MaxTapMove" "220"
(**) Option "VertScrollDelta" "100"
(--) TouchPad touchpad found
(**) Option "SendCoreEvents"
(**) TouchPad: always reports core events
(**) Option "SendCoreEvents"
(**) Wireless Mouse: always reports core events
(EE) Wireless Mouse: cannot open input pEvdev
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "Wireless Mouse"
(**) Option "SendCoreEvents"
(**) AutoMouse: always reports core events
(EE) ioctl EVIOCGBIT 0 failed: Inappropriate ioctl for device
(EE) AutoMouse: cannot load bits
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "AutoMouse"
(**) Option "CoreKeyboard"
(**) Default Keyboard: always reports core events
(EE) Default Keyboard: cannot open input pEvdev
(II) UnloadModule: "evdev"
(EE) PreInit returned NULL for "Default Keyboard"
...


There are all these (EE) entry in the log, but my mouse and keyboard seems to work nonetheless.

Here are my relevant entries in xorg.conf:
Code:
Section "InputDevice"
  Identifier  "Default Keyboard"
  Driver      "evdev"
  #Driver      "keyboard"
  #Option           "AutoRepeat" "500 30"
  # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
  #Option      "Xleds" "1 2 3"
  Option      "XkbRules" "xorg"
  Option            "XkbModel" "evdev"
  Option            "XkbLayout" "us"
  #Option      "RightAlt" "Meta"
EndSection

Section "InputDevice"
  Identifier  "TrackPoint"
  Driver      "evdev"
  Option      "Name" "TPPS/2 IBM TrackPoint"
  Option      "Emulate3Buttons"
EndSection

Section "InputDevice"
  Identifier  "AutoMouse"
  Driver      "evdev"
  Option      "Device" "/dev/input/mice"
  Option      "evBits" "+1-2"
  Option      "keyBits" "~272-287"
  Option      "relBits" "~0-2 ~6 ~8"
EndSection

_________________
-----------------------------------------------------------
"In heaven all the interesting people are missing"
-- Friedrich Nietzsche
Back to top
View user's profile Send private message
pjelezov
n00b
n00b


Joined: 22 Oct 2006
Posts: 3

PostPosted: Thu Jan 10, 2008 10:20 pm    Post subject: Reply with quote

Thanks ham_se17,

The way you fixed your problem, worked for me too.
My problem was with the kkbswitch layouts. Instead of seeing the second language I use on my machine for few days I only got no flag icon, but a white square with number 2 in it and '<Unnamed>' aside. Even though the layouts switched the keyboard actually was typing only 'EN'. It took me a lot of time to reemerge the last things updated, but nothing helped.
Your proposal saved my day.

Here we go with some sys info:
- KDE 3.5.8
- Keyboard Switch (kkbswitch) 1.4.3
- System - Linux mobile 2.6.23-gentoo-r3 #1 SMP Mon Dec 3 22:14:49 EET 2007 i686 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz GenuineIntel GNU/Linux
- xorg.conf (as per keyboard settings) -
Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver    "kbd"
        Option    "AutoRepeat" "250 30"
        Option    "XkbModel" "hpxe3gf"
        Option    "XkbLayout" "us,bg"
        Option    "XkbVariant" ",bds"
        Option    "XkbOptions" "grp:alt_shift_toggle"
EndSection


My opinion is, that the problem is really in the 'hal*' and in the 'xf86-input-evdev'. Today I reemerged the x11-base/xorg-server and other suspicious packages too. Went trough the full emerge history for the last few days and nothing helped.
Code:

    Tue Jan  8 22:33:06 2008 >>> kde-misc/kkbswitch-1.4.3
     Wed Jan  9 13:27:17 2008 >>> x11-libs/qt-3.3.8-r4
     Wed Jan  9 13:49:48 2008 >>> kde-base/kdelibs-3.5.8-r2
     Wed Jan  9 13:50:54 2008 >>> kde-base/libkonq-3.5.8
     Wed Jan  9 13:54:18 2008 >>> kde-base/konqueror-3.5.8
     Wed Jan  9 13:58:53 2008 >>> kde-base/kicker-3.5.8
     Wed Jan  9 14:00:27 2008 >>> kde-base/kdesktop-3.5.8
     Wed Jan  9 16:21:32 2008 >>> kde-misc/kkbswitch-1.4.3
     Wed Jan  9 23:39:13 2008 >>> x11-libs/libxkbfile-1.0.4
     Wed Jan  9 23:39:31 2008 >>> x11-apps/setxkbmap-1.0.4
     Wed Jan  9 23:39:57 2008 >>> x11-apps/xkbcomp-1.0.3
     Wed Jan  9 23:40:29 2008 >>> x11-libs/libxkbui-1.0.2
     Wed Jan  9 23:43:31 2008 >>> kde-base/kxkb-3.5.8
     Thu Jan 10 12:57:33 2008 >>> media-fonts/font-adobe-100dpi-1.0.0
     Thu Jan 10 12:57:45 2008 >>> media-fonts/font-adobe-utopia-type1-1.0.1
     Thu Jan 10 12:59:24 2008 >>> app-doc/xorg-docs-1.4-r1
     Thu Jan 10 12:59:36 2008 >>> media-fonts/font-bh-type1-1.0.0
     Thu Jan 10 12:59:47 2008 >>> x11-misc/xkbd-0.8.12
     Thu Jan 10 13:00:05 2008 >>> x11-base/xorg-x11-7.3
     Thu Jan 10 13:11:22 2008 >>> x11-misc/xkeyboard-config-1.1
     Thu Jan 10 16:59:41 2008 >>> x11-base/xorg-server-1.4.0.90
     Thu Jan 10 17:04:26 2008 >>> x11-drivers/synaptics-0.14.6
     Thu Jan 10 17:04:39 2008 >>> x11-drivers/xf86-input-evdev-1.2.0
     Thu Jan 10 17:04:52 2008 >>> x11-drivers/xf86-input-keyboard-1.2.2
     Thu Jan 10 17:05:03 2008 >>> x11-drivers/xf86-input-mouse-1.2.3
     Thu Jan 10 17:05:16 2008 >>> x11-drivers/xf86-input-void-1.1.1
     Thu Jan 10 17:05:28 2008 >>> x11-drivers/xf86-video-fbdev-0.3.1
     Thu Jan 10 17:05:56 2008 >>> x11-drivers/xf86-video-i810-2.1.1
     Thu Jan 10 17:06:08 2008 >>> x11-drivers/xf86-video-vesa-1.3.0
     Thu Jan 10 23:05:39 2008 >>> x11-drivers/xf86-input-evdev-1.1.5-r2
     Thu Jan 10 23:06:48 2008 >>> sys-apps/hal-0.5.9.1-r3
     Thu Jan 10 23:06:54 2008 >>> app-misc/hal-info-20070618


Just note the last three lines! They solved the problem!!!

Keep Walking! Cheers!
Back to top
View user's profile Send private message
Gergan Penkov
Veteran
Veteran


Joined: 17 Jul 2004
Posts: 1464
Location: das kleinste Kuhdorf Deutschlands :)

PostPosted: Fri Jan 11, 2008 12:32 am    Post subject: Reply with quote

The only question is how could hal be so broken?
My mouse was able to move itself only vertically...
Downgrading hal solved it....
_________________
"I knew when an angel whispered into my ear,
You gotta get him away, yeah
Hey little bitch!
Be glad you finally walked away or you may have not lived another day."
Godsmack
Back to top
View user's profile Send private message
renrutal
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2005
Posts: 135
Location: Brazil

PostPosted: Fri Jan 11, 2008 12:52 am    Post subject: Reply with quote

I had the layout problems, Insert was / and / was Insert, only letters worked... that's crazy!

Doing
Code:
echo '>=sys-apps/hal-0.5.10' >> /etc/portage/package.mask
emerge -1 hal
/etc/init.d/hald restart
/etc/init.d/xdm stop
/etc/init.d/xdm start

solved these keyboard problems.


Last edited by renrutal on Fri Jan 11, 2008 1:47 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 1 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum